Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / entr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
3 ;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages entr)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public entr
27 (package
28 (name "entr")
29 (version "3.6")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "http://entrproject.org/code/entr-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "1sy81np6kgmq04kfn2ckf4fp7jcf5d1963shgmapx3al3kc4c9x4"))))
37 (build-system gnu-build-system)
38 (arguments
39 `(#:test-target "test"
40 #:phases (modify-phases %standard-phases
41 (replace 'configure
42 (lambda* (#:key outputs #:allow-other-keys)
43 (let ((out (assoc-ref outputs "out")))
44 (setenv "CONFIG_SHELL" (which "bash"))
45 (setenv "CC" (which "gcc"))
46 (setenv "DESTDIR" (string-append out "/"))
47 (setenv "PREFIX" "")
48 (setenv "MANPREFIX" "man")
49 (zero? (system* "./configure")))))
50 (add-before 'build 'remove-fhs-file-names
51 (lambda _
52 ;; Use the tools available in $PATH.
53 (substitute* "entr.c"
54 (("/bin/cat") "cat")
55 (("/usr/bin/clear") "clear")))))))
56 (home-page "http://entrproject.org/")
57 (synopsis "Run arbitrary commands when files change")
58 (description
59 "entr is a zero-configuration tool with no external build or run-time
60 dependencies. The interface to entr is not only minimal, it aims to be simple
61 enough to create a new category of ad hoc automation. These micro-tests
62 reduce keystrokes, but more importantly they emphasize the utility of
63 automated checks.")
64
65 ;; Per 'LICENSE', portability code under missing/ is under BSD-2.
66 (license isc)))