Imported Debian patch 0.7.1-1
[hcoop/zz_old/debian/suphp.git] / debian / patches / 01_debian.dpatch
1 #! /bin/sh /usr/share/dpatch/dpatch-run
2 ## 01_debian.dpatch by <elacour@home-dn.net>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: Adapt to debian paths
6
7 @DPATCH@
8 --- ./doc/suphp.conf-example
9 +++ ./doc/suphp.conf-example
10 @@ -1,12 +1,12 @@
11 [global]
12 ;Path to logfile
13 -logfile=/var/log/suphp.log
14 +logfile=/var/log/suphp/suphp.log
15
16 ;Loglevel
17 loglevel=info
18
19 ;User Apache is running as
20 -webserver_user=wwwrun
21 +webserver_user=www-data
22
23 ;Path all scripts have to be in
24 docroot=/var/www:${HOME}/public_html
25 @@ -41,7 +41,7 @@ min_gid=100
26
27 [handlers]
28 ;Handler for php-scripts
29 -x-httpd-php="php:/usr/bin/php"
30 +application/x-httpd-suphp="php:/usr/bin/php-cgi"
31
32 ;Handler for CGI-scripts
33 x-suphp-cgi="execute:!self"