Import Debian patch 4.84.2-2+deb8u3
[hcoop/debian/exim4.git] / debian / patches / 35_install.dpatch
1 Description: Exim's installation scripts install the binary as
2 exim-<version> - disable this feature.
3 Author: Andreas Metzler <ametzler@debian.org>
4 Origin: vendor
5 Forwarded: not-needed
6 Last-Update: 2013-09-28
7
8 --- exim4-4.82~rc1.orig/scripts/exim_install
9 +++ exim4-4.82~rc1/scripts/exim_install
10 @@ -217,8 +217,9 @@ while [ $# -gt 0 ]; do
11 # The exim binary is handled specially
12
13 if [ $name = exim${EXE} ]; then
14 - version=exim-`./exim -bV -C /dev/null | \
15 - awk '/Exim version/ { OFS=""; print $3,"-",substr($4,2,length($4)-1) }'`${EXE}
16 + version=exim
17 +# version=exim-`./exim -bV -C /dev/null | \
18 +# awk '/Exim version/ { OFS=""; print $3,"-",substr($4,2,length($4)-1) }'`${EXE}
19
20 if [ "${version}" = "exim-${EXE}" ]; then
21 echo $com ""
22 @@ -368,10 +369,8 @@ done
23
24
25
26 -# If there is no configuration file, install the default, modifying it to refer
27 -# to the configured system aliases file. If there is no setting for
28 -# SYSTEM_ALIASES_FILE, use the traditional /etc/aliases. If the file does not
29 -# exist, install a default (dummy) for that too.
30 +# Install default configuration file
31 +# This is a local Debian modification.
32
33 # However, if CONFIGURE_FILE specifies a list of files, skip this code.
34
35 @@ -394,7 +393,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
36 ${real} ${MKDIR} -p `${DIRNAME} ${CONFIGURE_FILE}`
37
38 echo sed -e '\\'
39 - echo " \"/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'${ACTUAL_SYSTEM_ALIASES_FILE}'\"" '\\'
40 + echo " \"/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'/etc/aliases'\"" '\\'
41 echo " ../src/configure.default > \${CONFIGURE_FILE}"
42
43 # I can't find a way of writing this using the ${real} feature because
44 @@ -403,7 +402,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
45
46 if [ "$real" = "" ] ; then
47 sed -e \
48 - "/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'${ACTUAL_SYSTEM_ALIASES_FILE}'" \
49 + "/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'/etc/aliases'" \
50 ../src/configure.default > ${CONFIGURE_FILE}
51 else
52 true