Minimize spurious changes, so that we match debian more closely.
[hcoop/debian/courier-authlib.git] / courier-authlib.spec
index d599314..a02fbca 100644 (file)
@@ -1,18 +1,20 @@
-# $Id: courier-authlib.spec.in,v 1.8 2007/04/22 18:38:04 mrsam Exp $
+# $Id: courier-authlib.spec.in,v 1.14 2008/07/13 14:53:39 mrsam Exp $
 #
-# Copyright 1998 - 2006 Double Precision, Inc.  See COPYING for
+# Copyright 1998 - 2008 Double Precision, Inc.  See COPYING for
 # distribution information.
 
 # No dist tag from mock; detect mandrake, redhat, etc. the old fashioned way
 %if 0%{!?dist:1}
 %define courier_release %(test -e /etc/mandrake-release -o -e /etc/mandriva-release && release="mdk" ; if test $? != 0; then release="`rpm -q --queryformat='.rh%{VERSION}' redhat-release 2>/dev/null`" ; if test $? != 0 ; then release="`rpm -q --queryformat='.fc%{VERSION}' fedora-release 2>/dev/null`" ; if test $? != 0 ; then release="" ; fi ; fi ; fi ; echo "$release")
+%else
+%define courier_release %{nil}
 %endif
 
 ################################################################################
 
 Name:           courier-authlib
-Version:        0.59.3
-Release: 10%{courier_release}
+Version:        0.61.0
+Release:        1%{?dist}%{?courier_release}
 Summary:        Courier authentication library
 
 Group:          System Environment/Daemons
@@ -35,6 +37,7 @@ BuildRequires:      gdbm-devel
 BuildRequires:      pam-devel
 BuildRequires:      expect
 BuildRequires:      gcc-c++
+BuildRequires:     redhat-rpm-config
 
 BuildRequires:      %{_includedir}/ltdl.h
 
@@ -46,6 +49,13 @@ BuildRequires:      redhat-rpm-config
 Requires(post):     /sbin/chkconfig
 Requires(preun):    /sbin/chkconfig
 
+# Provides by symlinks in this release, for compatibility with 0.60,
+# will be removed in 0.62. This is temporary hack:
+
+%define dummysuffix %(test "%{_lib}" = "lib64" && echo '()(64bit)')
+
+Provides: libcourierauth.so.0%{dummysuffix} libcourierauthsasl.so.0%{dummysuffix} libcourierauthsaslclient.so.0%{dummysuffix} libcourierauthcommon.so.0%{dummysuffix}
+
 ################################################################################
 
 %description
@@ -137,7 +147,7 @@ program, then communicates through messages on stdin and stdout.
 %configure --with-redhat
 
 %build
-%{__make} %{_smp_mflags}
+%{__make} -s %{_smp_mflags}
 
 %install
 rm -rf $RPM_BUILD_ROOT