Imported Debian patch 0.59.3-1
[hcoop/debian/courier-authlib.git] / debian / courier-authlib-postgresql.postinst
diff --git a/debian/courier-authlib-postgresql.postinst b/debian/courier-authlib-postgresql.postinst
new file mode 100644 (file)
index 0000000..5de5e6c
--- /dev/null
@@ -0,0 +1,30 @@
+#! /bin/sh -e
+#
+# Copyright 2001,2005 by Stefan Hornburg (Racke) <racke@linuxia.de>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public
+# License along with this program; if not, write to the Free
+# Software Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA  02111-1307  USA.
+
+
+if [ "$1" = "configure" ]; then
+       if [ -z "$2" ]; then
+               # initial install of authpostgresql, we need to restart authdaemon
+               if [ -x /usr/sbin/authdaemond ]; then
+                       /usr/sbin/authdaemond restart
+               fi
+       fi
+fi
+
+#DEBHELPER#