update upstream sources
[clinton/guile-figl.git] / upstream-doc / spec / glx.spec
1 # THIS FILE IS OBSOLETE. Please migrate away from using the
2 # ".spec" files to the XML Registry. See
3 # http://www.opengl.org/registry/api/README.txt
4 # for more information.
5
6 # Copyright (c) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
7 # Copyright (c) 2006-2013 The Khronos Group, Inc.
8 #
9 # This document is licensed under the SGI Free Software B License Version
10 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
11 #
12 # $Revision: 21963 $ on $Date: 2013-06-13 02:52:31 -0700 (Thu, 13 Jun 2013) $
13
14 required-props:
15 param: retval retained
16 dlflags: notlistable handcode nop
17 glxflags: client-handcode server-handcode
18 glxvendorglx: *
19 vectorequiv: *
20 category: pixel-rw bgn-end display-list drawing drawing-control feedback framebuf misc modeling pixel-op pixel-rw state-req xform glx glxopcode
21 glxopcode: *
22
23 ###############################################################################
24 #
25 # GLX1.0 commands
26 #
27 ###############################################################################
28 Render()
29 return void
30 category glx
31 dlflags notlistable
32 glxflags client-handcode server-handcode
33 glxopcode 1
34
35
36 RenderLarge()
37 return void
38 category glx
39 dlflags notlistable
40 glxflags client-handcode server-handcode
41 glxopcode 2
42
43
44 CreateContext(gc_id, screen, visual, share_list)
45 return void
46 param gc_id Int32 in value
47 param screen Int32 in value
48 param visual Int32 in value
49 param share_list Int32 in value
50 glxflags client-handcode server-handcode
51 category glx
52 dlflags notlistable
53 glxopcode 3
54
55
56 DestroyContext(context)
57 return void
58 param context Int32 in value
59 glxflags client-handcode server-handcode
60 category glx
61 dlflags notlistable
62 glxopcode 4
63
64
65 MakeCurrent(drawable, context)
66 return void
67 param drawable Int32 in value
68 param context Int32 in value
69 glxflags client-handcode server-handcode
70 category glx
71 dlflags notlistable
72 glxopcode 5
73
74
75 IsDirect(dpy, context)
76 return void
77 param dpy Int32 in value
78 param context Int32 in value
79 glxflags client-handcode server-handcode
80 category glx
81 dlflags notlistable
82 glxopcode 6
83
84
85 QueryVersion(major, minor)
86 return void
87 param major Int32 out reference
88 param minor Int32 out reference
89 category glx
90 dlflags notlistable
91 glxflags client-handcode server-handcode
92 glxopcode 7
93
94
95 WaitGL(context)
96 return void
97 param context Int32 in value
98 category glx
99 dlflags notlistable
100 glxflags client-handcode server-handcode
101 glxopcode 8
102
103
104 WaitX()
105 return void
106 category glx
107 dlflags notlistable
108 glxflags client-handcode server-handcode
109 glxopcode 9
110
111
112 CopyContext(source, dest, mask)
113 return void
114 param source Int32 in value
115 param dest Int32 in value
116 param mask Int32 in value
117 category glx
118 dlflags notlistable
119 glxflags client-handcode server-handcode
120 glxopcode 10
121
122
123 SwapBuffers(drawable)
124 return void
125 param drawable Int32 in value
126 category glx
127 dlflags notlistable
128 glxflags client-handcode server-handcode
129 glxopcode 11
130
131
132 UseXFont(font, first, count, list_base)
133 return void
134 param font Int32 in value
135 param first Int32 in value
136 param count Int32 in value
137 param list_base Int32 in value
138 category glx
139 dlflags notlistable
140 glxflags client-handcode server-handcode
141 glxopcode 12
142
143
144 CreateGLXPixmap(visual, pixmap, glxpixmap)
145 return void
146 param visual Int32 in value
147 param pixmap Int32 in value
148 param glxpixmap Int32 in value
149 category glx
150 dlflags notlistable
151 glxflags client-handcode server-handcode
152 glxopcode 13
153
154 GetVisualConfigs()
155 return void
156 category glx
157 dlflags notlistable
158 glxflags client-handcode server-handcode
159 glxopcode 14
160
161
162 DestroyGLXPixmap(pixmap)
163 return void
164 param pixmap Int32 in value
165 glxflags client-handcode
166 category glx
167 dlflags notlistable
168 glxopcode 15
169
170
171 VendorPrivate()
172 return void
173 glxflags client-handcode server-handcode
174 category glx
175 dlflags notlistable
176 glxopcode 16
177
178
179 VendorPrivateWithReply()
180 return void
181 glxflags client-handcode server-handcode
182 category glx
183 dlflags notlistable
184 glxopcode 17
185
186 ###############################################################################
187 #
188 # GLX1.1 commands
189 #
190 ###############################################################################
191 QueryExtensionsString(screen)
192 return void
193 param screen Int32 in value
194 glxflags client-handcode server-handcode
195 category glx
196 dlflags notlistable
197 glxopcode 18
198
199 QueryServerString(screen, name)
200 return void
201 param screen Int32 in value
202 param name Int32 in value
203 glxflags client-handcode server-handcode
204 category glx
205 dlflags notlistable
206 glxopcode 19
207
208 ClientInfo()
209 return void
210 glxflags client-handcode server-handcode
211 category glx
212 dlflags notlistable
213 glxopcode 20
214
215 ###############################################################################
216 #
217 # GLX1.3 commands
218 #
219 ###############################################################################
220 GetFBConfigs()
221 return void
222 category glx
223 dlflags notlistable
224 glxflags client-handcode server-handcode
225 glxopcode 21
226
227 CreatePixmap(config, pixmap, glxpixmap)
228 return void
229 param config Int32 in value
230 param pixmap Int32 in value
231 param glxpixmap Int32 in value
232 dlflags notlistable
233 glxflags client-handcode server-handcode
234 category glx
235 glxopcode 22
236
237 DestroyPixmap(glxpixmap)
238 return void
239 param glxpixmap Int32 in value
240 dlflags notlistable
241 glxflags client-handcode server-handcode
242 category glx
243 glxopcode 23
244
245 CreateNewContext(config, render_type, share_list, direct)
246 return void
247 param config Int32 in value
248 param render_type Int32 in value
249 param share_list Int32 in value
250 param direct Int32 in value
251 dlflags notlistable
252 glxflags client-handcode server-handcode
253 category glx
254 glxopcode 24
255
256 QueryContext()
257 return void
258 dlflags notlistable
259 glxflags client-handcode server-handcode
260 category glx
261 glxopcode 25
262
263 MakeContextCurrent(drawable, readdrawable, context)
264 return void
265 param drawable Int32 in value
266 param readdrawable Int32 in value
267 param context Int32 in value
268 dlflags notlistable
269 glxflags client-handcode server-handcode
270 category glx
271 glxopcode 26
272
273 CreatePbuffer(config, pbuffer)
274 return void
275 param config Int32 in value
276 param pbuffer Int32 in value
277 dlflags notlistable
278 glxflags client-handcode server-handcode
279 category glx
280 glxopcode 27
281
282 DestroyPbuffer(pbuffer)
283 return void
284 param pbuffer Int32 in value
285 dlflags notlistable
286 glxflags client-handcode
287 category glx
288 glxopcode 28
289
290 GetDrawableAttributes(drawable)
291 return void
292 param drawable Int32 in value
293 dlflags notlistable
294 glxflags client-handcode server-handcode
295 category glx
296 glxopcode 29
297
298 ChangeDrawableAttributes(drawable)
299 return void
300 param drawable Int32 in value
301 dlflags notlistable
302 glxflags client-handcode server-handcode
303 category glx
304 glxopcode 30
305
306 CreateWindow(config, window, glxwindow)
307 return void
308 param config Int32 in value
309 param window Int32 in value
310 param glxwindow Int32 in value
311 dlflags notlistable
312 glxflags client-handcode server-handcode
313 category glx
314 glxopcode 31
315
316 DestroyWindow(glxwindow)
317 return void
318 param glxwindow Int32 in value
319 dlflags notlistable
320 glxflags client-handcode server-handcode
321 category glx
322 glxopcode 32
323
324 ###############################################################################
325 #
326 # IRIX5.3 extension commands
327 #
328 ###############################################################################
329
330 ###############################################################################
331 #
332 # SGI_swap_control extension commands
333 #
334 ###############################################################################
335 SwapIntervalSGI()
336 return void
337 glxflags client-handcode server-handcode
338 category glx
339 dlflags notlistable
340 glxvendorglx 65536
341
342 ###############################################################################
343 #
344 # IRIX5.3-PATCH154 extension commands
345 #
346 ###############################################################################
347
348 ###############################################################################
349 #
350 # SGI_make_current_read extension commands
351 #
352 ###############################################################################
353 MakeCurrentReadSGI(drawable, readdrawable, context)
354 return void
355 param drawable Int32 in value
356 param readdrawable Int32 in value
357 param context Int32 in value
358 glxflags client-handcode server-handcode
359 category glx
360 dlflags notlistable
361 glxvendorglx 65537
362
363 ###############################################################################
364 #
365 # SGIX_video_source extension commands
366 #
367 ###############################################################################
368 CreateGLXVideoSourceSGIX(dpy, screen, server, path, class, node)
369 return void
370 param dpy Int32 in value
371 param screen Int32 in value
372 param server Int32 in value
373 param path Int32 in value
374 param class Int32 in value
375 param node Int32 in value
376 glxflags client-handcode server-handcode
377 category glx
378 dlflags notlistable
379 glxvendorglx 65538
380
381 DestroyGLXVideoSourceSGIX(dpy, glxvideosource)
382 return void
383 param dpy Int32 in value
384 param glxvideosource Int32 in value
385 glxflags client-handcode server-handcode
386 category glx
387 dlflags notlistable
388 glxvendorglx 65539
389
390 ###############################################################################
391 #
392 # IRIX6.2 extension commands
393 #
394 ###############################################################################
395
396 ###############################################################################
397 #
398 # EXT_import_context extension commands
399 #
400 ###############################################################################
401 QueryContextInfoEXT()
402 return void
403 category glx
404 dlflags notlistable
405 glxflags client-handcode server-handcode
406 glxvendorglx 1024
407
408 ###############################################################################
409 #
410 # SGIX_fbconfig extension commands
411 #
412 ###############################################################################
413 GetFBConfigsSGIX()
414 return void
415 category glx
416 dlflags notlistable
417 glxflags client-handcode server-handcode
418 glxvendorglx 65540
419
420 CreateContextWithConfigSGIX(gc_id, screen, config, share_list)
421 return void
422 param gc_id Int32 in value
423 param screen Int32 in value
424 param config Int32 in value
425 param share_list Int32 in value
426 glxflags client-handcode server-handcode
427 category glx
428 dlflags notlistable
429 glxvendorglx 65541
430
431 CreateGLXPixmapWithConfigSGIX(config, pixmap, glxpixmap)
432 return void
433 param config Int32 in value
434 param pixmap Int32 in value
435 param glxpixmap Int32 in value
436 category glx
437 dlflags notlistable
438 glxflags client-handcode server-handcode
439 glxvendorglx 65542
440
441 ###############################################################################
442 #
443 # SGIX_pbuffer extension commands
444 #
445 ###############################################################################
446
447 CreateGLXPbufferSGIX(config, pbuffer)
448 return void
449 param config Int32 in value
450 param pbuffer Int32 in value
451 dlflags notlistable
452 glxflags client-handcode server-handcode
453 category glx
454 glxvendorglx 65543
455
456 DestroyGLXPbufferSGIX(pbuffer)
457 return void
458 param pbuffer Int32 in value
459 dlflags notlistable
460 glxflags client-handcode
461 category glx
462 glxvendorglx 65544
463
464 ChangeDrawableAttributesSGIX(drawable)
465 return void
466 param drawable Int32 in value
467 dlflags notlistable
468 glxflags client-handcode server-handcode
469 category glx
470 glxvendorglx 65545
471
472 GetDrawableAttributesSGIX(drawable)
473 return void
474 param drawable Int32 in value
475 dlflags notlistable
476 glxflags client-handcode server-handcode
477 category glx
478 glxvendorglx 65546
479
480 ###############################################################################
481 #
482 # SGIX_swap_group extension commands
483 #
484 ###############################################################################
485
486 JoinSwapGroupSGIX(window,group)
487 return void
488 param window Int32 in value
489 param group Int32 in value
490 glxflags client-handcode server-handcode
491 category glx
492 dlflags notlistable
493 glxvendorglx 65547
494
495 ###############################################################################
496 #
497 # SGIX_swap_barrier extension commands
498 #
499 ###############################################################################
500
501 BindSwapBarrierSGIX(window,barrier)
502 return void
503 param window Int32 in value
504 param barrier Int32 in value
505 glxflags client-handcode server-handcode
506 category glx
507 dlflags notlistable
508 glxvendorglx 65548
509
510 QueryMaxSwapBarriersSGIX()
511 return void
512 glxflags client-handcode server-handcode
513 category glx
514 dlflags notlistable
515 glxvendorglx 65549
516
517 ###############################################################################
518 #
519 # SGIX_hyperpipe extension commands
520 #
521 ###############################################################################
522
523 QueryHyperpipeNetworkSGIX(dpy, npipes)
524 return GLXHyperpipeNetworkSGIXPointer
525 param dpy Display out reference
526 param npipes int out reference
527 glxflags client-handcode server-handcode
528 category glx
529 dlflags notlistable
530 glxvendorglx 65550
531
532 HyperpipeConfigSGIX(dpy, networkId, npipes, cfg, hpId)
533 return int
534 param dpy Display out reference
535 param networkId int in value
536 param npipes int in value
537 param cfg GLXHyperpipeConfigSGIX in array[npipes]
538 param hpId int out reference
539 glxflags client-handcode server-handcode
540 category glx
541 dlflags notlistable
542 glxvendorglx 65552
543
544 QueryHyperpipeConfigSGIX(dpy, hpId, npipes)
545 return GLXHyperpipeConfigSGIXPointer
546 param dpy Display out reference
547 param hpId int in value
548 param npipes int out reference
549 glxflags client-handcode server-handcode
550 category glx
551 dlflags notlistable
552 glxvendorglx 65551
553
554 DestroyHyperpipeConfigSGIX(dpy, hpId)
555 return int
556 param dpy Display out reference
557 param hpId int in value
558 glxflags client-handcode server-handcode
559 category glx
560 dlflags notlistable
561 glxvendorglx 65553
562
563 BindHyperpipeSGIX(dpy, hpId)
564 return int
565 param dpy Display out reference
566 param hpId int in value
567 glxflags client-handcode server-handcode
568 category glx
569 dlflags notlistable
570 glxvendorglx ???
571
572 QueryHyperpipeBestAttribSGIX(dpy, timeSlice, attrib, size, attribList, returnAttribList)
573 return int
574 param dpy Display out reference
575 param timeSlice int in value
576 param attrib int in value
577 param size int in value
578 param attribList Void in array[size]
579 param returnAttribList Void out array[size]
580 glxflags client-handcode server-handcode
581 category glx
582 dlflags notlistable
583 glxvendorglx ???
584
585 HyperpipeAttribSGIX(dpy, timeSlice, attrib, size, attribList)
586 return int
587 param dpy Display out reference
588 param timeSlice int in value
589 param attrib int in value
590 param size int in value
591 param attribList void in array[size]
592 glxflags client-handcode server-handcode
593 category glx
594 dlflags notlistable
595 glxvendorglx ???
596
597 QueryHyperpipeAttribSGIX(dpy, timeSlice, attrib, size, returnAttribList)
598 return int
599 param dpy Display out reference
600 param timeSlice int in value
601 param attrib int in value
602 param size int in value
603 param returnAttribList void in array[size]
604 glxflags client-handcode server-handcode
605 category glx
606 dlflags notlistable
607 glxvendorglx ???