* apt-inst/contrib/extracttar.cc:
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
76
77 debian/shlibs.local: apt-pkg/makefile
78 # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
79 # one for the rest of the packages. This ensures that each package gets
80 # the right overrides…
81 rm -rf $@ $@.apt $@.apt-utils
82 echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
83
84 echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
85 echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
86
87 echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
88 echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
89
90 build: build/build-stamp
91 build-doc: build/build-doc-stamp
92
93 # Note that this is unconditionally done first as part of loading environment.mak
94 # The true is needed to force make to reload environment.mak after running
95 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
96 build/environment.mak: build/configure-stamp
97 @true
98
99 configure: configure.in
100 build/configure-stamp: configure
101 dh_testdir
102 -mkdir build
103 cp COPYING debian/copyright
104 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
105 touch $@
106
107 build/build-stamp: build/configure-stamp
108 # Add here commands to compile the package.
109 $(MAKE) binary
110 touch $@
111
112 build/build-doc-stamp: build/configure-stamp
113 # Add here commands to compile the package.
114 $(MAKE) doc
115 touch $@
116
117 clean:
118 dh_testdir
119
120 [ ! -f Makefile ] || $(MAKE) clean distclean
121 rm -rf build
122
123 # Add here commands to clean up after the build process.
124 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
125
126 binary-indep: apt-doc libapt-pkg-doc
127 # Build architecture-independent files here.
128 libapt-pkg-doc: build-doc debian/shlibs.local
129 dh_testdir -p$@
130 dh_testroot -p$@
131 dh_prep -p$@
132 dh_installdirs -p$@
133 #
134 # libapt-pkg-doc install
135 #
136 dh_installdocs -p$@ $(BLD)/docs/design* \
137 $(BLD)/docs/dpkg-tech* \
138 $(BLD)/docs/files* \
139 $(BLD)/docs/method* \
140 doc/libapt-pkg2_to_3.txt \
141 doc/style.txt \
142 $(BLD)/doc/doxygen/html
143 dh_installexamples -p$@
144
145 dh_installchangelogs -p$@
146 dh_strip -p$@
147 dh_compress -p$@
148 dh_fixperms -p$@
149 dh_installdeb -p$@
150 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
151 dh_md5sums -p$@
152 dh_builddeb -p$@
153
154 apt-doc: build-doc
155 dh_testdir -p$@
156 dh_testroot -p$@
157 dh_prep -p$@
158 #
159 # apt-doc install
160 #
161 # Copy the guides
162 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
163 $(BLD)/docs/guide*.html \
164 $(BLD)/docs/offline*.text \
165 $(BLD)/docs/offline*.html
166 dh_installchangelogs -p$@
167 dh_compress -p$@
168 dh_fixperms -p$@
169 dh_installdeb -p$@
170 dh_gencontrol -p$@
171 dh_md5sums -p$@
172 dh_builddeb -p$@
173
174
175
176 # Build architecture-dependent files here.
177
178 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
179 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
180 apt: build build-doc debian/shlibs.local
181 dh_testdir -p$@
182 dh_testroot -p$@
183 dh_prep -p$@
184 dh_installdirs -p$@
185 #
186 # apt install
187 #
188 cp $(BLD)/bin/apt-* debian/$@/usr/bin/
189
190 # Remove the bits that are in apt-utils
191 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
192
193 # install the shared libs
194 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
195 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
196
197 cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
198 # https has its own package
199 rm debian/$@/usr/lib/apt/methods/https
200
201 cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
202 cp -r $(BLD)/locale debian/$@/usr/share/
203
204 cp debian/bugscript debian/$@/usr/share/bug/apt/script
205 cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
206
207 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
208
209 # copy lintian override
210 cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
211
212 # make rosetta happy and remove pot files in po/ (but leave stuff
213 # in po/domains/* untouched) and cp *.po into each domain dir
214 rm -f build/po/*.pot
215 rm -f po/*.pot
216
217 # move the mirror failure script in place
218 #mv debian/$@/usr/bin/apt-report-mirror-failure \
219 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
220
221 dh_installexamples -p$@ $(BLD)/docs/examples/*
222 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
223 dh_installcron -p$@
224 dh_installdocs -p$@
225 dh_installchangelogs -p$@
226 dh_strip -p$@
227 dh_compress -p$@
228 dh_fixperms -p$@
229 dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
230 dh_installdeb -p$@
231 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
232 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
233 dh_md5sums -p$@
234 dh_builddeb -p$@
235
236 libapt-pkg-dev: build debian/shlibs.local
237 dh_testdir -p$@
238 dh_testroot -p$@
239 dh_prep -p$@
240 dh_installdirs -p$@
241 #
242 # libapt-pkg-dev install
243 #
244 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
245 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
246 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
247 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
248
249 dh_installdocs -p$@
250
251 dh_installchangelogs -p$@
252 dh_strip -p$@
253 dh_compress -p$@
254 dh_fixperms -p$@
255 dh_installdeb -p$@
256 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
257 dh_md5sums -p$@
258 dh_builddeb -p$@
259
260 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
261 apt-utils: build debian/shlibs.local
262 dh_testdir -p$@
263 dh_testroot -p$@
264 dh_prep -p$@
265 dh_installdirs -p$@
266
267 # install the shared libs
268 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
269 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
270
271 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
272 dh_installdocs -p$@
273 dh_installexamples -p$@
274
275 # Install the man pages..
276 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
277
278 dh_installchangelogs -p$@
279 dh_strip -p$@
280 dh_compress -p$@
281 dh_fixperms -p$@
282 dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
283 dh_installdeb -p$@
284 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
285 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
286 dh_md5sums -p$@
287 dh_builddeb -p$@
288
289 apt-transport-https: build debian/shlibs.local libapt-pkg-dev
290 dh_testdir -p$@
291 dh_testroot -p$@
292 dh_prep -p$@
293 dh_installdirs -p$@
294
295 # install the method
296 mkdir --parents debian/$@/usr/lib/apt/methods
297 cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
298
299 dh_installdocs -p$@ debian/apt-transport-https.README
300 dh_installexamples -p$@
301
302 # Install the man pages..
303 dh_installman -p$@
304
305 dh_installchangelogs -p$@
306 dh_strip -p$@
307 dh_compress -p$@
308 dh_fixperms -p$@
309 dh_installdeb -p$@
310 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
311 dh_gencontrol -p$@
312 dh_md5sums -p$@
313 dh_builddeb -p$@
314
315 configure:
316 $(MAKE) configure
317
318 really-clean: clean
319 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
320 find -name ChangeLog | xargs rm -f
321 rm -f l33ch-stamp
322
323 binary: binary-indep binary-arch
324 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local