merged from debian-sid
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which library package names to use
74 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
76
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
79
80 build: build/build-stamp
81 build-doc: build/build-doc-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.in
90 build/configure-stamp: configure
91 dh_testdir
92 -mkdir build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 # compat symlink for the locale split
101 mkdir -p build/usr/share
102 cd build/usr/share && ln -f -s ../../locale .
103 # done here
104 touch $@
105
106 build/build-doc-stamp: build/configure-stamp
107 # Add here commands to compile the package.
108 $(MAKE) doc
109 touch $@
110
111 clean:
112 dh_testdir
113
114 [ ! -f Makefile ] || $(MAKE) clean distclean
115 rm -rf build
116
117 binary-indep: apt-doc libapt-pkg-doc
118 # Build architecture-independent files here.
119 libapt-pkg-doc: build-doc
120 dh_testdir -p$@
121 dh_testroot -p$@
122 dh_prep -p$@
123 dh_installdirs -p$@
124 #
125 # libapt-pkg-doc install
126 #
127 # remove doxygen's embedded jquery as we don't use it anyway (#622147)
128 rm -f $(BLD)/doc/doxygen/html/jquery.js
129
130 dh_installdocs -p$@ $(BLD)/docs/design* \
131 $(BLD)/docs/dpkg-tech* \
132 $(BLD)/docs/files* \
133 $(BLD)/docs/method* \
134 doc/libapt-pkg2_to_3.txt \
135 doc/style.txt \
136 $(BLD)/doc/doxygen/html
137 dh_installexamples -p$@
138
139 dh_installchangelogs -p$@
140 dh_strip -p$@
141 dh_compress -p$@
142 dh_fixperms -p$@
143 dh_installdeb -p$@
144 dh_gencontrol -p$@
145 dh_md5sums -p$@
146 dh_builddeb -p$@
147
148 apt-doc: build-doc
149 dh_testdir -p$@
150 dh_testroot -p$@
151 dh_prep -p$@
152 #
153 # apt-doc install
154 #
155 # Copy the guides
156 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
157 $(BLD)/docs/guide*.html \
158 $(BLD)/docs/offline*.text \
159 $(BLD)/docs/offline*.html
160 dh_installchangelogs -p$@
161 dh_compress -p$@
162 dh_fixperms -p$@
163 dh_installdeb -p$@
164 dh_gencontrol -p$@
165 dh_md5sums -p$@
166 dh_builddeb -p$@
167
168
169
170 # Build architecture-dependent files here.
171
172 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
173 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
174 apt: build build-doc
175 dh_testdir -p$@
176 dh_testroot -p$@
177 dh_prep -p$@
178 dh_installdirs -p$@
179 #
180 # apt install
181 #
182 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
183
184 # make rosetta happy and remove pot files in po/ (but leave stuff
185 # in po/domains/* untouched) and cp *.po into each domain dir
186 rm -f build/po/*.pot
187 rm -f po/*.pot
188
189 dh_install -p$@ --sourcedir=$(BLD)
190
191 # Remove the bits that are in apt-utils
192 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
193
194 # https has its own package
195 rm debian/$@/usr/lib/apt/methods/https
196
197 # move the mirror failure script in place
198 #mv debian/$@/usr/bin/apt-report-mirror-failure \
199 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
200
201 dh_bugfiles -p$@
202 dh_lintian -p$@
203 dh_installexamples -p$@ $(BLD)/docs/examples/*
204 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
205 dh_installcron -p$@
206 dh_installdocs -p$@
207 dh_installchangelogs -p$@
208 dh_installlogrotate -p$@
209 dh_strip -p$@
210 dh_compress -p$@
211 dh_fixperms -p$@
212 dh_installdeb -p$@
213 dh_shlibdeps -p$@
214 dh_gencontrol -p$@
215 dh_md5sums -p$@
216 dh_builddeb -p$@
217
218 libapt-pkg-dev: build
219 dh_testdir -p$@
220 dh_testroot -p$@
221 dh_prep -p$@
222 dh_installdirs -p$@
223 #
224 # libapt-pkg-dev install
225 #
226 dh_install -p$@ --sourcedir=$(BLD)
227 dh_installdocs -p$@
228 dh_installchangelogs -p$@
229 dh_strip -p$@
230 dh_compress -p$@
231 dh_fixperms -p$@
232 dh_installdeb -p$@
233 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
234 dh_md5sums -p$@
235 dh_builddeb -p$@
236
237 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
238 apt-utils: build
239 dh_testdir -p$@
240 dh_testroot -p$@
241 dh_prep -p$@
242 dh_installdirs -p$@
243
244 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
245 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
246
247 dh_install -p$@ --sourcedir=$(BLD)
248 dh_link -p$@
249 dh_installdocs -p$@
250 dh_installexamples -p$@
251
252 # Install the man pages..
253 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
254
255 dh_installchangelogs -p$@
256 dh_strip -p$@
257 dh_compress -p$@
258 dh_fixperms -p$@
259 dh_makeshlibs -p$@
260 dh_installdeb -p$@
261 dh_shlibdeps -p$@
262 dh_gencontrol -p$@
263 dh_md5sums -p$@
264 dh_builddeb -p$@
265
266 $(LIBAPT_PKG): build
267 dh_testdir -p$@
268 dh_testroot -p$@
269 dh_prep -p$@
270 dh_installdirs -p$@
271
272 dh_install -p$@ --sourcedir=$(BLD)
273 dh_installdocs -p$@
274 dh_installchangelogs -p$@
275 dh_strip -p$@
276 dh_compress -p$@
277 dh_fixperms -p$@
278 dh_makeshlibs -p$@
279 dh_installdeb -p$@
280 dh_shlibdeps -p$@
281 dh_gencontrol -p$@
282 dh_md5sums -p$@
283 dh_builddeb -p$@
284
285 $(LIBAPT_INST): build
286 dh_testdir -p$@
287 dh_testroot -p$@
288 dh_prep -p$@
289 dh_installdirs -p$@
290
291 dh_install -p$@ --sourcedir=$(BLD)
292 dh_installdocs -p$@
293 dh_installchangelogs -p$@
294 dh_strip -p$@
295 dh_compress -p$@
296 dh_fixperms -p$@
297 dh_makeshlibs -p$@
298 dh_installdeb -p$@
299 dh_shlibdeps -p$@
300 dh_gencontrol -p$@
301 dh_md5sums -p$@
302 dh_builddeb -p$@
303
304 apt-transport-https: build libapt-pkg-dev
305 dh_testdir -p$@
306 dh_testroot -p$@
307 dh_prep -p$@
308 dh_installdirs -p$@
309
310 dh_install -p$@ --sourcedir=$(BLD)
311 dh_installdocs -p$@ debian/apt-transport-https.README
312 dh_installexamples -p$@
313
314 # Install the man pages..
315 dh_installman -p$@
316
317 dh_installchangelogs -p$@
318 dh_strip -p$@
319 dh_compress -p$@
320 dh_fixperms -p$@
321 dh_installdeb -p$@
322 dh_shlibdeps -p$@
323 dh_gencontrol -p$@
324 dh_md5sums -p$@
325 dh_builddeb -p$@
326
327 configure:
328 $(MAKE) configure
329
330 really-clean: clean
331 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
332 find -name ChangeLog | xargs rm -f
333 rm -f l33ch-stamp
334
335 binary: binary-indep binary-arch
336 .PHONY: build clean binary-indep binary-arch binary