initial version of apt-helper
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 # build in verbose mode by default to make it easy to diangose issues
7 export NOISY=1
8
9 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
10 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
11 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
12
13 # FOR AUTOCONF 2.52 AND NEWER ONLY
14 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
15 confflags += --build $(DEB_HOST_GNU_TYPE)
16 else
17 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
18 endif
19
20 # See below
21 -include build/environment.mak
22
23 ifneq (,$(shell which dpkg-buildflags))
24 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
25 export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
26 export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
27 else
28 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
29 export CXXFLAGS = -O0 -g -Wall
30 else
31 export CXXFLAGS = -O2 -g -Wall
32 endif
33 endif
34
35 # Default rule
36 build:
37
38 PKG=apt
39 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
40
41 # Determine the build directory to use
42 BASE=.
43 ifdef BUILD
44 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
45 else
46 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
47 endif
48 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
49 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
50 override BLD := $(BUILDX)
51
52 ifeq ($(words $(BLD)),0)
53 override BLD := ./build
54 endif
55
56 # APT Programs in apt-utils
57 APT_UTILS=ftparchive sortpkgs extracttemplates
58
59 # Uncomment this to turn on verbose mode.
60 #export DH_VERBOSE=1
61
62 # Find the libapt-pkg major version for use in other control files
63 include buildlib/libversion.mak
64
65 # Determine which library package names to use
66 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
67 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
68
69 # do not fail as we are just experimenting with symbol files for now
70 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
71
72 build-binary: build/build-binary-stamp
73 build-debiandoc: build/build-debiandoc-stamp
74 build-manpages: build/build-manpages-stamp
75
76 # Note that this is unconditionally done first as part of loading environment.mak
77 # The true is needed to force make to reload environment.mak after running
78 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
79 build/environment.mak: build/configure-stamp
80 @true
81
82 configure: configure.ac
83 build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
84 dh_testdir
85 -mkdir build
86 cp COPYING debian/copyright
87 cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
88 touch $@
89
90 build/build-binary-stamp: build/configure-stamp
91 # Add here commands to compile the package.
92 $(MAKE) binary
93 # compat symlink for the locale split
94 mkdir -p build/usr/share
95 cd build/usr/share && ln -f -s ../../locale .
96 # compile and run tests
97 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
98 $(MAKE) test
99 else
100 @echo "Tests DISABLED"
101 endif
102 touch $@
103
104 build/build-debiandoc-stamp: build/configure-stamp
105 # Add here commands to compile the package.
106 $(MAKE) debiandoc
107 touch $@
108
109 build/build-manpages-stamp: build/configure-stamp
110 # Add here commands to compile the package.
111 $(MAKE) manpages
112 touch $@
113
114 clean:
115 dh_testdir
116 dh_clean
117
118 [ ! -f Makefile ] || $(MAKE) clean distclean
119 rm -rf build
120 rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
121 debian/libapt-pkg-dev.install debian/apt.install
122 test ! -L buildlib/config.guess || rm -f buildlib/config.guess
123 test ! -L buildlib/config.sub || rm -f buildlib/config.sub
124
125 debian/%.install: debian/%.install.in
126 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
127
128 # Build architecture-independent files here.
129 libapt-pkg-doc: build-debiandoc
130 dh_testdir -p$@
131 dh_testroot -p$@
132 dh_prep -p$@
133 dh_installdirs -p$@
134 #
135 # libapt-pkg-doc install
136 #
137 rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
138 dh_installdocs -p$@ $(BLD)/docs/design* \
139 $(BLD)/docs/dpkg-tech* \
140 $(BLD)/docs/files* \
141 $(BLD)/docs/method* \
142 doc/libapt-pkg2_to_3.txt \
143 doc/style.txt \
144 $(BLD)/doc/doxygen/html
145 dh_installexamples -p$@
146
147 dh_installchangelogs -p$@
148 dh_strip -p$@
149 dh_compress -p$@ -X.xhtml
150 dh_fixperms -p$@
151 dh_installdeb -p$@
152 dh_gencontrol -p$@
153 dh_md5sums -p$@
154 dh_builddeb -p$@
155
156 apt-doc: build-debiandoc
157 dh_testdir -p$@
158 dh_testroot -p$@
159 dh_prep -p$@
160 #
161 # apt-doc install
162 #
163 # Copy the guides
164 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
165 $(BLD)/docs/guide*.html \
166 $(BLD)/docs/offline*.text \
167 $(BLD)/docs/offline*.html
168 dh_installchangelogs -p$@
169 dh_compress -p$@
170 dh_fixperms -p$@
171 dh_installdeb -p$@
172 dh_gencontrol -p$@
173 dh_md5sums -p$@
174 dh_builddeb -p$@
175
176
177
178 # Build architecture-dependent files here.
179
180 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
181 apt: build-binary build-manpages debian/apt.install
182 dh_testdir -p$@
183 dh_testroot -p$@
184 dh_prep -p$@
185 dh_installdirs -p$@
186 #
187 # apt install
188 #
189 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
190 cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
191 chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
192
193 # make rosetta happy and remove pot files in po/ (but leave stuff
194 # in po/domains/* untouched) and cp *.po into each domain dir
195 rm -f build/po/*.pot
196 rm -f po/*.pot
197
198 dh_install -p$@ --sourcedir=$(BLD)
199
200 # Remove the bits that are in apt-utils
201 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
202
203 # https has its own package
204 rm debian/$@/usr/lib/apt/methods/https
205
206 # move the mirror failure script in place
207 #mv debian/$@/usr/bin/apt-report-mirror-failure \
208 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
209
210 # move the apt-helper in place
211 mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
212
213 dh_bugfiles -p$@
214 dh_lintian -p$@
215 dh_installexamples -p$@ $(BLD)/docs/examples/*
216 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
217 dh_installcron -p$@
218 dh_installdocs -p$@
219 dh_installchangelogs -p$@
220 dh_installlogrotate -p$@
221 dh_strip -p$@
222 dh_compress -p$@
223 dh_fixperms -p$@
224 dh_makeshlibs -p$@
225 dh_installdeb -p$@
226 dh_shlibdeps -p$@
227 dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
228 dh_md5sums -p$@
229 dh_builddeb -p$@
230
231 libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
232 dh_testdir -p$@
233 dh_testroot -p$@
234 dh_prep -p$@
235 dh_installdirs -p$@
236 #
237 # libapt-pkg-dev install
238 #
239 dh_install -p$@ --sourcedir=$(BLD)
240 dh_installdocs -p$@
241 dh_installchangelogs -p$@
242 dh_strip -p$@
243 dh_compress -p$@
244 dh_fixperms -p$@
245 dh_installdeb -p$@
246 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
247 dh_md5sums -p$@
248 dh_builddeb -p$@
249
250 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
251 apt-utils: build-binary build-manpages
252 dh_testdir -p$@
253 dh_testroot -p$@
254 dh_prep -p$@
255 dh_installdirs -p$@
256
257 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
258 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
259 cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
260
261 dh_install -p$@ --sourcedir=$(BLD)
262 dh_link -p$@
263 dh_installdocs -p$@
264 dh_installexamples -p$@
265
266 # Install the man pages..
267 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
268
269 dh_installchangelogs -p$@
270 dh_strip -p$@
271 dh_compress -p$@
272 dh_fixperms -p$@
273 dh_makeshlibs -p$@
274 dh_installdeb -p$@
275 dh_shlibdeps -p$@
276 dh_gencontrol -p$@
277 dh_md5sums -p$@
278 dh_builddeb -p$@
279
280 $(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
281 dh_testdir -p$@
282 dh_testroot -p$@
283 dh_prep -p$@
284 dh_installdirs -p$@
285
286 dh_install -p$@ --sourcedir=$(BLD)
287 dh_installdocs -p$@
288 dh_installchangelogs -p$@
289 dh_strip -p$@
290 dh_compress -p$@
291 dh_fixperms -p$@
292 dh_makeshlibs -p$@
293 dh_installdeb -p$@
294 dh_shlibdeps -p$@
295 dh_gencontrol -p$@
296 dh_md5sums -p$@
297 dh_builddeb -p$@
298
299 $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
300 dh_testdir -p$@
301 dh_testroot -p$@
302 dh_prep -p$@
303 dh_installdirs -p$@
304
305 dh_install -p$@ --sourcedir=$(BLD)
306 dh_installdocs -p$@
307 dh_installchangelogs -p$@
308 dh_strip -p$@
309 dh_compress -p$@
310 dh_fixperms -p$@
311 dh_makeshlibs -p$@
312 dh_installdeb -p$@
313 dh_shlibdeps -p$@
314 dh_gencontrol -p$@
315 dh_md5sums -p$@
316 dh_builddeb -p$@
317
318 apt-transport-https: build-binary libapt-pkg-dev
319 dh_testdir -p$@
320 dh_testroot -p$@
321 dh_prep -p$@
322 dh_installdirs -p$@
323
324 dh_install -p$@ --sourcedir=$(BLD)
325 dh_installdocs -p$@ debian/apt-transport-https.README
326 dh_installexamples -p$@
327
328 # Install the man pages..
329 dh_installman -p$@
330
331 dh_installchangelogs -p$@
332 dh_strip -p$@
333 dh_compress -p$@
334 dh_fixperms -p$@
335 dh_installdeb -p$@
336 dh_shlibdeps -p$@
337 dh_gencontrol -p$@
338 dh_md5sums -p$@
339 dh_builddeb -p$@
340
341 buildlib/config.guess buildlib/config.sub:
342 $(MAKE) "$@"
343
344 configure:
345 $(MAKE) configure
346
347 # translate targets to targets required by debian-policy
348 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
349 binary-indep: apt-doc libapt-pkg-doc
350 binary: binary-indep binary-arch
351 build-arch: build-binary
352 build-indep: build-manpages build-debiandoc
353 build: build-indep build-arch
354
355 .PHONY: build clean binary-indep binary-arch binary