* debian/rules:
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
76
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
79
80 build: build/build-stamp
81 build-doc: build/build-doc-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.in
90 build/configure-stamp: configure
91 dh_testdir
92 -mkdir build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 touch $@
101
102 build/build-doc-stamp: build/configure-stamp
103 # Add here commands to compile the package.
104 $(MAKE) doc
105 touch $@
106
107 clean:
108 dh_testdir
109
110 [ ! -f Makefile ] || $(MAKE) clean distclean
111 rm -rf build
112
113 binary-indep: apt-doc libapt-pkg-doc
114 # Build architecture-independent files here.
115 libapt-pkg-doc: build-doc
116 dh_testdir -p$@
117 dh_testroot -p$@
118 dh_prep -p$@
119 dh_installdirs -p$@
120 #
121 # libapt-pkg-doc install
122 #
123 # remove doxygen's embedded jquery as we don't use it anyway (#622147)
124 rm -f $(BLD)/doc/doxygen/html/jquery.js
125
126 dh_installdocs -p$@ $(BLD)/docs/design* \
127 $(BLD)/docs/dpkg-tech* \
128 $(BLD)/docs/files* \
129 $(BLD)/docs/method* \
130 doc/libapt-pkg2_to_3.txt \
131 doc/style.txt \
132 $(BLD)/doc/doxygen/html
133 dh_installexamples -p$@
134
135 dh_installchangelogs -p$@
136 dh_strip -p$@
137 dh_compress -p$@
138 dh_fixperms -p$@
139 dh_installdeb -p$@
140 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
141 dh_md5sums -p$@
142 dh_builddeb -p$@
143
144 apt-doc: build-doc
145 dh_testdir -p$@
146 dh_testroot -p$@
147 dh_prep -p$@
148 #
149 # apt-doc install
150 #
151 # Copy the guides
152 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
153 $(BLD)/docs/guide*.html \
154 $(BLD)/docs/offline*.text \
155 $(BLD)/docs/offline*.html
156 dh_installchangelogs -p$@
157 dh_compress -p$@
158 dh_fixperms -p$@
159 dh_installdeb -p$@
160 dh_gencontrol -p$@
161 dh_md5sums -p$@
162 dh_builddeb -p$@
163
164
165
166 # Build architecture-dependent files here.
167
168 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
169 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
170 apt: build build-doc
171 dh_testdir -p$@
172 dh_testroot -p$@
173 dh_prep -p$@
174 dh_installdirs -p$@
175 #
176 # apt install
177 #
178 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
179
180 # make rosetta happy and remove pot files in po/ (but leave stuff
181 # in po/domains/* untouched) and cp *.po into each domain dir
182 rm -f build/po/*.pot
183 rm -f po/*.pot
184
185 dh_install -p$@ --sourcedir=$(BLD)
186
187 # Remove the bits that are in apt-utils
188 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
189
190 # https has its own package
191 rm debian/$@/usr/lib/apt/methods/https
192
193 # move the mirror failure script in place
194 #mv debian/$@/usr/bin/apt-report-mirror-failure \
195 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
196
197 dh_bugfiles -p$@
198 dh_lintian -p$@
199 dh_installexamples -p$@ $(BLD)/docs/examples/*
200 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
201 dh_installcron -p$@
202 dh_installdocs -p$@
203 dh_installchangelogs -p$@
204 dh_installlogrotate -p$@
205 dh_strip -p$@
206 dh_compress -p$@
207 dh_fixperms -p$@
208 dh_makeshlibs -p$@
209 dh_installdeb -p$@
210 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
211 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
212 dh_md5sums -p$@
213 dh_builddeb -p$@
214
215 libapt-pkg-dev: build
216 dh_testdir -p$@
217 dh_testroot -p$@
218 dh_prep -p$@
219 dh_installdirs -p$@
220 #
221 # libapt-pkg-dev install
222 #
223 dh_install -p$@ --sourcedir=$(BLD)
224 dh_installdocs -p$@
225 dh_installchangelogs -p$@
226 dh_strip -p$@
227 dh_compress -p$@
228 dh_fixperms -p$@
229 dh_installdeb -p$@
230 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
231 dh_md5sums -p$@
232 dh_builddeb -p$@
233
234 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
235 apt-utils: build
236 dh_testdir -p$@
237 dh_testroot -p$@
238 dh_prep -p$@
239 dh_installdirs -p$@
240
241 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
242
243 dh_install -p$@ --sourcedir=$(BLD)
244 dh_installdocs -p$@
245 dh_installexamples -p$@
246
247 # Install the man pages..
248 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
249
250 dh_installchangelogs -p$@
251 dh_strip -p$@
252 dh_compress -p$@
253 dh_fixperms -p$@
254 dh_makeshlibs -p$@
255 dh_installdeb -p$@
256 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
257 dh_gencontrol -p$@ -- -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
258 dh_md5sums -p$@
259 dh_builddeb -p$@
260
261 apt-transport-https: build libapt-pkg-dev
262 dh_testdir -p$@
263 dh_testroot -p$@
264 dh_prep -p$@
265 dh_installdirs -p$@
266
267 dh_install -p$@ --sourcedir=$(BLD)
268 dh_installdocs -p$@ debian/apt-transport-https.README
269 dh_installexamples -p$@
270
271 # Install the man pages..
272 dh_installman -p$@
273
274 dh_installchangelogs -p$@
275 dh_strip -p$@
276 dh_compress -p$@
277 dh_fixperms -p$@
278 dh_installdeb -p$@
279 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
280 dh_gencontrol -p$@
281 dh_md5sums -p$@
282 dh_builddeb -p$@
283
284 configure:
285 $(MAKE) configure
286
287 really-clean: clean
288 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
289 find -name ChangeLog | xargs rm -f
290 rm -f l33ch-stamp
291
292 binary: binary-indep binary-arch
293 .PHONY: build clean binary-indep binary-arch binary