Merge remote-tracking branch 'upstream/debian/sid' into bugfix/coverity
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
9
10 # FOR AUTOCONF 2.52 AND NEWER ONLY
11 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
12 confflags += --build $(DEB_HOST_GNU_TYPE)
13 else
14 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
15 endif
16
17 # See below
18 -include build/environment.mak
19
20 ifneq (,$(shell which dpkg-buildflags))
21 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
22 export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
23 export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
24 else
25 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26 export CXXFLAGS = -O0 -g -Wall
27 else
28 export CXXFLAGS = -O2 -g -Wall
29 endif
30 endif
31
32 # Default rule
33 build:
34
35 PKG=apt
36 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # APT Programs in apt-utils
54 APT_UTILS=ftparchive sortpkgs extracttemplates
55
56 # Uncomment this to turn on verbose mode.
57 #export DH_VERBOSE=1
58
59 # Find the libapt-pkg major version for use in other control files
60 include buildlib/libversion.mak
61
62 # Determine which library package names to use
63 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
64 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
65
66 # do not fail as we are just experimenting with symbol files for now
67 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
68
69 build-binary: build/build-binary-stamp
70 build-debiandoc: build/build-debiandoc-stamp
71 build-manpages: build/build-manpages-stamp
72
73 # Note that this is unconditionally done first as part of loading environment.mak
74 # The true is needed to force make to reload environment.mak after running
75 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
76 build/environment.mak: build/configure-stamp
77 @true
78
79 configure: configure.ac
80 build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
81 dh_testdir
82 -mkdir build
83 cp COPYING debian/copyright
84 cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
85 touch $@
86
87 build/build-binary-stamp: build/configure-stamp
88 # Add here commands to compile the package.
89 $(MAKE) binary
90 # compat symlink for the locale split
91 mkdir -p build/usr/share
92 cd build/usr/share && ln -f -s ../../locale .
93 # compile and run tests
94 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
95 $(MAKE) test
96 else
97 @echo "Tests DISABLED"
98 endif
99 touch $@
100
101 build/build-debiandoc-stamp: build/configure-stamp
102 # Add here commands to compile the package.
103 $(MAKE) debiandoc
104 touch $@
105
106 build/build-manpages-stamp: build/configure-stamp
107 # Add here commands to compile the package.
108 $(MAKE) manpages
109 touch $@
110
111 clean:
112 dh_testdir
113 dh_clean
114
115 [ ! -f Makefile ] || $(MAKE) clean distclean
116 rm -rf build
117 rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
118 debian/libapt-pkg-dev.install
119 test ! -L buildlib/config.guess || rm -f buildlib/config.guess
120 test ! -L buildlib/config.sub || rm -f buildlib/config.sub
121
122 debian/%.install: debian/%.install.in
123 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
124
125 # Build architecture-independent files here.
126 libapt-pkg-doc: build-debiandoc
127 dh_testdir -p$@
128 dh_testroot -p$@
129 dh_prep -p$@
130 dh_installdirs -p$@
131 #
132 # libapt-pkg-doc install
133 #
134 dh_installdocs -p$@ $(BLD)/docs/design* \
135 $(BLD)/docs/dpkg-tech* \
136 $(BLD)/docs/files* \
137 $(BLD)/docs/method* \
138 doc/libapt-pkg2_to_3.txt \
139 doc/style.txt \
140 $(BLD)/doc/doxygen/html
141 dh_installexamples -p$@
142
143 dh_installchangelogs -p$@
144 dh_strip -p$@
145 dh_compress -p$@
146 dh_fixperms -p$@
147 dh_installdeb -p$@
148 dh_gencontrol -p$@
149 dh_md5sums -p$@
150 dh_builddeb -p$@
151
152 apt-doc: build-debiandoc
153 dh_testdir -p$@
154 dh_testroot -p$@
155 dh_prep -p$@
156 #
157 # apt-doc install
158 #
159 # Copy the guides
160 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
161 $(BLD)/docs/guide*.html \
162 $(BLD)/docs/offline*.text \
163 $(BLD)/docs/offline*.html
164 dh_installchangelogs -p$@
165 dh_compress -p$@
166 dh_fixperms -p$@
167 dh_installdeb -p$@
168 dh_gencontrol -p$@
169 dh_md5sums -p$@
170 dh_builddeb -p$@
171
172
173
174 # Build architecture-dependent files here.
175
176 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
177 apt: build-binary build-manpages
178 dh_testdir -p$@
179 dh_testroot -p$@
180 dh_prep -p$@
181 dh_installdirs -p$@
182 #
183 # apt install
184 #
185 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
186 cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
187 chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
188
189 # make rosetta happy and remove pot files in po/ (but leave stuff
190 # in po/domains/* untouched) and cp *.po into each domain dir
191 rm -f build/po/*.pot
192 rm -f po/*.pot
193
194 dh_install -p$@ --sourcedir=$(BLD)
195
196 # Remove the bits that are in apt-utils
197 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
198
199 # https has its own package
200 rm debian/$@/usr/lib/apt/methods/https
201
202 # move the mirror failure script in place
203 #mv debian/$@/usr/bin/apt-report-mirror-failure \
204 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
205
206 dh_bugfiles -p$@
207 dh_lintian -p$@
208 dh_installexamples -p$@ $(BLD)/docs/examples/*
209 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
210 dh_installcron -p$@
211 dh_installdocs -p$@
212 dh_installchangelogs -p$@
213 dh_installlogrotate -p$@
214 dh_strip -p$@
215 dh_compress -p$@
216 dh_fixperms -p$@
217 dh_installdeb -p$@
218 dh_shlibdeps -p$@
219 dh_gencontrol -p$@
220 dh_md5sums -p$@
221 dh_builddeb -p$@
222
223 libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
224 dh_testdir -p$@
225 dh_testroot -p$@
226 dh_prep -p$@
227 dh_installdirs -p$@
228 #
229 # libapt-pkg-dev install
230 #
231 dh_install -p$@ --sourcedir=$(BLD)
232 dh_installdocs -p$@
233 dh_installchangelogs -p$@
234 dh_strip -p$@
235 dh_compress -p$@
236 dh_fixperms -p$@
237 dh_installdeb -p$@
238 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
239 dh_md5sums -p$@
240 dh_builddeb -p$@
241
242 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
243 apt-utils: build-binary build-manpages
244 dh_testdir -p$@
245 dh_testroot -p$@
246 dh_prep -p$@
247 dh_installdirs -p$@
248
249 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
250 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
251 cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
252
253 dh_install -p$@ --sourcedir=$(BLD)
254 dh_link -p$@
255 dh_installdocs -p$@
256 dh_installexamples -p$@
257
258 # Install the man pages..
259 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
260
261 dh_installchangelogs -p$@
262 dh_strip -p$@
263 dh_compress -p$@
264 dh_fixperms -p$@
265 dh_makeshlibs -p$@
266 dh_installdeb -p$@
267 dh_shlibdeps -p$@
268 dh_gencontrol -p$@
269 dh_md5sums -p$@
270 dh_builddeb -p$@
271
272 $(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
273 dh_testdir -p$@
274 dh_testroot -p$@
275 dh_prep -p$@
276 dh_installdirs -p$@
277
278 dh_install -p$@ --sourcedir=$(BLD)
279 dh_installdocs -p$@
280 dh_installchangelogs -p$@
281 dh_strip -p$@
282 dh_compress -p$@
283 dh_fixperms -p$@
284 dh_makeshlibs -p$@
285 dh_installdeb -p$@
286 dh_shlibdeps -p$@
287 dh_gencontrol -p$@
288 dh_md5sums -p$@
289 dh_builddeb -p$@
290
291 $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
292 dh_testdir -p$@
293 dh_testroot -p$@
294 dh_prep -p$@
295 dh_installdirs -p$@
296
297 dh_install -p$@ --sourcedir=$(BLD)
298 dh_installdocs -p$@
299 dh_installchangelogs -p$@
300 dh_strip -p$@
301 dh_compress -p$@
302 dh_fixperms -p$@
303 dh_makeshlibs -p$@
304 dh_installdeb -p$@
305 dh_shlibdeps -p$@
306 dh_gencontrol -p$@
307 dh_md5sums -p$@
308 dh_builddeb -p$@
309
310 apt-transport-https: build-binary libapt-pkg-dev
311 dh_testdir -p$@
312 dh_testroot -p$@
313 dh_prep -p$@
314 dh_installdirs -p$@
315
316 dh_install -p$@ --sourcedir=$(BLD)
317 dh_installdocs -p$@ debian/apt-transport-https.README
318 dh_installexamples -p$@
319
320 # Install the man pages..
321 dh_installman -p$@
322
323 dh_installchangelogs -p$@
324 dh_strip -p$@
325 dh_compress -p$@
326 dh_fixperms -p$@
327 dh_installdeb -p$@
328 dh_shlibdeps -p$@
329 dh_gencontrol -p$@
330 dh_md5sums -p$@
331 dh_builddeb -p$@
332
333 buildlib/config.guess buildlib/config.sub:
334 $(MAKE) "$@"
335
336 configure:
337 $(MAKE) configure
338
339 # translate targets to targets required by debian-policy
340 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
341 binary-indep: apt-doc libapt-pkg-doc
342 binary: binary-indep binary-arch
343 build-arch: build-binary
344 build-indep: build-manpages build-debiandoc
345 build: build-indep build-arch
346
347 .PHONY: build clean binary-indep binary-arch binary