Add option to apt-get to show versions of packages being
[ntk/apt.git] / debian / changelog
1 apt (0.5.4.9) unstable; urgency=low
2
3 * New deb version compare function, that has no integer limits, and
4 supports pre-versions using ~. Code ported from dpkg.
5 * Fix handling of [!arch] for build-dependencies. Closes: #88798, #149595
6 * Fix handling of build-deps on unknown packages. Closes: #88664, #153307
7 * "apt-get --arch-only build-dep" to install only architecture-
8 dependent build dependencies. Bump minor shared lib number to reflect
9 small change in BuildDepend API.
10 * APT::Build-Essential configuration option (defaults to "build-essential")
11 so that "apt-get build-dep" will ensure build essential packages are
12 installed prior to installing other build-dependencies. Closes: #148879
13 * LD_LIBRARY_PATH thing. Closes: #109430, #147529
14 * /usr/doc reference in postinst. Closes: #126189
15 * Doc updates. Closes: #120689
16 * Possible apt-cache segfault. Closes: #120311, #118431, #117915, #135295,
17 #131062, #136749
18 * Print special message for EAI_AGAIN. Closes: #131397
19 * libapt-pkg-dev needs to bring in the apt-inst library if linking
20 is to work. Closes: #133943
21 * Typos, Doc Stuff. Closes: #132772, #129970, #123642, #114892, #113786,
22 #109591, #105920, #103678, #139752, #138186, #138054, #138050,
23 #139994, #142955, #151654, #151834, #147611, #154268, #173971
24 * Fix possibility for tag file parsing to fail in some unlikely situations.
25 Closes: #139328
26 * Use std C++ names for some header files. Closes: #128741
27 * Do not check for free space if --no-download. Closes: #117856
28 * Actually implement or group handling for 'upgrade'. Closes: #133950
29 * "Internal Error, Couldn't configure pre-depend" is not actually an
30 internal error, it is a packaging error and now it says so, and
31 pinpoints the problem dependency. Closes: #155621
32 * Allows failure to write to a pipe for post-invoke stuff. Closes: #89830
33 * Use usr/share/doc for dhelp. Closes: #115701
34 * --print-uris works with 'update'. Closes: #57070
35 * Options Dpkg::MaxArgs,Dpkg::MaxArgBytes to allow a much longer dpkg
36 command line.
37 * Fixed 2 little OR group bugs, thanks to Yann Dirson. Closes: #143995,
38 #142298
39 * Allow an uninstalled package to be marked for removal on an install
40 line (meaning not to automatically install it), also fix some dodgy
41 handling of protected packages. Closes: #92287, #116011
42 * Fix errant prefix matching in version selection. Closes: #105968
43 * Ensure that all files needed to run APT as a user are readable and
44 ignore roots umask for these files. Closes: #108801
45 * Support larger config spaces. Closes: #111914
46 * 'apt-get update' no longer does 'Building Dependency Tree'.
47 * When matching regexs allways print a message. Change regex activation
48 charset. Closes: #147817
49 * Don't die if lines in sources.list are too long. Closes: #146846
50 * Show file name on apt-extracttemplate error messges. Closes: #151835
51 * i18n gettext stuff, based on work from Michael Piefel: Closes: #95933
52 * Some highly unlikely memory faults. Closes: #155842
53 * C++ stuff for G++3.2. Closes: #162617, #165515,
54 * apt-config dumps sends to stdout not stderr now. Closes: #146294
55 * Fix segfault in FindAny when /i is used, and there is no default.
56 Closes: #165891
57 * Add s390x to archtable. Closese: #160992.
58 * Update config.sub/config.guess in cvs, and add support to debian/rules
59 to update them from /usr/share/misc if they exist. Closes: #155014
60 * Remove 'Sorry' from messages. Closes: #148824.
61 * Change wording of 'additional disk space usage' message. Closes:
62 #135021.
63 * apt-extracttemplates now prepends the package name when extracting
64 files. Closes: #132776
65 * Add -n synonym for --names-only for apt-cache. Closes: #130689
66 * Display both current version and new version in apt-get -s. Closes:
67 #92358
68 * Add an options and timeout config item to ssh/rsh. Closes: #90654
69 * libapt-pkg-dev now depends on apt-utils. Closes: #133942.
70 * Change verbose logging output of apt-ftparchive to go to stderr,
71 instead of stdout. Also, errors that occur no longer go to stdout,
72 but stderr. Closes: #161592
73 * Test for timegm in configure. Closes: #165516.
74 * s/st_mtime/mtime/ on our local stat structure in apt-ftparchive, to
75 support compliation on platforms where st_mtime is a macro. Closes:
76 #165518
77 * Check the currently mounted cdrom, to see if it's the one we are
78 interested in. Closes: #154602
79 * Refer to reportbug instead of bug in the man pages. Closes: #173745
80 * Link apt-inst to apt-pkg. Closes: #175055
81 * New apt_preferences man page from Thomas Hood, Susan Kleinmann,
82 and others.
83 * Fix > 300 col screen segfault. Closes: #176052
84 * Rebuild with gcc-3.2. Closes: #177752, #178008.
85 * Fix build-dep handling of | dependencies.
86 Closes: #98640, #145997, #158896, #172901
87 * Double default value of APT::Cache-Limit, until such time as it
88 can be made more dynamic. Closes: #178623.
89 * Report uris with '.gz' when there are errors. Closes: #178435.
90 * When installing build-deps, make sure the new version will
91 satisfy build requirements. Closes: #178121
92 * Split offline and guide documentation into apt-doc. This was done so
93 that binary-arch builds do not require documention deps. Note, that
94 apt-doc is not installed on upgrades.
95 * Use doc-base, instead of dhelp directly. Closes: #110389
96 * Change http message 'Waiting for file' to 'Waiting for headers'.
97 Closes: #178537
98 * Remove trailing lines on package lists in apt-get. Closes: #178736.
99 * Fix origin pins for file:// uris. Closes: #189014.
100 * Apply typo and syntax patch from bug to apt-cache.8.sgml. Closes:
101 #155194
102 * s/dpkg-preconfig/dpkg-preconfigure/ in examples/configure-index.
103 Closes: #153734.
104 * Fix some typos in the apt-get manual. Closes: #163932.
105 * Apply patch from bug, to change frozen to testing, and then do it
106 everywhere else. Closes: #165085.
107 * Update es.po. Closes: #183111.
108 * Add pt_BR translation of apt_preferences(5). Also, build fr manpages.
109 Closes: #183904.
110 * Add a vcg command to apt-cache, similiar to dotty. Closes: #150512.
111 * Add option to apt-get to show versions of packages being
112 upgraded/installed.
113
114 -- Adam Heath <doogie@debian.org> Sun, 02 Feb 2003 02:54:45 -0600
115
116 apt (0.5.4) unstable; urgency=low
117
118 * M68k config.guess patch. Closes: #88913
119 * Bi-yearly test on OpenBSD and Solaris
120 * Doc updates. Closes: #89121, #89854, #99671, #98353, #95823, #93057,
121 #97520, #102867, #101071, #102421, #101565, #98272, #106914,
122 #105606, #105377
123 * Various cosmetic code updates. Closes: #89066, #89066, #89152
124 * Add "pre-auto" as an option for DSelect::Clean (run autoclean after
125 update).
126 * More patches from Alfredo for Vendors and more SHA-1 stuff
127 * Fix for AJ's 'desire to remove perl-5.005' and possibly other
128 similar situations. Closes: #56708, #59432
129 * no_proxy and ftp. Closes: #89671
130 * Philippe Batailler's man page patches.
131 * Fix for display bug. Closes: #92033, #93652, #98468
132 * Use more than 16bits for the dep ID. Some people ran out..
133 Closes: #103020, #97809, #102951, #99974, #107362, #107395, #107362,
134 #106911, #107395, #108968
135 * Reordered some things to make dante and FTP happier. Closes: #92757
136 * James R. Van Zandt's guide.sgml updates. Closes: #90027
137 * apt-ftparchive copes with no uncompressed package files + contents.
138 * French man pages from philippe batailler - well sort of. They
139 don't build yet..
140 * run-parts. Closes: #94286
141 * 'apt-cache policy' preferences debug tool.
142 * Whatever. Closes: #89762
143 * libstdc++ and HURD. Closes: #92025
144 * More apt-utils verbage. Closes: #86954
145 * Fliped comparision operator. Closes: #94618
146 * Used the right copyright file. Closes: #65691
147 * Randolph's G++3 patches.
148 * Fixed no_proxy tokanizing. Closes: #100046
149 * Strip Config-Version when copying status to available. Closes: #97520
150 * Segfault with missing source files. Closes: #100325
151 * EINTR check. Closes: #102293
152 * Various changes to the locking metholodgy for --print-uris.
153 Closes: #100590
154 * Lame LD_LIBRARY_PATH thing. Closes: #98928
155 * apt-cache search searchs provide names too now. Closes: #98695
156 * Checksum and long lines problem. Closes: #106591
157 * .aptignr and empty files are just a warning. Closes: #97364
158
159 -- Jason Gunthorpe <jgg@debian.org> Sat, 18 Aug 2001 17:21:59 -0500
160
161 apt (0.5.3) unstable; urgency=low
162
163 * JoeyH's dpkg::preconfig not working. Closes: #88675
164 * Fixed apt override disparity
165 * Alfredo's SHA-1 and related patches
166
167 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
168
169 apt (0.5.2) unstable; urgency=low
170
171 * Fixed mention of /usr/doc in the long description
172 * JoeyH's downgrade bug -- don't use 0.5.1
173 * Doc bug. Closes: #88538
174 * Fault in building release strings. Closes: #88533
175
176 -- Jason Gunthorpe <jgg@debian.org> Sun, 4 Mar 2001 15:39:43 -0700
177
178 apt (0.5.1) unstable; urgency=low
179
180 * Fixed #82894 again, or should be and.
181 * Process the option string right. Closes: #86921
182 * Don't eat the last command for pipes. Closes: #86923
183 * Ignore .* for configuration directory processing. Closes: #86923
184 * Alfredo's no_proxy patch
185 * Documentation fixes. Closes: #87091
186 * JoeyH's double slash bug. Closes: #87266
187 * Unintitialized buffer and apt-ftparchive contents generation.
188 Closes: #87612
189 * Build-deps on virtual packages. Closes: #87639
190 * Fixes glibc/libstdc++ symbol dependencies by including glibc and
191 libstdc++ version info in the library soname and in the package
192 provides. Closes: #87426
193 * Updated soname version to 0.3.2
194 * apt-extracttemplates moved from debconf into apt-utils
195 * s390 archtable entry. Closes: #88232
196 * Dan's segfault
197 * Some instances where the status file can source a package in a
198 non-sensical way. Closes: #87390
199 * Work better if there are duplicate sources.list entries.
200 * Fixed the resetting of Dir with "dir {};". Closes: #87323
201
202 -- Randolph Chung <tausq@debian.org> Sat, 3 Mar 2001 15:37:38 -0700
203
204 apt (0.5.0) unstable; urgency=low
205
206 * Fixed an obscure bug with missing final double new lines in
207 package files
208 * Changed the apt-cdrom index copy routine to use the new section
209 rewriter
210 * Added a package file sorter, apt-sortpkgs
211 * Parse obsolete Optional dependencies.
212 * Added Ben's rsh method. Closes: #57794
213 * Added IPv6 FTP support and better DNS rotation support.
214 * Include the server IP in error messages when using a DNS rotation.
215 Closes: #64895
216 * Made most of the byte counters into doubles to prevent 32bit overflow.
217 Closes: #65349
218 * HTTP Authorization. Closes: #61158
219 * Ability to parse and return source index build depends from Randolph.
220 * new 'apt-get build-dep' command from Randolph. Closes: #63982
221 * Added apt-ftparchive the all dancing all singing FTP archive
222 maintinance program
223 * Allow version specifications with =1.2.4-3 and /2.2 or /stable postfixes
224 in apt-get.
225 * Removed useless internal cruft including the xstatus file.
226 * Fixed config parser bugs. Closes: #67848, #71108
227 * Brain Damanged apt-get config options changed, does not change the command
228 line interface, except to allow --enable-* to undo a configuration
229 option:
230 No-Remove -> Remove
231 No-Download -> Download
232 No-Upgrade -> Upgrade
233 * Made this fix configable (DSelect::CheckDir) and default to disabled:
234 * No remove prompt if the archives dir has not changed. Closes: #55709
235 Because it is stupid in the case where no files were downloaded due to
236 a resumed-aborted install, or a full cache! Closes: #65952
237 * Obscure divide by zero problem. Closes: #64394
238 * Update sizetable for mips. Closes: #62288
239 * Fixed a bug with passive FTP connections
240 * Has sizetable entry for sparc64. Closes: #64869
241 * Escape special characters in the ::Label section of the cdroms.lst
242 * Created apt-utils and python-apt packages
243 * Due to the new policy engine, the available file may contain entries
244 from the status file. These are generated if the package is not obsolete
245 but the policy engine prohibits using the version from the package files.
246 They can be identified by the lack of a Filename field.
247 * The new policy engine. Closes: #66509, #66944, #45122, #45094, #40006,
248 #36223, #33468, #22551
249 * Fixed deb-src line for non-us. Closes: #71501, #71601
250 * Fixes for G++ 2.96, s/friend/friend class/
251 * Fixed mis doc of APT::Get::Fix-Missing. Closes: #69269
252 * Confirmed fix for missing new line problem. Closes: #69386
253 * Fixed up dhelp files. Closes: #71312
254 * Added some notes about dselect and offline usage. Closes: #66473, #38316
255 * Lock files on read only file systems are ignored w/ warning.
256 Closes: #61701
257 * apt-get update foo now gives an error! Closes: #42891
258 * Added test for shlibs on hurd. Closes: #71499
259 * Clarified apt-cache document. Closes: #71934
260 * DocBook SGML man pages and some improvements in the text..
261 * sigwinch thing. Closes: #72382
262 * Caching can be turned off by setting the cache file names blank.
263 * Ignores arches it does not know about when autocleaning. Closes: #72862
264 * New function in apt-config to return dirs, files, bools and integers.
265 * Fixed an odd litle bug in MarkInstall and fixed it up to handle
266 complex cases involving OR groups and provides.
267 68754 describes confusing messages which are the result of this..
268 Closes: #63149, #69394, #68754, #77683, #66806, #81486, #78712
269 * Speeling mistake and return code for the 'wicked' resolver error
270 Closes: #72621, #75226, #77464
271 * Solved unable to upgrade libc6 from potato to woody due to 3 package
272 libc6 dependency loop problem.
273 * Leading sources.list spaces. Closes: #76010
274 * Removed a possible infinite loop while processing installations.
275 * Man page updates. Closes: #75411, #75560, #64292, #78469
276 * ReduceSourceList bug. Closes: #76027
277 * --only-source option. Closes: #76320
278 * Typos. Closes: #77812, #77999
279 * Different status messages. Closes: #76652, #78353
280 * /etc/apt/apt.conf.d/ directory for Joey and Matt and pipe protocol 2
281 * OS detection an support for the new pseduo standard of os-arch for the
282 Architecture string. Also uses regexing.. Closes: #39227, #72349
283 * Various i18n stuff. Note that this still needs some i18n wizard
284 to do the last gettextization right. Closes: #62386
285 * Fixed a problem with some odd http servers/proxies that did not return
286 the content size in the header. Closes: #79878, #44379
287 * Little acquire bugs. Closes: #77029, #55820
288 * _POSIX_THREADS may not be defined to anything, just defined..
289 Closes: #78996
290 * Spelling of Ignore-Hold correctly. Closes: #78042
291 * Unlock the dpkg db if in download only mode. Closes: #84851
292 * Brendan O'Dea's dselect admindir stuff. Closes: #62811
293 * Patch from BenC. Closes: #80810
294 * Single output of some names in lists. Closes: #80498, #43286
295 * Nice message for people who can't read syserror output. Closes: #84734
296 * OR search function. Closes: #82894
297 * User's guide updates. Closes: #82469
298 * The AJ/JoeyH var/state to var/lib transition patch. Closes: #59094
299 * Various CD bugs, again thanks to Greenbush
300 Closes: #80946, #76547, #71810, #70049, #69482
301 * Using potato debhelper. Closes: #57977
302 * I cannot self-terminate. Closes: #74928
303
304 -- Jason Gunthorpe <jgg@debian.org> Wed, 21 Feb 2001 00:39:15 -0500
305
306 apt (0.3.19) frozen unstable; urgency=low
307
308 * Updates to apt-cdrom to support integrated non-us nicely, thanks to
309 Paul Wade.
310 * Fixed that apt-get/cdrom deadlock thing. Closes: #59853, #62945, #61976
311 * Fixed hardcoded path. Closes: #59743
312 * Fixed Jay's relative path bug
313 * Allowed source only CDs. Closes: #58952
314 * Space check is supressed if --print-uris is given. Closes: #58965
315 * Clarified the documenation examples for non-us. Closes: #58646
316 * Typo in the package description. Closes: #60230
317 * Man Page typo. Closes: #60347
318 * Typo in Algorithms.cc. Closes: #63577
319 * Evil dotty function in apt-cache for generating dependency graphs
320 with the as-yet-unpackaged GraphVis.
321 * Appears to have been fixed in Janurary.. Closes: #57981
322 * New config.guess/sub for the new archs. Closes: #60874
323 * Fixed error reporting for certain kinds of resolution failures.
324 Closes: #61327
325 * Made autoclean respect 'q' settings. Closes: #63023
326 * Fixed up the example sources.list. Closes: #63676
327 * Added DPkg::FlushSTDIN to control the flushing of stdin before
328 forking dpkg. Closes: #63991
329
330 -- Ben Gertzfield <che@debian.org> Fri, 12 May 2000 21:10:54 -0700
331
332 apt (0.3.18) frozen unstable; urgency=low
333
334 * Changes in the postinst script. Closes: #56855, #57237
335 * Fixed bashism. Closes: #57216, #57335
336 * Doc updates. Closes: #57772, #57069, #57331, #57833, #57896
337
338 -- Ben Gertzfield <che@debian.org> Sun, 13 Feb 2000 01:52:31 -0800
339
340 apt (0.3.17) unstable; urgency=low
341
342 * RFC 2732 usage for CDROM URIs and fixes to apt-cdrom
343 * Fixed the configuration parser to not blow up if ; is in the config
344 string
345 * Applied visual patch to dselect install script . Closes #55214
346 * Included the configure-index example
347 * Minimal CD swaps
348 * Library soname has increased
349 * Fixed default sources.list to have correct URLs for potato when it
350 becomes stable
351 * Added a message about erasing sources.list to dselect setup script
352 Closes: #55755
353 * No remove prompt if the archives dir has not changed. Closes: #55709
354 * Fixed inclusion of 2nd sample config file. Closes: #55374
355 * Made file mtimes of 0 not confuse the methods If-Modifed-Since check.
356 Closes: #55991
357
358 -- Ben Gertzfield <che@debian.org> Mon, 31 Jan 2000 12:12:40 -0800
359
360 apt (0.3.16) unstable; urgency=low
361
362 * Made --no-download work. Closes: #52993
363 * Now compiles on OpenBSD, Solaris and HP-UX
364 * Clarify segfault errors
365 * More debhelper fixes. Closes: #52662, #54566, #52090, #53531, #54769
366 * Fix for Joel's discovery of glibc removal behavoir.
367 * Fix for Ben Collins file: uri from slink upgrade.
368 * Fixed resume code in FTP. Closes: #54323
369 * Take more precautions to prevent the corruption Joey Hess saw.
370 * Fixed --no-list-cleanup
371 * RFC 2732 URI parsing ([] for hostnames).
372 * Typo in apt-cache man page. Closes: #54949
373
374 -- Ben Gertzfield <che@debian.org> Fri, 14 Jan 2000 08:04:15 -0800
375
376 apt (0.3.15) unstable; urgency=low
377
378 * Added DSelect::WaitAfterDownload Closes: #49549
379 * Fixed cast error in byteswap macro and supporting code. Closes: #50093
380 * Fixed buffer overflow for wide terminal sizes. Closes: #50295
381 * Made -s and clean not do anything. Closes: #50238
382 * Problem with Protected packages and the new OR code.
383 * /usr/share/doc stuff. Closes: #51017, #50228, #51141
384 * Remove doesn't require a package to be installable. Closes: #51175
385 * FTP proxy touch ups in the mabn page. Closes: #51315, #51314
386
387 -- Ben Gertzfield <che@debian.org> Sat, 4 Dec 1999 21:17:24 -0800
388
389 apt (0.3.14) unstable; urgency=low
390
391 * Fix Perl or group pre-depends thing Closes: #46091, #46096, #46233, #45901
392 * Fix handling of dpkg's conversions from < -> <= Closes: #46094, #47088
393 * Make unparsable priorities non-fatal Closes: #46266, #46267, #46293, #46298
394 * Fix handling of '/' for the dist name. Closes: #43830, #45640, #45692
395 * Fixed 'Method gave a blank filename' error from IMS queries onto CDs.
396 Closes: #45034, #45695, #46537
397 * Made OR group handling in the problem resolver more elaborate. Closes: #45646
398 * Added APT::Clean-Installed option. Closes: #45973
399 * Moves the free space check to after the calculated size is printed.
400 Closes: #46639, #47498
401 * mipsel arch Closes: #47614
402 * Beautified URI printing to not include passwords Closes: #46857
403 * Fixed little problem with --no-download Closes: #47557
404 * Tweaked Dselect 'update' script to re-gen the avail file even in the
405 event of a failure Closes: #47112
406 * Retries for source archives too Closes: #47529
407 * Unmounts CDROMs iff it mounted them Closes: #45299
408 * Checks for the partial directories before doing downloads Closes: #47392
409 * no_proxy environment variable (http only!) Closes: #43476
410 * apt-cache showsrc Closes: #45799
411 * De-Refs Single Pure virtual packages. Closes: #42437, #43555
412 * Regexs for install. Closes: #35304, #38835
413 * Dependency reports now show OR group relations
414 * Re-Install feature. Cloes: #46961, #37393, #38919
415 * Locks archive directory on clean (woops)
416 * Remove is not 'sticky'. Closes: #48392
417 * Slightly more accurate 'can not find package' message. Closes: #48311
418 * --trivial-only and --no-remove. Closes: #48518
419 * Increased the cache size. Closes: #47648
420 * Comment woopsie. Closes: #48789
421 * Removes existing links when linking sources. Closes: #48775
422 * Problem resolver does not install all virtual packages. Closes: #48591, #49252
423 * Clearer usage message about 'source' Closes: #48858
424 * Immediate configure internal error Closes: #49062, #48884
425
426 -- Ben Gertzfield <che@debian.org> Sun, 7 Nov 1999 20:21:25 -0800
427
428 apt (0.3.13) unstable; urgency=low
429
430 * Fix timestamp miss in FTP. Closes: #44363
431 * Fix sorting of Kept packages. Closes: #44377
432 * Fix Segfault for dselect-upgrade. Closes: #44436
433 * Fix handling of '/' for the dist name. Closes #43830
434 * Added APT::Get::Diff-Only and Tar-Only options. Closes #44384
435 * Add commented-out deb-src URI to default sources.list file.
436
437 -- Ben Gertzfield <che@debian.org> Sun, 19 Sep 1999 18:54:20 -0700
438
439 apt (0.3.12) unstable; urgency=low
440
441 * Fix for typo in the dhelp index. Closes: #40377
442 * Multiple media swap support
443 * Purge support. Closes: #33291, #40694
444 * Better handling of - remove notation. Closes: #41024
445 * Purge support. Closes: #33291, #40694
446 * Error code on failed update. Closes: #41053
447 * apt-cdrom adds entries for source directories. Closes: #41231
448 * Sorts the output of any list. Closes: #41107
449 * Fixes the looping problem. Closes: #41784, #42414, #44022
450 * Fixes the CRC mechanism to lowercase all strings. Closes: #41839
451 * More checks to keep the display sane. Particularly when fail-over is
452 used with local mirrors and CD-Roms. Closes: #42127, #43130, #43668
453 * PThread lockup problem on certain sparc/m68k. Closes: #40628
454 * apt-cdrom understands .gz Package files too. Closes: #42779
455 * Spelling error in dselect method description. Closes: #43251
456 * Added security to the default source list. Closes: #43356
457
458 -- Ben Gertzfield <che@debian.org> Fri, 3 Sep 1999 09:04:28 -0700
459
460 apt (0.3.11) unstable; urgency=low
461
462 * Fix for mis-parsed file: URIs. Closes: #40373, #40366, #40230
463 * Fix for properly upgrading the system from perl 5.004 to 5.005
464
465 -- Ben Gertzfield <che@debian.org> Mon, 28 Jun 1999 21:06:44 -0700
466
467 apt (0.3.9) unstable; urgency=low
468
469 * Spelling error in cachefile.cc. Closes: #39885
470 * Trailing slash in dselect install if you try to use the
471 default config file. Closes: #40011
472 * Simulate works for autoclean. Closes: #39141
473 * Fixed spelling errors. Closes: #39673
474 * Changed url parsing a bit. Closes: #40070, #40069
475 * Version 0.3.8 will be for slink/hamm (GNU libc 2).
476
477 -- Ben Gertzfield <che@debian.org> Thu, 24 Jun 1999 18:02:52 -0700
478
479 apt (0.3.7) unstable; urgency=low
480
481 * Fixed missing text in the apt-get(8) page. Closes: #37596
482 * Made --simulate and friends work with apt-get source. Closes: #37597, #37656
483 * Fixed inclusion of man pages in the -doc/-dev package. Closes: #37633, #38651
484 * Fixed handling of the -q option with not-entirely integer arguments
485 Closes: #37499
486 * Man page typo Closes: #37762
487 * Fixed parsing of the Source: line. Closes: #37679
488 * Dpkg/dpkg-hurd source bug. Closes: #38004, #38032
489 * Added a check for an empty cache directory. Closes: #37963
490 * Return a failure code if -d is given and packages fail to download.
491 Closes: #38127
492 * Arranged for an ftp proxy specifing an http server to work. See the
493 important note in the sources.list man page.
494 * Accounted for resumed files in the cps calculation. Closes: #36787
495 * Deal with duplicate same version different packages. Closes: #30237
496 * Added --no-download. Closes: #38095
497 * Order of apt-cdrom dist detection. Closes: #38139
498 * Fix apt-cdrom chop handling and missing lines. Closes: #37276
499 * IPv6 http support
500 * Suggests dpkg-dev for apt-get source. Closes: #38158
501 * Fixed typo in apt-get help. Closes: #38712
502 * Improved the error message in the case of broken held package. Closes: #38777
503 * Fixed handling of MD5 failures
504 * Documented list notation Closes: #39008
505 * Change the 'b' to 'B'. Closes: #39007
506
507 -- Ben Gertzfield <che@debian.org> Sun, 20 Jun 1999 18:36:20 -0700
508
509 apt (0.3.6) unstable; urgency=low
510
511 * Note that 0.3.5 never made it out the door..
512 * Fix for apt-cdrom and unusual disk label locations. Closes: #35571
513 * Made APT print numbers in decimal. Closes: #35617, #37319
514 * Buffer munching fix for FTP. Closes: #35868
515 * Typo in sample config file. Closes: #35907
516 * Fixed whitespace in version compares. Closes: #35968, #36283, #37051
517 * Changed installed size counter to only count unpacked packages.
518 Closes: #36201
519 * apt-get source support. Closes: #23934, #27190
520 * Renames .debs that fail MD5 checking, provides automatic corruption
521 recovery. Closes: #35931
522 * Fixed autoconf verison. Closes: #37305
523 * Random Segfaulting. Closes: #37312, #37530
524 * Fixed apt-cache man page. Closes: #36904
525 * Added a newline to apt-cache showpkg. Closes: #36903
526
527 -- Ben Gertzfield <che@debian.org> Wed, 12 May 1999 09:18:49 -0700
528
529 apt (0.3.4) unstable; urgency=low
530
531 * Release for Ben while he is out of town.
532 * Checked the size of partial files. Closes: #33705
533 * apt-get should not print progress on non-tty. Closes: #34944
534 * s/guide.text.gz/users-guide.txt.gz/ debian/control: Closes: #35207
535 * Applied cdrom patches from Torsten. Closes: #35140, #35141
536 * smbmounted cdrom fix. Closes: #35470
537 * Changed ie to eg. Closes: #35196
538
539 -- Adam Heath <doogie@debian.org> Sun, 4 Apr 1999 18:26:44 -0500
540
541 apt (0.3.3) unstable; urgency=low
542
543 * Fixes bug with file:/ URIs and multi-CD handling. Closes: #34923
544
545 -- Ben Gertzfield <che@debian.org> Tue, 23 Mar 1999 12:15:44 -0800
546
547 apt (0.3.2) unstable; urgency=low
548
549 * Major release into unstable of v3
550 * These bugs have been fixed, explanations are in the bug system, read
551 the man pages as well..
552 Closes: #21113, #22507, #22675, #22836, #22892, #32883, #33006, #34121,
553 #23984, #24685, #24799, #25001, #25019, #34223, #34296, #34355,
554 #24021, #25022, #25026, #25104, #25176, #31557, #31691, #31853,
555 #25458, #26019, #26433, #26592, #26670, #27100, #27100, #27601,
556 #28184, #28391, #28778, #29293, #29351, #27841, #28172, #30260,
557 #29382, #29441, #29903, #29920, #29983, #30027, #30076, #30112,
558 #31009, #31155, #31381, #31883, #32140, #32395, #32584. #34465,
559 #30383, #30441, #30472, #30643, #30827, #30324, #36425, #34596
560
561 -- Ben Gertzfield <che@debian.org> Mon, 15 Mar 1999 19:14:25 -0800
562
563 apt (0.3.1) experimental; urgency=low
564
565 * Minor release of cvs version.
566 * Added virtual package libapt-pkgx.x
567
568 -- Mitch Blevins <mblevin@debian.org> Wed, 10 Mar 1999 07:52:44 -0500
569
570 apt (0.3.0) experimental; urgency=low
571
572 * New experimental version.
573
574 -- Ben Gertzfield <che@debian.org> Tue, 15 Dec 1998 12:53:21 -0800
575
576 apt (0.1.9) frozen unstable; urgency=low
577
578 * Return to the wacky numbering for when we build 0.1.8 for hamm
579 * Important bug related to APT on the Alpha fixed
580 * apt-get dist-upgrade problems fixed
581 * tiny patch for http method to fix an endless loop
582 * nice fix from /usr/doc/lintian/ to remove rpath nastiness from
583 libtool and add proper shared lib dependancies
584 * now dh_shlibdeps is called with LD_LIBRARY_PATH=debian/tmp/usr/lib
585 in case an old libpkg is installed while building APT to prevent
586 spurious dependancies
587
588 -- Ben Gertzfield <che@debian.org> Thu, 5 Nov 1998 17:43:25 -0800
589
590 apt (0.1.7) unstable; urgency=low
591
592 * New build with libstdc++2.9.
593 * Various fixes; read the Changelog.
594
595 -- Ben Gertzfield <che@debian.org> Thu, 15 Oct 1998 18:29:18 -0700
596
597 apt (0.1.6) unstable; urgency=low
598
599 * Various fixes in the FTP method for error checking. Fixes: #26188.
600 * Spelling corrections in dselect method. Fixes: #25884
601 * Fixes for compilation on alpha/ppc. Fixes: #25313, #26108.
602 * No more bo releases: we're using a normal numbering system now.
603
604 -- Ben Gertzfield <che@debian.org> Tue, 8 Sep 1998 19:27:13 -0700
605
606 apt (0.1.5) unstable; urgency=low
607
608 * Changed sources.list to point to 'unstable' by default, as
609 'frozen' no longer exists!
610
611 -- Ben Gertzfield <che@debian.org> Thu, 23 Jul 1998 22:00:18 -0700
612
613 apt (0.1.3) unstable; urgency=low
614
615 * New upstreamish version.
616 * ftp method rewritten in C. Removes dependancies on all perl/perl
617 related modules. This fixes many of the ftp method bugs.
618
619 -- Ben Gertzfield <che@debian.org> Thu, 16 Jul 1998 22:19:00 -0700
620
621 apt (0.1.1) unstable; urgency=low
622
623 * Release for unstable.
624
625 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:48:30 -0700
626
627 apt (0.1) unstable; urgency=low
628
629 * Kludge to fix problem in libnet-perl with illegal anonymous
630 FTP passwords.
631 * Moved to unstable; apt is in a useable state now.
632 * Fixed version numbering. From now on, numbering will be:
633 0.1 (no actual release) -> 0.1.0bo (release for libc5) ->
634 0.1.1 (release for unstable). Thanks, Manoj.
635
636 -- Ben Gertzfield <che@debian.org> Tue, 30 Jun 1998 20:40:58 -0700
637
638 apt (0.0.17-1) experimental; urgency=low
639
640 * Fixed problem with libc6 version compare
641 * Scott's away for a while, so I'll be packaging apt for the time
642 being.
643
644 -- Ben Gertzfield <che@debian.org> Thu, 25 Jun 1998 19:02:03 -0700
645
646 apt (0.0.16-1) experimental; urgency=low
647
648 * Modifications to make apt-get more friendly when backgrounded.
649 * Updated documentation.
650 * Updates to graphic widgets
651
652 -- Scott K. Ellis <scott@debian.org> Mon, 8 Jun 1998 11:22:02 -0400
653
654 apt (0.0.15-0.2bo) experimental; urgency=low
655
656 * Bo compilation
657 * Bob Hilliards crash
658
659 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
660
661 apt (0.0.15-0.1bo) experimental; urgency=low
662
663 * Bo compilation
664 * libstdc++272 patch
665
666 -- Jason Gunthorpe <jgg@debian.org> Sun, 31 May 1998 20:18:35 -0600
667
668 apt (0.0.15) experimental; urgency=low
669
670 * Clean up source tarball (no user-visible changes)
671
672 -- Scott K. Ellis <scott@debian.org> Tue, 26 May 1998 12:23:53 -0400
673
674 apt (0.0.14) experimental; urgency=low
675
676 * Updates in ordering code to make sure certain upgrades work correctly.
677 * Made dselect/setup understand ftp as well as http
678
679 -- Scott K. Ellis <scott@debian.org> Wed, 20 May 1998 13:33:32 -0400
680
681 apt (0.0.13-bo1) experimental; urgency=low
682
683 * Bo compilation
684
685 -- Jason Gunthorpe <jgg@debian.org> Mon, 18 May 1998 15:10:49 -0600
686
687 apt (0.0.13) experimental; urgency=low
688
689 * Remove hardcoded egcc from debian/rules (#21575)
690 * Fixes for ordering logic when system has a number of unpacked
691 but unconfigured packages installed.
692 * Spelling fix in dselect install method (#22556)
693
694 -- Scott K. Ellis <scott@debian.org> Sun, 17 May 1998 20:08:33 -0400
695
696 apt (0.0.12) experimental; urgency=low
697
698 * Fixed problems with package cache corruption.
699 * Made to depend on libc6 >= 2.0.7pre1 due to timezone problems with
700 earlier versions.
701 * Interface and documentation improvements.
702
703 -- Scott K. Ellis <scott@debian.org> Sat, 16 May 1998 23:17:32 -0400
704
705 apt (0.0.11) experimental; urgency=low
706
707 * Change dependancies to pre-depends since breaking your packaging tools
708 in the middle of an installation isn't very good.
709 * Bug fixes to ftp method and general apt-get code
710
711 -- Scott K. Ellis <scott@debian.org> Fri, 15 May 1998 08:57:38 -0400
712
713 apt (0.0.10) experimental; urgency=low
714
715 * Run "dpkg --configure -a" after an aborted dselect install
716 * Fixed problem with install looping
717 * Support for authenticating proxys: (note this isn't terribly secure)
718 http_proxy="http://user:pass@firewall:port/"
719 * Substitute $ARCH in sources.list
720 * Fixes in the resumption code for ftp
721
722 -- Scott K. Ellis <scott@debian.org> Tue, 12 May 1998 09:14:41 -0400
723
724 apt (0.0.9) experimental; urgency=low
725
726 * Added ftp support.
727 * Various other less visible bug fixes.
728 * Fixed problem with segfault when apt-get invoked in a non-existant
729 directory (Bug #21863)
730 * Bumped policy to 2.4.1
731
732 -- Scott K. Ellis <scott@debian.org> Fri, 1 May 1998 09:18:19 -0400
733
734 apt (0.0.8) experimental; urgency=low
735
736 * Fixed generated available file (Bug #21836)
737 * Added download ETA (Bug #21774).
738 * Fixed hardcoded ARCH (Bug #21751).
739 * Fixed check on http_proxy (Bug #21795).
740 * Added download speed indicator.
741
742 -- Scott K. Ellis <scott@debian.org> Mon, 27 Apr 1998 10:58:32 -0400
743
744 apt (0.0.7) experimental; urgency=low
745
746 * Remove libdeity and apt from package for now, since only apt-get and
747 apt-cache are actually useful right now.
748 * Clean up handling of package installation errors.
749 * Added timeout to http transfers (#21269)
750 * Updated setup for dselect/apt method.
751 * Updated man pages
752 * Long options (added in 0.0.6)
753
754 -- Scott K. Ellis <scott@debian.org> Tue, 21 Apr 1998 09:06:49 -0400
755
756 apt (0.0.6) experimental; urgency=low
757
758 * Spelling changes.
759 * Revamped download status display.
760 * Call apt-get clean after successful install in dselect.
761 * Added "apt-get clean" which deletes package files from /var/cache/apt
762
763 -- Scott K. Ellis <scott@debian.org> Thu, 9 Apr 1998 15:13:59 -0400
764
765 apt (0.0.5) experimental; urgency=low
766
767 * Ignore signals while dpkg is running so we don't leave dpkg running in
768 the background (#20804)
769 * Check Packages as well as Packages.gz for file URIs (#20784)
770 * Spelling cleanup (#20800)
771 * Added -m option to permit upgrade to go on in the case of a bad mirror.
772 This option may result in incomplete upgrades when used with -f.
773
774 -- Scott K. Ellis <scott@debian.org> Tue, 7 Apr 1998 12:40:29 -0400
775
776 apt (0.0.4) experimental; urgency=low
777
778 * New usage guide.
779 * Various documentation updates and cleanup.
780 * Added '-f' option to apt-get attempt to fix broken dependancies.
781
782 -- Scott K. Ellis <scott@debian.org> Sat, 4 Apr 1998 14:36:00 -0500
783
784 apt (0.0.3) experimental; urgency=low
785
786 * Added a shlibs.local file to prevent apt from depending on itself.
787 * Updates to how apt-get handles bad states in installed packages.
788 * Updated rules to make sure build works from a freshly checked out source
789 archive. Building from CVS needs libtool/automake/autoconf, builds from
790 the distributed source package should have no such dependancy.
791
792 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 11:49:47 -0500
793
794 apt (0.0.2) unstable; urgency=low
795
796 * Updates to apt-get and http binding for dselect method (apt).
797 * Updating version number from 0.0.1, which was released only on IRC.
798
799 -- Scott K. Ellis <scott@debian.org> Fri, 3 Apr 1998 00:35:18 -0500
800
801 apt (0.0.1) unstable; urgency=low
802
803 * Initial Release.
804
805 -- Scott K. Ellis <scott@debian.org> Tue, 31 Mar 1998 12:49:28 -0500
806