merge with debian-sid 0.8.15.2
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which package we should provide in the control files
74 LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
76
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
79
80 build: build/build-stamp
81 build-doc: build/build-doc-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.in
90 build/configure-stamp: configure
91 dh_testdir
92 -mkdir build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 touch $@
101
102 build/build-doc-stamp: build/configure-stamp
103 # Add here commands to compile the package.
104 $(MAKE) doc
105 touch $@
106
107 clean:
108 dh_testdir
109
110 [ ! -f Makefile ] || $(MAKE) clean distclean
111 rm -rf build
112
113 binary-indep: apt-doc libapt-pkg-doc
114 # Build architecture-independent files here.
115 libapt-pkg-doc: build-doc
116 dh_testdir -p$@
117 dh_testroot -p$@
118 dh_prep -p$@
119 dh_installdirs -p$@
120 #
121 # libapt-pkg-doc install
122 #
123 dh_installdocs -p$@ $(BLD)/docs/design* \
124 $(BLD)/docs/dpkg-tech* \
125 $(BLD)/docs/files* \
126 $(BLD)/docs/method* \
127 doc/libapt-pkg2_to_3.txt \
128 doc/style.txt \
129 $(BLD)/doc/doxygen/html
130 dh_installexamples -p$@
131
132 dh_installchangelogs -p$@
133 dh_strip -p$@
134 dh_compress -p$@
135 dh_fixperms -p$@
136 dh_installdeb -p$@
137 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
138 dh_md5sums -p$@
139 dh_builddeb -p$@
140
141 apt-doc: build-doc
142 dh_testdir -p$@
143 dh_testroot -p$@
144 dh_prep -p$@
145 #
146 # apt-doc install
147 #
148 # Copy the guides
149 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
150 $(BLD)/docs/guide*.html \
151 $(BLD)/docs/offline*.text \
152 $(BLD)/docs/offline*.html
153 dh_installchangelogs -p$@
154 dh_compress -p$@
155 dh_fixperms -p$@
156 dh_installdeb -p$@
157 dh_gencontrol -p$@
158 dh_md5sums -p$@
159 dh_builddeb -p$@
160
161
162
163 # Build architecture-dependent files here.
164
165 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
166 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
167 apt: build build-doc
168 dh_testdir -p$@
169 dh_testroot -p$@
170 dh_prep -p$@
171 dh_installdirs -p$@
172 #
173 # apt install
174 #
175 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
176
177 # make rosetta happy and remove pot files in po/ (but leave stuff
178 # in po/domains/* untouched) and cp *.po into each domain dir
179 rm -f build/po/*.pot
180 rm -f po/*.pot
181
182 dh_install -p$@ --sourcedir=$(BLD)
183
184 # Remove the bits that are in apt-utils
185 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
186
187 # https has its own package
188 rm debian/$@/usr/lib/apt/methods/https
189
190 # move the mirror failure script in place
191 #mv debian/$@/usr/bin/apt-report-mirror-failure \
192 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
193
194 dh_bugfiles -p$@
195 dh_lintian -p$@
196 dh_installexamples -p$@ $(BLD)/docs/examples/*
197 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
198 dh_installcron -p$@
199 dh_installdocs -p$@
200 dh_installchangelogs -p$@
201 dh_installlogrotate -p$@
202 dh_strip -p$@
203 dh_compress -p$@
204 dh_fixperms -p$@
205 dh_makeshlibs -p$@
206 dh_installdeb -p$@
207 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
208 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
209 dh_md5sums -p$@
210 dh_builddeb -p$@
211
212 libapt-pkg-dev: build
213 dh_testdir -p$@
214 dh_testroot -p$@
215 dh_prep -p$@
216 dh_installdirs -p$@
217 #
218 # libapt-pkg-dev install
219 #
220 dh_install -p$@ --sourcedir=$(BLD)
221 dh_installdocs -p$@
222 dh_installchangelogs -p$@
223 dh_strip -p$@
224 dh_compress -p$@
225 dh_fixperms -p$@
226 dh_installdeb -p$@
227 dh_gencontrol -p$@ -- -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
228 dh_md5sums -p$@
229 dh_builddeb -p$@
230
231 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
232 apt-utils: build
233 dh_testdir -p$@
234 dh_testroot -p$@
235 dh_prep -p$@
236 dh_installdirs -p$@
237
238 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
239
240 dh_install -p$@ --sourcedir=$(BLD)
241 dh_installdocs -p$@
242 dh_installexamples -p$@
243
244 # Install the man pages..
245 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
246
247 dh_installchangelogs -p$@
248 dh_strip -p$@
249 dh_compress -p$@
250 dh_fixperms -p$@
251 dh_makeshlibs -p$@
252 dh_installdeb -p$@
253 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
254 dh_gencontrol -p$@ -- -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
255 dh_md5sums -p$@
256 dh_builddeb -p$@
257
258 apt-transport-https: build libapt-pkg-dev
259 dh_testdir -p$@
260 dh_testroot -p$@
261 dh_prep -p$@
262 dh_installdirs -p$@
263
264 dh_install -p$@ --sourcedir=$(BLD)
265 dh_installdocs -p$@ debian/apt-transport-https.README
266 dh_installexamples -p$@
267
268 # Install the man pages..
269 dh_installman -p$@
270
271 dh_installchangelogs -p$@
272 dh_strip -p$@
273 dh_compress -p$@
274 dh_fixperms -p$@
275 dh_installdeb -p$@
276 dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
277 dh_gencontrol -p$@
278 dh_md5sums -p$@
279 dh_builddeb -p$@
280
281 configure:
282 $(MAKE) configure
283
284 really-clean: clean
285 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
286 find -name ChangeLog | xargs rm -f
287 rm -f l33ch-stamp
288
289 binary: binary-indep binary-arch
290 .PHONY: build clean binary-indep binary-arch binary