enable APT in unpack/configure ordering to handle loops as well
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which library package names to use
74 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
76
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
79
80 build: build/build-stamp
81 build-doc: build/build-doc-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.in
90 build/configure-stamp: configure
91 dh_testdir
92 -mkdir build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 # compat symlink for the locale split
101 mkdir -p build/usr/share
102 cd build/usr/share && ln -f -s ../../locale .
103 # compile and run tests
104 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
105 $(MAKE) test
106 else
107 @echo "Tests DISABLED"
108 endif
109 touch $@
110
111 build/build-doc-stamp: build/configure-stamp
112 # Add here commands to compile the package.
113 $(MAKE) doc
114 touch $@
115
116 clean:
117 dh_testdir
118
119 [ ! -f Makefile ] || $(MAKE) clean distclean
120 rm -rf build
121
122 binary-indep: apt-doc libapt-pkg-doc
123 # Build architecture-independent files here.
124 libapt-pkg-doc: build-doc
125 dh_testdir -p$@
126 dh_testroot -p$@
127 dh_prep -p$@
128 dh_installdirs -p$@
129 #
130 # libapt-pkg-doc install
131 #
132 dh_installdocs -p$@ $(BLD)/docs/design* \
133 $(BLD)/docs/dpkg-tech* \
134 $(BLD)/docs/files* \
135 $(BLD)/docs/method* \
136 doc/libapt-pkg2_to_3.txt \
137 doc/style.txt \
138 $(BLD)/doc/doxygen/html
139 dh_installexamples -p$@
140
141 dh_installchangelogs -p$@
142 dh_strip -p$@
143 dh_compress -p$@
144 dh_fixperms -p$@
145 dh_installdeb -p$@
146 dh_gencontrol -p$@
147 dh_md5sums -p$@
148 dh_builddeb -p$@
149
150 apt-doc: build-doc
151 dh_testdir -p$@
152 dh_testroot -p$@
153 dh_prep -p$@
154 #
155 # apt-doc install
156 #
157 # Copy the guides
158 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
159 $(BLD)/docs/guide*.html \
160 $(BLD)/docs/offline*.text \
161 $(BLD)/docs/offline*.html
162 dh_installchangelogs -p$@
163 dh_compress -p$@
164 dh_fixperms -p$@
165 dh_installdeb -p$@
166 dh_gencontrol -p$@
167 dh_md5sums -p$@
168 dh_builddeb -p$@
169
170
171
172 # Build architecture-dependent files here.
173
174 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
175 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
176 apt: build build-doc
177 dh_testdir -p$@
178 dh_testroot -p$@
179 dh_prep -p$@
180 dh_installdirs -p$@
181 #
182 # apt install
183 #
184 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
185
186 # make rosetta happy and remove pot files in po/ (but leave stuff
187 # in po/domains/* untouched) and cp *.po into each domain dir
188 rm -f build/po/*.pot
189 rm -f po/*.pot
190
191 dh_install -p$@ --sourcedir=$(BLD)
192
193 # Remove the bits that are in apt-utils
194 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
195
196 # https has its own package
197 rm debian/$@/usr/lib/apt/methods/https
198
199 # move the mirror failure script in place
200 #mv debian/$@/usr/bin/apt-report-mirror-failure \
201 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
202
203 dh_bugfiles -p$@
204 dh_lintian -p$@
205 dh_installexamples -p$@ $(BLD)/docs/examples/*
206 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
207 dh_installcron -p$@
208 dh_installdocs -p$@
209 dh_installchangelogs -p$@
210 dh_installlogrotate -p$@
211 dh_strip -p$@
212 dh_compress -p$@
213 dh_fixperms -p$@
214 dh_installdeb -p$@
215 dh_shlibdeps -p$@
216 dh_gencontrol -p$@
217 dh_md5sums -p$@
218 dh_builddeb -p$@
219
220 libapt-pkg-dev: build
221 dh_testdir -p$@
222 dh_testroot -p$@
223 dh_prep -p$@
224 dh_installdirs -p$@
225 #
226 # libapt-pkg-dev install
227 #
228 dh_install -p$@ --sourcedir=$(BLD)
229 dh_installdocs -p$@
230 dh_installchangelogs -p$@
231 dh_strip -p$@
232 dh_compress -p$@
233 dh_fixperms -p$@
234 dh_installdeb -p$@
235 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
236 dh_md5sums -p$@
237 dh_builddeb -p$@
238
239 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
240 apt-utils: build
241 dh_testdir -p$@
242 dh_testroot -p$@
243 dh_prep -p$@
244 dh_installdirs -p$@
245
246 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
247 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
248
249 dh_install -p$@ --sourcedir=$(BLD)
250 dh_link -p$@
251 dh_installdocs -p$@
252 dh_installexamples -p$@
253
254 # Install the man pages..
255 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
256
257 dh_installchangelogs -p$@
258 dh_strip -p$@
259 dh_compress -p$@
260 dh_fixperms -p$@
261 dh_makeshlibs -p$@
262 dh_installdeb -p$@
263 dh_shlibdeps -p$@
264 dh_gencontrol -p$@
265 dh_md5sums -p$@
266 dh_builddeb -p$@
267
268 $(LIBAPT_PKG): build
269 dh_testdir -p$@
270 dh_testroot -p$@
271 dh_prep -p$@
272 dh_installdirs -p$@
273
274 dh_install -p$@ --sourcedir=$(BLD)
275 dh_installdocs -p$@
276 dh_installchangelogs -p$@
277 dh_strip -p$@
278 dh_compress -p$@
279 dh_fixperms -p$@
280 dh_makeshlibs -p$@
281 dh_installdeb -p$@
282 dh_shlibdeps -p$@
283 dh_gencontrol -p$@
284 dh_md5sums -p$@
285 dh_builddeb -p$@
286
287 $(LIBAPT_INST): build
288 dh_testdir -p$@
289 dh_testroot -p$@
290 dh_prep -p$@
291 dh_installdirs -p$@
292
293 dh_install -p$@ --sourcedir=$(BLD)
294 dh_installdocs -p$@
295 dh_installchangelogs -p$@
296 dh_strip -p$@
297 dh_compress -p$@
298 dh_fixperms -p$@
299 dh_makeshlibs -p$@
300 dh_installdeb -p$@
301 dh_shlibdeps -p$@
302 dh_gencontrol -p$@
303 dh_md5sums -p$@
304 dh_builddeb -p$@
305
306 apt-transport-https: build libapt-pkg-dev
307 dh_testdir -p$@
308 dh_testroot -p$@
309 dh_prep -p$@
310 dh_installdirs -p$@
311
312 dh_install -p$@ --sourcedir=$(BLD)
313 dh_installdocs -p$@ debian/apt-transport-https.README
314 dh_installexamples -p$@
315
316 # Install the man pages..
317 dh_installman -p$@
318
319 dh_installchangelogs -p$@
320 dh_strip -p$@
321 dh_compress -p$@
322 dh_fixperms -p$@
323 dh_installdeb -p$@
324 dh_shlibdeps -p$@
325 dh_gencontrol -p$@
326 dh_md5sums -p$@
327 dh_builddeb -p$@
328
329 configure:
330 $(MAKE) configure
331
332 really-clean: clean
333 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
334 find -name ChangeLog | xargs rm -f
335 rm -f l33ch-stamp
336
337 binary: binary-indep binary-arch
338 .PHONY: build clean binary-indep binary-arch binary