merged from http://bzr.debian.org/bzr/apt/apt/debian-sid
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
7 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
8
9 # FOR AUTOCONF 2.52 AND NEWER ONLY
10 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
11 confflags += --build $(DEB_HOST_GNU_TYPE)
12 else
13 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
14 endif
15
16 # See below
17 -include build/environment.mak
18
19 ifneq (,$(shell which dpkg-buildflags))
20 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
21 else
22 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
23 export CXXFLAGS = -O0 -g -Wall
24 else
25 export CXXFLAGS = -O2 -g -Wall
26 endif
27 endif
28
29 # Default rule
30 build:
31
32 PKG=apt
33 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
34 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
35 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
36 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
37
38 # Determine the build directory to use
39 BASE=.
40 ifdef BUILD
41 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
42 else
43 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
44 endif
45 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
46 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
47 override BLD := $(BUILDX)
48
49 ifeq ($(words $(BLD)),0)
50 override BLD := ./build
51 endif
52
53 # Rebuild configure.in to have the correct version from the change log
54 ifneq ($(APT_DEBVER),$(APT_CONFVER))
55 ifneq ($(APT_DEBVER),)
56 .PHONY: configure.in
57 configure.in:
58 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
59 endif
60 else
61 configure.in:
62 endif
63
64 # APT Programs in apt-utils
65 APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
66
67 # Uncomment this to turn on verbose mode.
68 #export DH_VERBOSE=1
69
70 # Find the libapt-pkg major version for use in other control files
71 include buildlib/libversion.mak
72
73 # Determine which library package names to use
74 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
75 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
76
77 # do not fail as we are just experimenting with symbol files for now
78 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
79
80 build: build/build-stamp
81 build-doc: build/build-doc-stamp
82
83 # Note that this is unconditionally done first as part of loading environment.mak
84 # The true is needed to force make to reload environment.mak after running
85 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
86 build/environment.mak: build/configure-stamp
87 @true
88
89 configure: configure.in
90 build/configure-stamp: configure
91 dh_testdir
92 -mkdir build
93 cp COPYING debian/copyright
94 cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
95 touch $@
96
97 build/build-stamp: build/configure-stamp
98 # Add here commands to compile the package.
99 $(MAKE) binary
100 # compat symlink for the locale split
101 mkdir -p build/usr/share
102 cd build/usr/share && ln -f -s ../../locale .
103 # done here
104 touch $@
105
106 build/build-doc-stamp: build/configure-stamp
107 # Add here commands to compile the package.
108 $(MAKE) doc
109 touch $@
110
111 clean:
112 dh_testdir
113
114 [ ! -f Makefile ] || $(MAKE) clean distclean
115 rm -rf build
116
117 binary-indep: apt-doc libapt-pkg-doc
118 # Build architecture-independent files here.
119 libapt-pkg-doc: build-doc
120 dh_testdir -p$@
121 dh_testroot -p$@
122 dh_prep -p$@
123 dh_installdirs -p$@
124 #
125 # libapt-pkg-doc install
126 #
127 dh_installdocs -p$@ $(BLD)/docs/design* \
128 $(BLD)/docs/dpkg-tech* \
129 $(BLD)/docs/files* \
130 $(BLD)/docs/method* \
131 doc/libapt-pkg2_to_3.txt \
132 doc/style.txt \
133 $(BLD)/doc/doxygen/html
134 dh_installexamples -p$@
135
136 dh_installchangelogs -p$@
137 dh_strip -p$@
138 dh_compress -p$@
139 dh_fixperms -p$@
140 dh_installdeb -p$@
141 dh_gencontrol -p$@
142 dh_md5sums -p$@
143 dh_builddeb -p$@
144
145 apt-doc: build-doc
146 dh_testdir -p$@
147 dh_testroot -p$@
148 dh_prep -p$@
149 #
150 # apt-doc install
151 #
152 # Copy the guides
153 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
154 $(BLD)/docs/guide*.html \
155 $(BLD)/docs/offline*.text \
156 $(BLD)/docs/offline*.html
157 dh_installchangelogs -p$@
158 dh_compress -p$@
159 dh_fixperms -p$@
160 dh_installdeb -p$@
161 dh_gencontrol -p$@
162 dh_md5sums -p$@
163 dh_builddeb -p$@
164
165
166
167 # Build architecture-dependent files here.
168
169 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
170 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
171 apt: build build-doc
172 dh_testdir -p$@
173 dh_testroot -p$@
174 dh_prep -p$@
175 dh_installdirs -p$@
176 #
177 # apt install
178 #
179 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
180
181 # make rosetta happy and remove pot files in po/ (but leave stuff
182 # in po/domains/* untouched) and cp *.po into each domain dir
183 rm -f build/po/*.pot
184 rm -f po/*.pot
185
186 dh_install -p$@ --sourcedir=$(BLD)
187
188 # Remove the bits that are in apt-utils
189 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
190
191 # https has its own package
192 rm debian/$@/usr/lib/apt/methods/https
193
194 # move the mirror failure script in place
195 #mv debian/$@/usr/bin/apt-report-mirror-failure \
196 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
197
198 dh_bugfiles -p$@
199 dh_lintian -p$@
200 dh_installexamples -p$@ $(BLD)/docs/examples/*
201 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
202 dh_installcron -p$@
203 dh_installdocs -p$@
204 dh_installchangelogs -p$@
205 dh_installlogrotate -p$@
206 dh_strip -p$@
207 dh_compress -p$@
208 dh_fixperms -p$@
209 dh_installdeb -p$@
210 dh_shlibdeps -p$@
211 dh_gencontrol -p$@
212 dh_md5sums -p$@
213 dh_builddeb -p$@
214
215 libapt-pkg-dev: build
216 dh_testdir -p$@
217 dh_testroot -p$@
218 dh_prep -p$@
219 dh_installdirs -p$@
220 #
221 # libapt-pkg-dev install
222 #
223 dh_install -p$@ --sourcedir=$(BLD)
224 dh_installdocs -p$@
225 dh_installchangelogs -p$@
226 dh_strip -p$@
227 dh_compress -p$@
228 dh_fixperms -p$@
229 dh_installdeb -p$@
230 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
231 dh_md5sums -p$@
232 dh_builddeb -p$@
233
234 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
235 apt-utils: build
236 dh_testdir -p$@
237 dh_testroot -p$@
238 dh_prep -p$@
239 dh_installdirs -p$@
240
241 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
242 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
243
244 dh_install -p$@ --sourcedir=$(BLD)
245 dh_link -p$@
246 dh_installdocs -p$@
247 dh_installexamples -p$@
248
249 # Install the man pages..
250 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
251
252 dh_installchangelogs -p$@
253 dh_strip -p$@
254 dh_compress -p$@
255 dh_fixperms -p$@
256 dh_makeshlibs -p$@
257 dh_installdeb -p$@
258 dh_shlibdeps -p$@
259 dh_gencontrol -p$@
260 dh_md5sums -p$@
261 dh_builddeb -p$@
262
263 $(LIBAPT_PKG): build
264 dh_testdir -p$@
265 dh_testroot -p$@
266 dh_prep -p$@
267 dh_installdirs -p$@
268
269 dh_install -p$@ --sourcedir=$(BLD)
270 dh_installdocs -p$@
271 dh_installchangelogs -p$@
272 dh_strip -p$@
273 dh_compress -p$@
274 dh_fixperms -p$@
275 dh_makeshlibs -p$@
276 dh_installdeb -p$@
277 dh_shlibdeps -p$@
278 dh_gencontrol -p$@
279 dh_md5sums -p$@
280 dh_builddeb -p$@
281
282 $(LIBAPT_INST): build
283 dh_testdir -p$@
284 dh_testroot -p$@
285 dh_prep -p$@
286 dh_installdirs -p$@
287
288 dh_install -p$@ --sourcedir=$(BLD)
289 dh_installdocs -p$@
290 dh_installchangelogs -p$@
291 dh_strip -p$@
292 dh_compress -p$@
293 dh_fixperms -p$@
294 dh_makeshlibs -p$@
295 dh_installdeb -p$@
296 dh_shlibdeps -p$@
297 dh_gencontrol -p$@
298 dh_md5sums -p$@
299 dh_builddeb -p$@
300
301 apt-transport-https: build libapt-pkg-dev
302 dh_testdir -p$@
303 dh_testroot -p$@
304 dh_prep -p$@
305 dh_installdirs -p$@
306
307 dh_install -p$@ --sourcedir=$(BLD)
308 dh_installdocs -p$@ debian/apt-transport-https.README
309 dh_installexamples -p$@
310
311 # Install the man pages..
312 dh_installman -p$@
313
314 dh_installchangelogs -p$@
315 dh_strip -p$@
316 dh_compress -p$@
317 dh_fixperms -p$@
318 dh_installdeb -p$@
319 dh_shlibdeps -p$@
320 dh_gencontrol -p$@
321 dh_md5sums -p$@
322 dh_builddeb -p$@
323
324 configure:
325 $(MAKE) configure
326
327 really-clean: clean
328 -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
329 find -name ChangeLog | xargs rm -f
330 rm -f l33ch-stamp
331
332 binary: binary-indep binary-arch
333 .PHONY: build clean binary-indep binary-arch binary