Merge remote-tracking branch 'mvo/feature/apt-update-info' into debian/sid
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5
6 # build in verbose mode by default to make it easy to diangose issues
7 export NOISY=1
8
9 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
10 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
11 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
12
13 # FOR AUTOCONF 2.52 AND NEWER ONLY
14 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
15 confflags += --build $(DEB_HOST_GNU_TYPE)
16 else
17 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
18 endif
19
20 # See below
21 -include build/environment.mak
22
23 ifneq (,$(shell which dpkg-buildflags))
24 export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
25 export LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
26 export CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
27 else
28 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
29 export CXXFLAGS = -O0 -g -Wall
30 else
31 export CXXFLAGS = -O2 -g -Wall
32 endif
33 endif
34
35 # Default rule
36 build:
37
38 PKG=apt
39 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
40
41 # Determine the build directory to use
42 BASE=.
43 ifdef BUILD
44 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
45 else
46 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
47 endif
48 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
49 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
50 override BLD := $(BUILDX)
51
52 ifeq ($(words $(BLD)),0)
53 override BLD := ./build
54 endif
55
56 # APT Programs in apt-utils
57 APT_UTILS=ftparchive sortpkgs extracttemplates
58
59 # Uncomment this to turn on verbose mode.
60 #export DH_VERBOSE=1
61
62 # Find the libapt-pkg major version for use in other control files
63 include buildlib/libversion.mak
64
65 # Determine which library package names to use
66 LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
67 LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
68
69 # do not fail as we are just experimenting with symbol files for now
70 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
71
72 build-binary: build/build-binary-stamp
73 build-debiandoc: build/build-debiandoc-stamp
74 build-manpages: build/build-manpages-stamp
75
76 # Note that this is unconditionally done first as part of loading environment.mak
77 # The true is needed to force make to reload environment.mak after running
78 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
79 build/environment.mak: build/configure-stamp
80 @true
81
82 configure: configure.ac
83 build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
84 dh_testdir
85 -mkdir build
86 cp COPYING debian/copyright
87 cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
88 touch $@
89
90 build/build-binary-stamp: build/configure-stamp
91 # Add here commands to compile the package.
92 $(MAKE) binary
93 # compat symlink for the locale split
94 mkdir -p build/usr/share
95 cd build/usr/share && ln -f -s ../../locale .
96 # compile and run tests
97 ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
98 $(MAKE) test
99 else
100 @echo "Tests DISABLED"
101 endif
102 touch $@
103
104 build/build-debiandoc-stamp: build/configure-stamp
105 # Add here commands to compile the package.
106 $(MAKE) debiandoc
107 touch $@
108
109 build/build-manpages-stamp: build/configure-stamp
110 # Add here commands to compile the package.
111 $(MAKE) manpages
112 touch $@
113
114 clean:
115 dh_testdir
116 dh_clean
117
118 [ ! -f Makefile ] || $(MAKE) clean distclean
119 rm -rf build
120 rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
121 debian/libapt-pkg-dev.install debian/apt.install
122 test ! -L buildlib/config.guess || rm -f buildlib/config.guess
123 test ! -L buildlib/config.sub || rm -f buildlib/config.sub
124
125 debian/%.install: debian/%.install.in
126 sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
127
128 # Build architecture-independent files here.
129 libapt-pkg-doc: build-debiandoc
130 dh_testdir -p$@
131 dh_testroot -p$@
132 dh_prep -p$@
133 dh_installdirs -p$@
134 #
135 # libapt-pkg-doc install
136 #
137 rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
138 dh_installdocs -p$@ $(BLD)/docs/design* \
139 $(BLD)/docs/dpkg-tech* \
140 $(BLD)/docs/files* \
141 $(BLD)/docs/method* \
142 doc/libapt-pkg2_to_3.txt \
143 doc/style.txt \
144 $(BLD)/doc/doxygen/html
145 dh_installexamples -p$@
146
147 dh_installchangelogs -p$@
148 dh_strip -p$@
149 dh_compress -p$@ -X.xhtml
150 dh_fixperms -p$@
151 dh_installdeb -p$@
152 dh_gencontrol -p$@
153 dh_md5sums -p$@
154 dh_builddeb -p$@
155
156 apt-doc: build-debiandoc
157 dh_testdir -p$@
158 dh_testroot -p$@
159 dh_prep -p$@
160 #
161 # apt-doc install
162 #
163 # Copy the guides
164 dh_installdocs -p$@ $(BLD)/docs/guide*.text \
165 $(BLD)/docs/guide*.html \
166 $(BLD)/docs/offline*.text \
167 $(BLD)/docs/offline*.html
168 dh_installchangelogs -p$@
169 dh_compress -p$@
170 dh_fixperms -p$@
171 dh_installdeb -p$@
172 dh_gencontrol -p$@
173 dh_md5sums -p$@
174 dh_builddeb -p$@
175
176
177
178 # Build architecture-dependent files here.
179
180 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
181 apt: build-binary build-manpages debian/apt.install
182 dh_testdir -p$@
183 dh_testroot -p$@
184 dh_prep -p$@
185 dh_installdirs -p$@
186 #
187 # apt install
188 #
189 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
190 cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
191 chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
192 # install vendor specific apt confs
193 find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
194
195 # make rosetta happy and remove pot files in po/ (but leave stuff
196 # in po/domains/* untouched) and cp *.po into each domain dir
197 rm -f build/po/*.pot
198 rm -f po/*.pot
199
200 dh_install -p$@ --sourcedir=$(BLD)
201
202 # Remove the bits that are in apt-utils
203 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
204
205 # https has its own package
206 rm debian/$@/usr/lib/apt/methods/https
207
208 # move the mirror failure script in place
209 #mv debian/$@/usr/bin/apt-report-mirror-failure \
210 # debian/$@/usr/lib/apt/apt-report-mirror-failure \
211
212 # move the apt-helper in place
213 mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
214
215 dh_bugfiles -p$@
216 dh_lintian -p$@
217 dh_installexamples -p$@ $(BLD)/docs/examples/*
218 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
219 dh_installcron -p$@
220 dh_installdocs -p$@
221 dh_installchangelogs -p$@
222 dh_installlogrotate -p$@
223 dh_strip -p$@
224 dh_compress -p$@
225 dh_fixperms -p$@
226 dh_makeshlibs -p$@
227 dh_installdeb -p$@
228 dh_shlibdeps -p$@
229 dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
230 dh_md5sums -p$@
231 dh_builddeb -p$@
232
233 libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
234 dh_testdir -p$@
235 dh_testroot -p$@
236 dh_prep -p$@
237 dh_installdirs -p$@
238 #
239 # libapt-pkg-dev install
240 #
241 dh_install -p$@ --sourcedir=$(BLD)
242 dh_installdocs -p$@
243 dh_installchangelogs -p$@
244 dh_strip -p$@
245 dh_compress -p$@
246 dh_fixperms -p$@
247 dh_installdeb -p$@
248 dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
249 dh_md5sums -p$@
250 dh_builddeb -p$@
251
252 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
253 apt-utils: build-binary build-manpages
254 dh_testdir -p$@
255 dh_testroot -p$@
256 dh_prep -p$@
257 dh_installdirs -p$@
258
259 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
260 cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
261 cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
262
263 dh_install -p$@ --sourcedir=$(BLD)
264 dh_link -p$@
265 dh_installdocs -p$@
266 dh_installexamples -p$@
267
268 # Install the man pages..
269 dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
270
271 dh_installchangelogs -p$@
272 dh_strip -p$@
273 dh_compress -p$@
274 dh_fixperms -p$@
275 dh_makeshlibs -p$@
276 dh_installdeb -p$@
277 dh_shlibdeps -p$@
278 dh_gencontrol -p$@
279 dh_md5sums -p$@
280 dh_builddeb -p$@
281
282 $(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
283 dh_testdir -p$@
284 dh_testroot -p$@
285 dh_prep -p$@
286 dh_installdirs -p$@
287
288 dh_install -p$@ --sourcedir=$(BLD)
289 dh_installdocs -p$@
290 dh_installchangelogs -p$@
291 dh_strip -p$@
292 dh_compress -p$@
293 dh_fixperms -p$@
294 dh_makeshlibs -p$@
295 dh_installdeb -p$@
296 dh_shlibdeps -p$@
297 dh_gencontrol -p$@
298 dh_md5sums -p$@
299 dh_builddeb -p$@
300
301 $(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
302 dh_testdir -p$@
303 dh_testroot -p$@
304 dh_prep -p$@
305 dh_installdirs -p$@
306
307 dh_install -p$@ --sourcedir=$(BLD)
308 dh_installdocs -p$@
309 dh_installchangelogs -p$@
310 dh_strip -p$@
311 dh_compress -p$@
312 dh_fixperms -p$@
313 dh_makeshlibs -p$@
314 dh_installdeb -p$@
315 dh_shlibdeps -p$@
316 dh_gencontrol -p$@
317 dh_md5sums -p$@
318 dh_builddeb -p$@
319
320 apt-transport-https: build-binary libapt-pkg-dev
321 dh_testdir -p$@
322 dh_testroot -p$@
323 dh_prep -p$@
324 dh_installdirs -p$@
325
326 dh_install -p$@ --sourcedir=$(BLD)
327 dh_installdocs -p$@ debian/apt-transport-https.README
328 dh_installexamples -p$@
329
330 # Install the man pages..
331 dh_installman -p$@
332
333 dh_installchangelogs -p$@
334 dh_strip -p$@
335 dh_compress -p$@
336 dh_fixperms -p$@
337 dh_installdeb -p$@
338 dh_shlibdeps -p$@
339 dh_gencontrol -p$@
340 dh_md5sums -p$@
341 dh_builddeb -p$@
342
343 buildlib/config.guess buildlib/config.sub:
344 $(MAKE) "$@"
345
346 configure:
347 $(MAKE) configure
348
349 # translate targets to targets required by debian-policy
350 binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
351 binary-indep: apt-doc libapt-pkg-doc
352 binary: binary-indep binary-arch
353 build-arch: build-binary
354 build-indep: build-manpages build-debiandoc
355 build: build-indep build-arch
356
357 .PHONY: build clean binary-indep binary-arch binary