* debian/rules:
[ntk/apt.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Christoph Lameter.
5 # $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
6
7 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
8 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
9
10 # For the deb builder, you can run 'debian/rules cvs-build', which does all
11 # steps nescessary to produce a proper source tarball with the CVS/ removed.
12 # It builds in debian/cvs-build/apt-<VER>/, and places files in
13 # debian/cvs-build/. Optionally, you can run 'debian/rules cvs-mkul' to
14 # create ../upload-<VER>, with all the files needed to be uploaded placed
15 # in it.
16
17 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
18 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
19
20 # FOR AUTOCONF 2.52 AND NEWER ONLY
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
26
27 # See below
28 -include build/environment.mak
29
30 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
31 export CXXFLAGS = -O0 -g -Wall
32 else
33 export CXXFLAGS = -O2 -g -Wall
34 endif
35
36 # Default rule
37 build:
38
39 PKG=apt
40 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
41 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
42 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
43 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
44
45 # Determine the build directory to use
46 BASE=.
47 ifdef BUILD
48 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
49 else
50 BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
51 endif
52 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
53 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
54 override BLD := $(BUILDX)
55
56 ifeq ($(words $(BLD)),0)
57 override BLD := ./build
58 endif
59
60 # Rebuild configure.in to have the correct version from the change log
61 ifneq ($(APT_DEBVER),$(APT_CONFVER))
62 ifneq ($(APT_DEBVER),)
63 .PHONY: configure.in
64 configure.in:
65 sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
66 endif
67 else
68 configure.in:
69 endif
70
71 # APT Programs in apt-utils
72 APT_UTILS=ftparchive sortpkgs extracttemplates
73
74 # Uncomment this to turn on verbose mode.
75 #export DH_VERBOSE=1
76
77 # Find the libapt-pkg major version for use in other control files
78 include buildlib/libversion.mak
79
80 # Determine which package we should provide in the control files
81 LIBAPTPKG_PROVIDE=libapt-pkg$(LIBEXT)-$(LIBAPTPKG_MAJOR)
82 LIBAPTINST_PROVIDE=libapt-inst$(LIBEXT)-$(LIBAPTINST_MAJOR)
83
84 debian/shlibs.local: apt-pkg/makefile
85 # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
86 # one for the rest of the packages. This ensures that each package gets
87 # the right overrides..
88 rm -rf $@ $@.apt $@.apt-utils
89 echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR)" > $@.apt
90
91 echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
92 echo "libapt-inst$(LIBEXT) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
93
94 echo "libapt-pkg$(LIBEXT) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
95 echo "libapt-inst$(LIBEXT) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
96
97 build: build/build-stamp
98 build-doc: build/build-doc-stamp
99
100 # Note that this is unconditionally done first as part of loading environment.mak
101 # The true is needed to force make to reload environment.mak after running
102 # configure-stamp. Otherwise we can get stale or invalid, or missing config data.
103 build/environment.mak: build/configure-stamp
104 @true
105
106 configure: configure.in
107 build/configure-stamp: configure
108 dh_testdir
109 -mkdir build
110 cp COPYING debian/copyright
111 cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
112 touch $@
113
114 build/build-stamp: build/configure-stamp
115 # Add here commands to compile the package.
116 $(MAKE) binary
117 touch $@
118
119 build/build-doc-stamp: build/configure-stamp
120 # Add here commands to compile the package.
121 $(MAKE) doc
122 touch $@
123
124 clean:
125 dh_testdir
126 # dh_testroot
127 [ -f Makefile ] && $(MAKE) clean
128 [ -f Makefile ] && $(MAKE) distclean
129
130 rm -rf build
131
132 # Add here commands to clean up after the build process.
133 dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
134
135 binary-indep: apt-doc libapt-pkg-doc
136 # Build architecture-independent files here.
137 libapt-pkg-doc: build-doc debian/shlibs.local
138 dh_testdir -p$@
139 dh_testroot -p$@
140 dh_clean -p$@ -k
141 dh_installdirs -p$@
142 #
143 # libapt-pkg-doc install
144 #
145 dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
146 $(BLD)/docs/files* $(BLD)/docs/method* \
147 doc/libapt-pkg2_to_3.txt doc/style.txt \
148 $(BLD)/doc/doxygen/html/*
149 dh_installexamples -p$@
150 # dh_installmenu -p$@
151 # dh_installinit -p$@
152 # dh_installcron -p$@
153 # dh_installman -p$@
154
155 # dh_undocumented -p$@
156 dh_installchangelogs -p$@
157 dh_strip -p$@
158 dh_compress -p$@
159 dh_fixperms -p$@
160 # dh_suidregister -p$@
161 dh_installdeb -p$@
162 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
163 dh_md5sums -p$@
164 dh_builddeb -p$@
165
166 apt-doc: build-doc
167 dh_testdir -p$@
168 dh_testroot -p$@
169 dh_clean -p$@ -k
170 #
171 # apt-doc install
172 #
173 # Copy the guides
174 dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
175 $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
176 dh_installchangelogs -p$@
177 dh_compress -p$@
178 dh_fixperms -p$@
179 dh_installdeb -p$@
180 dh_gencontrol -p$@
181 dh_md5sums -p$@
182 dh_builddeb -p$@
183
184
185
186 # Build architecture-dependent files here.
187
188 binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
189 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
190 apt: build build-doc debian/shlibs.local
191 dh_testdir -p$@
192 dh_testroot -p$@
193 dh_clean -p$@ -k
194 dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
195 #
196 # apt install
197 #
198 cp $(BLD)/bin/apt-* debian/$@/usr/bin/
199
200 # Remove the bits that are in apt-utils
201 rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
202
203 # install the shared libs
204 find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
205 find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
206
207 cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
208 # https has its own package
209 rm debian/$@/usr/lib/apt/methods/https
210
211 cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
212 cp -r $(BLD)/locale debian/$@/usr/share/
213
214 cp debian/bugscript debian/$@/usr/share/bug/apt/script
215 cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
216
217 cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
218 # head -n 500 ChangeLog > debian/ChangeLog
219
220 # copy lintian override
221 cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
222
223 # make rosetta happy and remove pot files in po/ (but leave stuff
224 # in po/domains/* untouched) and cp *.po into each domain dir
225 rm -f build/po/*.pot
226 rm -f po/*.pot
227
228 dh_installexamples -p$@ $(BLD)/docs/examples/*
229 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
230 dh_installcron -p$@
231 dh_installdocs -p$@
232 dh_installchangelogs -p$@
233 dh_strip -p$@
234 dh_compress -p$@
235 dh_fixperms -p$@
236 dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
237 dh_installdeb -p$@
238 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
239 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
240 dh_md5sums -p$@
241 dh_builddeb -p$@
242
243 libapt-pkg-dev: build debian/shlibs.local
244 dh_testdir -p$@
245 dh_testroot -p$@
246 dh_clean -p$@ -k
247 dh_installdirs -p$@
248 #
249 # libapt-pkg-dev install
250 #
251 cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
252 cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
253 # ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
254 cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
255
256 dh_installdocs -p$@
257 # dh_installmenu -p$@
258 # dh_installinit -p$@
259 # dh_installcron -p$@
260 # dh_installman -p$@
261
262 dh_installchangelogs -p$@
263 dh_strip -p$@
264 dh_compress -p$@
265 dh_fixperms -p$@
266 # dh_suidregister -p$@
267 dh_installdeb -p$@
268 dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
269 dh_md5sums -p$@
270 dh_builddeb -p$@
271
272 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
273 apt-utils: build debian/shlibs.local
274 dh_testdir -p$@
275 dh_testroot -p$@
276 dh_clean -p$@ -k
277 dh_installdirs -p$@
278
279 # install the shared libs
280 find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
281 find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
282
283 cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
284 dh_installdocs -p$@
285 dh_installexamples -p$@
286
287 # Install the man pages..
288 dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
289
290 dh_installchangelogs -p$@
291 dh_strip -p$@
292 dh_compress -p$@
293 dh_fixperms -p$@
294 dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
295 dh_installdeb -p$@
296 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
297 dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
298 dh_md5sums -p$@
299 dh_builddeb -p$@
300
301 apt-transport-https: build debian/shlibs.local libapt-pkg-dev
302 dh_testdir -p$@
303 dh_testroot -p$@
304 dh_clean -p$@ -k
305 dh_installdirs -p$@
306
307 # install the method
308 mkdir -p debian/$@/usr/lib/apt/methods
309 cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
310
311 dh_installdocs -p$@ debian/apt-transport-https.README
312 dh_installexamples -p$@
313
314 # Install the man pages..
315 dh_installman -p$@
316
317 dh_installchangelogs -p$@
318 dh_strip -p$@
319 dh_compress -p$@
320 dh_fixperms -p$@
321 dh_installdeb -p$@
322 dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib
323 dh_gencontrol -p$@
324 dh_md5sums -p$@
325 dh_builddeb -p$@
326
327 source diff:
328 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
329
330 # Update from CVS
331 l33ch: really-clean
332 cvs update
333 buildlib/mkChangeLog
334
335 # Update from CVS and then configure for build
336 super-l33ch: l33ch Makefile.in
337
338 configure:
339 $(MAKE) configure
340
341 l33ch-stamp: super-l33ch
342 touch $@
343
344 really-clean: clean
345 -find -name Makefile.in -print0 | xargs -0r rm -f
346 find -name ChangeLog | xargs rm -f
347 rm -f l33ch-stamp
348
349 binary: binary-indep binary-arch
350 .PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
351
352
353 # Done by the uploader.
354 #cvs update..
355 #edit debian/changelog
356 # configure.in has the version automatically updated now.
357 # edit configure.in
358 # debian/rules cvs-build
359
360 CVS_BUILDDIR=apt-$(APT_DEBVER)
361 CVS_ROOT=$(shell cat CVS/Root)
362 CVS_MODULE=$(shell cat CVS/Repository)
363 cvs-build:
364 rm -rf debian/cvs-build
365 mkdir -p debian/cvs-build
366 (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
367 $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
368 (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
369
370 cvs-mkul:
371 -mkdir -p ../upload-$(APT_DEBVER)
372 cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
373
374 arch-build:
375 rm -rf debian/arch-build
376 mkdir -p debian/arch-build/apt-$(APT_DEBVER)
377 tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
378 $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
379 (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)