gnu: Add python-doc8.
[jackhill/guix/guix.git] / gnu / packages / upnp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
3 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
4 ;;; Copyright © 2016, 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
6 ;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages upnp)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages gettext)
26 #:use-module (gnu packages autotools)
27 #:use-module (gnu packages video)
28 #:use-module (gnu packages photo)
29 #:use-module (gnu packages image)
30 #:use-module (gnu packages mp3)
31 #:use-module (gnu packages xiph)
32 #:use-module (gnu packages sqlite)
33 #:use-module (gnu packages python)
34 #:use-module (guix build-system gnu)
35 #:use-module (guix utils)
36 #:use-module (guix download)
37 #:use-module (guix git-download)
38 #:use-module (guix licenses)
39 #:use-module (guix packages)
40 #:use-module (ice-9 match))
41
42 (define-public miniupnpc
43 (package
44 (name "miniupnpc")
45 (version "2.1.20191224")
46 (source
47 (origin
48 (method url-fetch)
49 (uri (string-append "https://miniupnp.tuxfamily.org/files/"
50 "miniupnpc-" version ".tar.gz"))
51 (sha256
52 (base32 "1kv6dpj93gckvwvgzxl4vdqpwnicb0c8p0xw53m2gh5naiw44ys4"))))
53 (build-system gnu-build-system)
54 (native-inputs
55 `(("python" ,python-2)))
56 (arguments
57 ;; The build system does not use a configure script but depends on
58 ;; `make'. Hence we should pass parameters to `make' instead and remove
59 ;; the configure phase.
60 '(#:make-flags
61 (list
62 (string-append "SH=" (assoc-ref %build-inputs "bash") "/bin/sh")
63 (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
64 "CC=gcc"
65
66 ;; Allow executables to find libminiupnpc.so.
67 (string-append "LDFLAGS=-Wl,-rpath="
68 (assoc-ref %outputs "out") "/lib"))
69 #:phases
70 (modify-phases %standard-phases
71 (delete 'configure)
72 (add-before 'install 'qualify-paths
73 (lambda* (#:key outputs #:allow-other-keys)
74 (substitute* "external-ip.sh"
75 (("upnpc")
76 (string-append (assoc-ref outputs "out") "/bin/upnpc")))
77 #t)))))
78 (home-page "http://miniupnp.free.fr/")
79 (synopsis "UPnP protocol client library")
80 (description
81 "The MiniUPnPc client library facilitates access to the services provided
82 by any @dfn{Universal Plug and Play} (UPnP) @dfn{Internet Gateway Device} (IGD)
83 present on the network. In UPnP terminology, MiniUPnPc is a UPnP Control Point.
84
85 It is useful whenever an application needs to listen for incoming connections
86 while running behind a UPnP-enabled router or firewall. Such applications
87 include peer-to-peer applications, active-mode FTP clients, DCC file transfers
88 over IRC, instant messaging, network games, and most server software.")
89 (license
90 (x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))
91
92 (define-public libupnp
93 (package
94 (name "libupnp")
95 (version "1.6.25")
96 (source
97 (origin
98 (method url-fetch)
99 (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
100 version "/" name "-" version ".tar.bz2"))
101 (sha256
102 (base32
103 "0hzsd7rvfa87b4hxg9yj4xhdfxx9sp09r9sqdl3mqhvmcyw018y5"))))
104 (build-system gnu-build-system)
105 (arguments
106 ;; The tests require a network device capable of multicasting which is
107 ;; not available in the build environment. See
108 ;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00312.html.
109 `(#:tests? #f
110 #:configure-flags '("--enable-ipv6")))
111 (home-page "http://pupnp.sourceforge.net")
112 (synopsis "Portable SDK for UPnP Devices")
113 (description
114 "The portable SDK for UPnP Devices (libupnp) provides developers with an
115 API and code for building control points, devices, and bridges that are
116 compliant with Version 1.0 of the Universal Plug and Play Device Architecture
117 Specification and support several operating systems like Linux, *BSD, Solaris
118 and others.")
119 (license bsd-3)))
120
121 (define-public readymedia
122 (package
123 (name "readymedia")
124 (version "1.2.1")
125 (source
126 (origin
127 (method git-fetch)
128 (uri (git-reference
129 (url "https://git.code.sf.net/p/minidlna/git")
130 (commit (string-append
131 "v"
132 (string-map (match-lambda
133 (#\. #\_)
134 (chr chr))
135 version)))))
136 (file-name (git-file-name name version))
137 (sha256
138 (base32
139 "160915yv38k0p5zmyncs12kkbbcd8m8fk9jq70fkfd5x6dz40xm4"))))
140 (build-system gnu-build-system)
141 (native-inputs
142 `(("automake" ,automake)
143 ("autoconf" ,autoconf)
144 ("gettext" ,gettext-minimal)))
145 (inputs
146 `(("libexif" ,libexif)
147 ("libjpeg" ,libjpeg)
148 ("libid3tag" ,libid3tag)
149 ("flac" ,flac)
150 ("libvorbis" ,libvorbis)
151 ("sqlite" ,sqlite)
152 ("ffmpeg" ,ffmpeg)))
153 (home-page "https://sourceforge.net/projects/minidlna/")
154 (synopsis "DLNA/UPnP-AV media server")
155 (description "ReadyMedia (formerly known as MiniDLNA) is a simple media
156 server, which serves multimedia content to compatible clients on the network.
157 It aims to be fully compliant with DLNA and UPnP-AV standards.")
158 (license gpl2)))