gnu: Remove python2-pyaudio.
[jackhill/guix/guix.git] / gnu / packages / nano.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2015-2022 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
5 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages nano)
24 #:use-module (guix licenses)
25 #:use-module (gnu packages gettext)
26 #:use-module (gnu packages ncurses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
30
31 (define-public nano
32 (package
33 (name "nano")
34 (version "6.3")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/nano/nano-" version ".tar.xz"))
39 (sha256
40 (base32 "11w6dxg8159bhcap9gzv11nlcnl8mfx5ss0ga05p6wjnk2j2slzb"))))
41 (build-system gnu-build-system)
42 (inputs
43 (list gettext-minimal ncurses))
44 (home-page "https://www.nano-editor.org/")
45 (synopsis "Small, user-friendly console text editor")
46 (description
47 "GNU nano is a small and simple text editor for use in a terminal. Besides
48 basic editing, it supports: undo/redo, syntax highlighting, spell checking,
49 justifying, auto-indentation, bracket matching, interactive search-and-replace
50 (with regular expressions), and the editing of multiple files.")
51 (license gpl3+))) ; some files are under GPLv2+