gnu: Add gnome-shell-extension-paperwm.
[jackhill/guix/guix.git] / gnu / packages / gnome-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
3 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
4 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
5 ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages gnome-xyz)
23 #:use-module (guix build-system trivial)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix build-system copy)
26 #:use-module (guix git-download)
27 #:use-module (guix packages)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (gnu packages base)
30 #:use-module (gnu packages bash)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages gnome)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages ruby)
36 #:use-module (gnu packages xml))
37
38 (define-public matcha-theme
39 (package
40 (name "matcha-theme")
41 (version "2019-11-02")
42 (source
43 (origin
44 (method git-fetch)
45 (uri
46 (git-reference
47 (url "https://github.com/vinceliuice/matcha")
48 (commit version)))
49 (file-name (git-file-name name version))
50 (sha256
51 (base32
52 "0wci9ahap8kynq8cbyxr7aba9ndb1d4kiq42xvzr34vw1rhcahrr"))))
53 (build-system trivial-build-system)
54 (arguments
55 '(#:modules ((guix build utils))
56 #:builder
57 (begin
58 (use-modules (guix build utils))
59 (let* ((out (assoc-ref %outputs "out"))
60 (source (assoc-ref %build-inputs "source"))
61 (bash (assoc-ref %build-inputs "bash"))
62 (coreutils (assoc-ref %build-inputs "coreutils"))
63 (themesdir (string-append out "/share/themes")))
64 (setenv "PATH"
65 (string-append coreutils "/bin:"
66 (string-append bash "/bin:")))
67 (copy-recursively source (getcwd))
68 (patch-shebang "Install")
69 (mkdir-p themesdir)
70 (invoke "./Install" "-d" themesdir)
71 #t))))
72 (inputs
73 `(("gtk-engines" ,gtk-engines)))
74 (native-inputs
75 `(("bash" ,bash)
76 ("coreutils" ,coreutils)))
77 (synopsis "Flat design theme for GTK 3, GTK 2 and GNOME-Shell")
78 (description "Matcha is a flat Design theme for GTK 3, GTK 2 and
79 Gnome-Shell which supports GTK 3 and GTK 2 based desktop environments
80 like Gnome, Unity, Budgie, Pantheon, XFCE, Mate and others.")
81 (home-page "https://github.com/vinceliuice/matcha")
82 (license license:gpl3+)))
83
84 (define-public delft-icon-theme
85 (package
86 (name "delft-icon-theme")
87 (version "1.10")
88 (source
89 (origin
90 (method git-fetch)
91 (uri (git-reference
92 (url "https://github.com/madmaxms/iconpack-delft.git")
93 (commit (string-append "v" version))))
94 (sha256
95 (base32
96 "0vw3yw9f9ygzfd2k3zrfih3r0vkzlhk1bmsk8sapvk7np24i1z9s"))
97 (file-name (git-file-name name version))))
98 (build-system trivial-build-system)
99 (arguments
100 `(#:modules ((guix build utils))
101 #:builder
102 (begin
103 (use-modules (guix build utils))
104 (copy-recursively (assoc-ref %build-inputs "source") "icons")
105 (substitute* "icons/Delft/index.theme"
106 (("gnome") "Adwaita"))
107 (delete-file "icons/README.md")
108 (delete-file "icons/LICENSE")
109 (delete-file "icons/logo.jpg")
110 (copy-recursively "icons" (string-append %output "/share/icons")))))
111 (home-page "https://www.gnome-look.org/p/1199881/")
112 (synopsis "Continuation of Faenza icon theme with up to date app icons")
113 (description "Delft is a fork of the popular icon theme Faenza with up to
114 date app icons. It will stay optically close to the original Faenza icons,
115 which haven't been updated for some years. The new app icons are ported from
116 the Obsidian icon theme.")
117 (license license:gpl3)))
118
119 (define-public gnome-shell-extension-appindicator
120 (package
121 (name "gnome-shell-extension-appindicator")
122 (version "30")
123 (source (origin
124 (method git-fetch)
125 (uri (git-reference
126 (url
127 "https://github.com/ubuntu/gnome-shell-extension-appindicator.git")
128 (commit (string-append "v" version))))
129 (sha256
130 (base32
131 "1fjhx23jqwv3d0smwhnjvc35gqhwk9p5f96ic22pfax653cn5vh8"))
132 (file-name (git-file-name name version))))
133 (build-system trivial-build-system)
134 (arguments
135 '(#:modules ((guix build utils))
136 #:builder
137 (begin
138 (use-modules (guix build utils))
139 (let* ((source (assoc-ref %build-inputs "source"))
140 (install-dir (string-append (assoc-ref %outputs "out")
141 "/share/gnome-shell/extensions"
142 "/appindicatorsupport@rgcjonas.gmail.com")))
143 (mkdir-p install-dir)
144 (copy-recursively source install-dir)
145 #t))))
146 (synopsis "Adds KStatusNotifierItem support to GNOME Shell")
147 (description "This extension integrates Ubuntu AppIndicators
148 and KStatusNotifierItems (KDE's successor of the systray) into
149 GNOME Shell.")
150 (home-page "https://github.com/ubuntu/gnome-shell-extension-appindicator/")
151 (license license:gpl2+)))
152
153 (define-public gnome-shell-extension-dash-to-dock
154 (package
155 (name "gnome-shell-extension-dash-to-dock")
156 (version "66")
157 (source (origin
158 (method git-fetch)
159 (uri (git-reference
160 (url "https://github.com/micheleg/dash-to-dock.git")
161 (commit (string-append "extensions.gnome.org-v"
162 version))))
163 (sha256
164 (base32
165 "04krl6rxlp1qc97psraf2kwin7h0mx4c7pnfpi7vhplmvasrwkfh"))
166 (file-name (git-file-name name version))))
167 (build-system gnu-build-system)
168 (arguments
169 '(#:tests? #f
170 #:make-flags (list (string-append "INSTALLBASE="
171 (assoc-ref %outputs "out")
172 "/share/gnome-shell/extensions"))
173 #:phases
174 (modify-phases %standard-phases
175 (delete 'bootstrap)
176 (delete 'configure))))
177 (native-inputs
178 `(("glib:bin" ,glib "bin")
179 ("intltool" ,intltool)
180 ("pkg-config" ,pkg-config)))
181 (propagated-inputs
182 `(("glib" ,glib)))
183 (synopsis "Transforms GNOME's dash into a dock")
184 (description "This extension moves the dash out of the
185 overview, transforming it into a dock for easier application launching and
186 faster window switching.")
187 (home-page "https://micheleg.github.io/dash-to-dock/")
188 (license license:gpl2+)))
189
190 (define-public gnome-shell-extension-hide-app-icon
191 (let ((commit "4188aa5f4ba24901a053a0c3eb0d83baa8625eab")
192 (revision "0"))
193 (package
194 (name "gnome-shell-extension-hide-app-icon")
195 (version (git-version "2.7" revision commit))
196 (source
197 (origin
198 (method git-fetch)
199 (uri (git-reference
200 (url (string-append "https://github.com/michael-rapp"
201 "/gnome-shell-extension-hide-app-icon.git"))
202 (commit commit)))
203 (sha256
204 (base32
205 "1i28n4bz6wrhn07vpxkr6l1ljyn7g8frp5xrr11z3z32h2hxxcd6"))
206 (file-name (git-file-name name version))))
207 (build-system gnu-build-system)
208 (arguments
209 '(#:tests? #f ; no test target
210 #:make-flags (list (string-append "EXTENSIONS_DIR="
211 (assoc-ref %outputs "out")
212 "/share/gnome-shell/extensions"))
213 #:phases
214 (modify-phases %standard-phases
215 (delete 'configure) ; no configure script
216 (replace 'install
217 (lambda* (#:key outputs #:allow-other-keys)
218 (let ((out (assoc-ref outputs "out"))
219 (pre "/share/gnome-shell/extensions/")
220 (dir "hide-app-icon@mrapp.sourceforge.com"))
221 (copy-recursively dir (string-append out pre dir))
222 #t))))))
223 (native-inputs
224 `(("glib" ,glib "bin")
225 ("intltool" ,intltool)))
226 (propagated-inputs
227 `(("glib" ,glib)))
228 (synopsis "Hide app icon from GNOME's panel")
229 (description "This extension allows to hide the icon and/or title of the
230 currently focused application in the top panel of the GNOME shell.")
231 (home-page
232 "https://github.com/michael-rapp/gnome-shell-extension-hide-app-icon/")
233 (license
234 ;; README.md and LICENSE.txt disagree -- the former claims v3, the
235 ;; latter v2. No mention of "or later" in either place or in the code.
236 (list license:gpl2
237 license:gpl3)))))
238
239 (define-public gnome-shell-extension-dash-to-panel
240 (package
241 (name "gnome-shell-extension-dash-to-panel")
242 (version "26")
243 (source (origin
244 (method git-fetch)
245 (uri (git-reference
246 (url "https://github.com/home-sweet-gnome/dash-to-panel.git")
247 (commit (string-append "v" version))))
248 (sha256
249 (base32
250 "1phfx2pblygpcvsppsqqqflm7qnz46mqkw29hj0nv2dn69hf4xbc"))
251 (file-name (git-file-name name version))))
252 (build-system gnu-build-system)
253 (arguments
254 `(#:tests? #f
255 #:make-flags (list (string-append "INSTALLBASE="
256 (assoc-ref %outputs "out")
257 "/share/gnome-shell/extensions")
258 (string-append "VERSION="
259 ,(package-version
260 gnome-shell-extension-dash-to-panel)))
261 #:phases
262 (modify-phases %standard-phases
263 (delete 'bootstrap)
264 (delete 'configure))))
265 (native-inputs
266 `(("intltool" ,intltool)
267 ("pkg-config" ,pkg-config)))
268 (propagated-inputs
269 `(("glib" ,glib)
270 ("glib" ,glib "bin")))
271 (synopsis "Icon taskbar for GNOME Shell")
272 (description "This extension moves the dash into the gnome main
273 panel so that the application launchers and system tray are combined
274 into a single panel, similar to that found in KDE Plasma and Windows 7+.")
275 (home-page "https://github.com/home-sweet-gnome/dash-to-panel/")
276 (license license:gpl2+)))
277
278 (define-public gnome-shell-extension-noannoyance
279 (package
280 (name "gnome-shell-extension-noannoyance")
281 (version "5")
282 (source (origin
283 (method git-fetch)
284 (uri (git-reference
285 (url "https://github.com/BjoernDaase/noannoyance.git")
286 (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
287 (sha256
288 (base32
289 "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
290 (file-name (git-file-name name version))))
291 (build-system trivial-build-system)
292 (arguments
293 '(#:modules ((guix build utils))
294 #:builder
295 (begin
296 (use-modules (guix build utils))
297 (let ((dst (string-append
298 (assoc-ref %outputs "out")
299 "/share/gnome-shell/extensions/"
300 "noannoyance@daase.net")))
301 (mkdir-p dst)
302 (copy-recursively (assoc-ref %build-inputs "source") dst)))))
303 (synopsis "Removes 'Window is ready' annotation")
304 (description "One of the many extensions, that remove this message.
305 It uses ES6 syntax and claims to be more actively maintained than others.")
306 (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
307 (license license:gpl2)))
308
309 (define-public gnome-shell-extension-paperwm
310 (package
311 (name "gnome-shell-extension-paperwm")
312 (version "34.3")
313 (source (origin
314 (method git-fetch)
315 (uri (git-reference
316 (url "https://github.com/paperwm/PaperWM.git")
317 (commit version)))
318 (file-name (git-file-name name version))
319 (sha256
320 (base32
321 "1qry75f696pgmd9yzqvwhq5h6cipin2fvk7h881g29cjcpxim37a"))))
322 (build-system copy-build-system)
323 (arguments
324 '(#:install-plan
325 '(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
326 #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
327 "\\.xml$" "\\.compiled$")))))
328 (home-page "https://github.com/paperwm/PaperWM")
329 (synopsis "Tiled scrollable window management for GNOME Shell")
330 (description "PaperWM is an experimental GNOME Shell extension providing
331 scrollable tiling of windows and per monitor workspaces. It's inspired by paper
332 notebooks and tiling window managers.")
333 (license license:gpl3)))
334
335 (define-public numix-theme
336 (package
337 (name "numix-theme")
338 (version "2.6.7")
339 (source (origin
340 (method git-fetch)
341 (uri (git-reference
342 (url "https://github.com/numixproject/numix-gtk-theme.git")
343 (commit version)))
344 (file-name (git-file-name name version))
345 (sha256
346 (base32
347 "12mw0kr0kkvg395qlbsvkvaqccr90cmxw5rrsl236zh43kj8grb7"))))
348 (build-system gnu-build-system)
349 (arguments
350 '(#:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))
351 #:phases
352 (modify-phases %standard-phases
353 (delete 'configure)
354 (delete 'check))))
355 (native-inputs
356 `(("glib:bin" ,glib "bin") ; for glib-compile-schemas
357 ("gnome-shell" ,gnome-shell)
358 ("gtk+" ,gtk+)
359 ("xmllint" ,libxml2)
360 ("ruby-sass" ,ruby-sass)))
361 (synopsis "Flat theme with light and dark elements")
362 (description "Numix is a modern flat theme with a combination of light and
363 dark elements. It supports GNOME, Unity, Xfce, and Openbox.")
364 (home-page "https://numixproject.github.io")
365 (license license:gpl3+)))
366
367 (define-public papirus-icon-theme
368 (let ((version "0.0.0") ;; The package does not use semver
369 (revision "0")
370 (tag "20191201"))
371 (package
372 (name "papirus-icon-theme")
373 (version (git-version version revision tag))
374 (source
375 (origin
376 (method git-fetch)
377 (uri (git-reference
378 (url "https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git")
379 (commit tag)))
380 (sha256
381 (base32
382 "0lnz1kmz28xh1f4slbsx7ycji5hgszyiyprbf5w5fbjhvi5gzw1h"))
383 (file-name (git-file-name name version))))
384 (build-system gnu-build-system)
385 (arguments
386 '(#:tests? #f
387 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
388 #:phases
389 (modify-phases %standard-phases
390 (delete 'bootstrap)
391 (delete 'configure)
392 (delete 'build))))
393 (native-inputs
394 `(("gtk+:bin" ,gtk+ "bin")))
395 (home-page "https://git.io/papirus-icon-theme")
396 (synopsis "Fork of Paper icon theme with a lot of new icons and a few extras")
397 (description "Papirus is a fork of the icon theme Paper with a lot of new icons
398 and a few extra features.")
399 (license license:gpl3))))