gnu: Generalize the variable name of the test-only tzdata package.
[jackhill/guix/guix.git] / gnu / packages / scribus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Nicolas Goaziou <mail@nicolasgoaziou.fr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages scribus)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix build-system cmake)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages boost)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages cups)
31 #:use-module (gnu packages fontutils)
32 #:use-module (gnu packages ghostscript)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages icu4c)
35 #:use-module (gnu packages image)
36 #:use-module (gnu packages imagemagick)
37 #:use-module (gnu packages libreoffice)
38 #:use-module (gnu packages linux)
39 #:use-module (gnu packages pdf)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages python)
42 #:use-module (gnu packages qt)
43 #:use-module (gnu packages tls)
44 #:use-module (gnu packages xml))
45
46 (define-public scribus
47 (package
48 (name "scribus")
49 (version "1.5.3")
50 (source
51 (origin
52 (method url-fetch)
53 (uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
54 version "/scribus-" version ".tar.xz"))
55 (sha256
56 (base32
57 "0kyp45vidxa3v35ic9592db4zk3m8al26vck38q5v7z14x3hp8vk"))
58 (patches
59 (list
60 (origin
61 (method url-fetch)
62 (uri (string-append "https://github.com/scribusproject/scribus/commit/"
63 "61186c7ef083046b7e0c908952e8a773e2787d82.patch"))
64 (file-name "scribus-fix-poppler-0.58-breakage.patch")
65 (sha256
66 (base32 "189qw9xmgz01xz1w1bi9lzrp399zk1j1iz5qdhchdrhgnd69b7ly")))
67 (origin
68 (method url-fetch)
69 (uri (string-append "https://github.com/scribusproject/scribus/commit/"
70 "d82b1c989bd0e79b5611521f671adbfb94996e5e.patch"))
71 (file-name "scribus-fix-poppler-packaging.patch")
72 (sha256
73 (base32 "1p9s18jjvj2h0ba1xvk1zhmnn4f4n3ykrgb56mjd6in30h0vrykx")))))
74 (modules '((guix build utils)))
75 (snippet
76 ;; Fix typo. Equivalent to patch at
77 ;; https://bugs.scribus.net/view.php?id=14850
78 '(substitute* "cmake/modules/FindLIBPODOFO.cmake"
79 (("find_package\\(OPENSSL\\)") "find_package(OpenSSL)")))))
80 (build-system cmake-build-system)
81 (arguments
82 `(#:tests? #f ;no test target
83 #:configure-flags
84 '("-DWANT_GRAPHICSMAGICK=1")))
85 (inputs
86 `(("boost" ,boost)
87 ("cairo" ,cairo)
88 ("cups" ,cups)
89 ("fontconfig" ,fontconfig)
90 ("freetype" ,freetype)
91 ("graphicsmagick" ,graphicsmagick)
92 ("harfbuzz" ,harfbuzz)
93 ("hunspell" ,hunspell)
94 ("icu4c" ,icu4c)
95 ("lcms" ,lcms)
96 ("libcdr" ,libcdr)
97 ("libfreehand" ,libfreehand)
98 ("libjpeg" ,libjpeg)
99 ("libmspub" ,libmspub)
100 ("libpagemaker" ,libpagemaker)
101 ("librevenge" ,librevenge)
102 ("libtiff" ,libtiff)
103 ("libvisio" ,libvisio)
104 ("libxml2" ,libxml2)
105 ("openssl" ,openssl)
106 ("podofo" ,podofo)
107 ("poppler" ,poppler)
108 ("python" ,python-2) ;need Python library
109 ("qtbase" ,qtbase)
110 ("qtdeclarative" ,qtdeclarative)
111 ("zlib" ,zlib)))
112 (native-inputs
113 `(("pkg-config" ,pkg-config)
114 ("qttools" ,qttools)
115 ("util-linux" ,util-linux)))
116 (home-page "https://www.scribus.net")
117 (synopsis "Desktop publishing and page layout program")
118 (description
119 "Scribus is a @dfn{desktop publishing} (DTP) application and can be used
120 for many tasks; from brochure design to newspapers, magazines, newsletters and
121 posters to technical documentation. Scribus supports professional DTP
122 features, such as CMYK color and a color management system to soft proof
123 images for high quality color printing, flexible PDF creation options,
124 Encapsulated PostScript import/export and creation of four color separations,
125 import of EPS/PS and SVG as native vector graphics, Unicode text including
126 right to left scripts such as Arabic and Hebrew via freetype.")
127 (license license:gpl2+)))