gnu: python-deepmerge: Use pyproject-build-system.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2017 Nikita <nikita@n0.is>
6 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages enlightenment)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix utils)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system meson)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages algebra)
34 #:use-module (gnu packages bittorrent)
35 #:use-module (gnu packages check)
36 #:use-module (gnu packages code)
37 #:use-module (gnu packages compression)
38 #:use-module (gnu packages curl)
39 #:use-module (gnu packages fonts)
40 #:use-module (gnu packages fontutils)
41 #:use-module (gnu packages freedesktop)
42 #:use-module (gnu packages fribidi)
43 #:use-module (gnu packages game-development)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages ghostscript)
46 #:use-module (gnu packages gl)
47 #:use-module (gnu packages glib)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages gstreamer)
50 #:use-module (gnu packages gtk)
51 #:use-module (gnu packages hardware)
52 #:use-module (gnu packages ibus)
53 #:use-module (gnu packages image)
54 #:use-module (gnu packages libunwind)
55 #:use-module (gnu packages linux)
56 #:use-module (gnu packages llvm)
57 #:use-module (gnu packages lua)
58 #:use-module (gnu packages pdf)
59 #:use-module (gnu packages perl)
60 #:use-module (gnu packages photo)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages pulseaudio)
63 #:use-module (gnu packages python)
64 #:use-module (gnu packages python-xyz)
65 #:use-module (gnu packages tls)
66 #:use-module (gnu packages video)
67 #:use-module (gnu packages xdisorg)
68 #:use-module (gnu packages xorg)
69 #:use-module (ice-9 match))
70
71 (define-public efl
72 (package
73 (name "efl")
74 (version "1.26.3")
75 (source (origin
76 (method url-fetch)
77 (uri (string-append
78 "https://download.enlightenment.org/rel/libs/efl/efl-"
79 version ".tar.xz"))
80 (sha256
81 (base32
82 "05bxc58hj0z6pkp6yy5cmy1lc575q0nrbr5lxr6z8d4kznh3my6r"))))
83 (build-system meson-build-system)
84 (native-inputs
85 `(("check" ,check)
86 ("gettext" ,gettext-minimal)
87 ("pkg-config" ,pkg-config)
88 ("python" ,python)))
89 (inputs
90 `(("curl" ,curl)
91 ("giflib" ,giflib)
92 ("gstreamer" ,gstreamer)
93 ("gst-plugins-base" ,gst-plugins-base)
94 ("ibus" ,ibus)
95 ("mesa" ,mesa)
96 ("libraw" ,libraw)
97 ("librsvg" ,(librsvg-for-system))
98 ("libspectre" ,libspectre)
99 ("libtiff" ,libtiff)
100 ("libxau" ,libxau)
101 ("libxcomposite" ,libxcomposite)
102 ("libxcursor" ,libxcursor)
103 ("libxdamage" ,libxdamage)
104 ("libxdmcp" ,libxdmcp)
105 ("libxext" ,libxext)
106 ("libxi" ,libxi)
107 ("libxfixes" ,libxfixes)
108 ("libxinerama" ,libxinerama)
109 ("libxrandr" ,libxrandr)
110 ("libxrender" ,libxrender)
111 ("libxss" ,libxscrnsaver)
112 ("libxtst" ,libxtst)
113 ("libwebp" ,libwebp)
114 ("openjpeg" ,openjpeg)
115 ("poppler" ,poppler)
116 ("util-linux" ,util-linux "lib")
117 ("wayland-protocols" ,wayland-protocols)))
118 (propagated-inputs
119 ;; All these inputs are in package config files in section
120 ;; Requires.private.
121 `(("dbus" ,dbus)
122 ("elogind" ,elogind)
123 ("eudev" ,eudev)
124 ("fontconfig" ,fontconfig)
125 ("freetype" ,freetype)
126 ("fribidi" ,fribidi)
127 ("glib" ,glib)
128 ("harfbuzz" ,harfbuzz)
129 ("libinput" ,libinput-minimal)
130 ("libjpeg" ,libjpeg-turbo)
131 ("libsndfile" ,libsndfile)
132 ("libpng" ,libpng)
133 ("libunwind" ,libunwind)
134 ("libx11" ,libx11)
135 ("libxkbcommon" ,libxkbcommon)
136 ("luajit" ,luajit)
137 ("lz4" ,lz4)
138 ("openssl" ,openssl)
139 ("pulseaudio" ,pulseaudio)
140 ("wayland" ,wayland)
141 ("zlib" ,zlib)))
142 (arguments
143 `(#:configure-flags
144 `("-Dembedded-lz4=false"
145 "-Dbuild-examples=false"
146 "-Decore-imf-loaders-disabler=scim"
147 "-Dglib=true"
148 "-Dmount-path=/run/setuid-programs/mount"
149 "-Dunmount-path=/run/setuid-programs/umount"
150 "-Dnetwork-backend=connman"
151 ;; For Wayland.
152 "-Dwl=true"
153 "-Ddrm=true")
154 #:tests? #f ; Many tests fail due to timeouts and network requests.
155 #:phases
156 (modify-phases %standard-phases
157 ;; If we don't hardcode the location of libcurl.so and others then we
158 ;; have to wrap the outputs of efl's dependencies in those libraries.
159 (add-after 'unpack 'hardcode-dynamic-libraries
160 (lambda* (#:key inputs #:allow-other-keys)
161 (let ((curl (assoc-ref inputs "curl"))
162 (pulse (assoc-ref inputs "pulseaudio"))
163 (sndfile (assoc-ref inputs "libsndfile"))
164 (elogind (assoc-ref inputs "elogind"))
165 (lib "/lib/"))
166 (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
167 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
168 (string-append curl lib libcurl)))
169 (substitute* "src/lib/ecore_audio/ecore_audio.c"
170 (("libpulse.so.0" libpulse)
171 (string-append pulse lib libpulse))
172 (("libsndfile.so.1" libsnd)
173 (string-append sndfile lib libsnd)))
174 (substitute* "src/lib/elput/elput_logind.c"
175 (("libelogind.so.0" libelogind)
176 (string-append elogind "/lib/" libelogind))))))
177 (add-after 'unpack 'fix-install-paths
178 (lambda _
179 (substitute* "dbus-services/meson.build"
180 (("install_dir.*")
181 "install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
182 (substitute* "src/tests/elementary/meson.build"
183 (("dir_data") "meson.source_root(), 'test-output'"))
184 (substitute* "data/eo/meson.build"
185 (("'usr', 'lib'") "'./' + dir_lib"))))
186 (add-after 'unpack 'set-home-directory
187 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
188 (lambda _ (setenv "HOME" "/tmp"))))))
189 (home-page "https://www.enlightenment.org/about-efl")
190 (synopsis "Enlightenment Foundation Libraries")
191 (description
192 "Enlightenment Foundation Libraries is a set of libraries developed
193 for Enlightenment. Libraries covers data serialization, wide support for
194 graphics rendering, UI layout and themes, interaction with OS, access to
195 removable devices or support for multimedia.")
196 ;; Different parts are under different licenses.
197 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
198
199 (define-public terminology
200 (package
201 (name "terminology")
202 (version "1.12.1")
203 (source (origin
204 (method url-fetch)
205 (uri
206 (string-append "https://download.enlightenment.org/rel/apps/"
207 "terminology/terminology-" version ".tar.xz"))
208 (sha256
209 (base32
210 "1aasddf2343qj798b5s8qwif3lxj4pyjax6fa9sfi6if9icdkkpq"))
211 (modules '((guix build utils)))
212 ;; Remove the bundled fonts.
213 (snippet
214 '(begin
215 (delete-file-recursively "data/fonts")
216 (substitute* "data/meson.build"
217 (("subdir\\('fonts'\\)") ""))))))
218 (build-system meson-build-system)
219 (arguments
220 `(#:configure-flags
221 (let ((efl (assoc-ref %build-inputs "efl")))
222 (list "-Dtests=true"
223 (string-append "-Dedje-cc=" efl "/bin/edje_cc")
224 (string-append "-Deet=" efl "/bin/eet")))
225 #:phases
226 (modify-phases %standard-phases
227 (add-after 'unpack 'set-home-directory
228 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
229 (lambda _ (setenv "HOME" "/tmp")))
230 (replace 'check
231 (lambda* (#:key tests? #:allow-other-keys)
232 (when tests?
233 (with-directory-excursion
234 (string-append "../" ,name "-" ,version "/tests")
235 (invoke "sh" "run_tests.sh" "--verbose"
236 "-t" "../../build/src/bin/tytest")))))
237 (add-after 'install 'remove-test-binary
238 (lambda* (#:key outputs #:allow-other-keys)
239 ;; This file is not meant to be installed.
240 (delete-file (string-append (assoc-ref outputs "out")
241 "/bin/tytest")))))))
242 (native-inputs
243 (list gettext-minimal
244 perl
245 pkg-config
246 python))
247 (inputs
248 (list efl))
249 (home-page "https://www.enlightenment.org/about-terminology")
250 (synopsis "Powerful terminal emulator based on EFL")
251 (description
252 "Terminology is fast and feature rich terminal emulator. It is solely
253 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
254 URL and local path detection, themes, popup based content viewer for non-text
255 contents and more.")
256 (license license:bsd-2)))
257
258 (define-public rage
259 (package
260 (name "rage")
261 (version "0.4.0")
262 (source (origin
263 (method url-fetch)
264 (uri
265 (string-append
266 "https://download.enlightenment.org/rel/apps/rage/rage-"
267 version ".tar.xz"))
268 (sha256
269 (base32
270 "03yal7ajh57x2jhmygc6msf3gzvqkpmzkqzj6dnam5sim8cq9rbw"))))
271 (build-system meson-build-system)
272 (arguments
273 '(#:phases
274 (modify-phases %standard-phases
275 (add-after 'unpack 'set-home-directory
276 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
277 (lambda _ (setenv "HOME" "/tmp"))))))
278 (native-inputs
279 (list pkg-config))
280 (inputs
281 (list efl))
282 (home-page "https://www.enlightenment.org/about-rage")
283 (synopsis "Video and audio player based on EFL")
284 (description
285 "Rage is a video and audio player written with Enlightenment Foundation
286 Libraries with some extra bells and whistles.")
287 (license license:bsd-2)))
288
289 (define-public enlightenment
290 (package
291 (name "enlightenment")
292 (version "0.25.4")
293 (source (origin
294 (method url-fetch)
295 (uri
296 (string-append "https://download.enlightenment.org/rel/apps/"
297 "enlightenment/enlightenment-" version ".tar.xz"))
298 (sha256
299 (base32
300 "18mp4ggfy7n0yz6kzx56ali0piqa84z72vnj6649l6w2dch5vnsn"))
301 (patches (search-patches "enlightenment-fix-setuid-path.patch"))))
302 (build-system meson-build-system)
303 (arguments
304 `(#:configure-flags
305 (list "-Dsystemd=false"
306 "-Dpackagekit=false"
307 "-Dwl=true")
308 #:phases
309 (modify-phases %standard-phases
310 (add-before 'configure 'set-system-actions
311 (lambda* (#:key inputs #:allow-other-keys)
312 (setenv "HOME" "/tmp")
313 (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
314 (setxkbmap (assoc-ref inputs "setxkbmap"))
315 (libc (assoc-ref inputs "libc"))
316 (bc (assoc-ref inputs "bc"))
317 (ddcutil (assoc-ref inputs "ddcutil"))
318 (efl (assoc-ref inputs "efl")))
319 ;; We need to patch the path to 'base.lst' to be able
320 ;; to switch the keyboard layout in E.
321 (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
322 "src/modules/wizard/page_011.c")
323 (("/usr/share/X11/xkb/rules/xorg.lst")
324 (string-append xkeyboard
325 "/share/X11/xkb/rules/base.lst")))
326 (substitute* "src/bin/e_xkb.c"
327 (("\"setxkbmap \"")
328 (string-append "\"" setxkbmap "/bin/setxkbmap \"")))
329 (substitute* (list "src/bin/e_intl.c"
330 "src/modules/conf_intl/e_int_config_intl.c"
331 "src/modules/wizard/page_010.c")
332 (("locale -a") (string-append libc "/bin/locale -a")))
333 (substitute* "src/modules/everything/evry_plug_apps.c"
334 (("/usr/bin/") ""))
335 (substitute* '("src/bin/e_sys_main.c"
336 "src/bin/e_util_suid.h")
337 (("PATH=/bin:/usr/bin:/sbin:/usr/sbin")
338 (string-append "PATH=/run/setuid-programs:"
339 "/run/current-system/profile/bin:"
340 "/run/current-system/profile/sbin")))
341 (substitute* "src/modules/everything/evry_plug_calc.c"
342 (("bc -l") (string-append bc "/bin/bc -l")))
343 (substitute* "src/bin/system/e_system_ddc.c"
344 (("libddcutil\\.so\\.?" libddcutil)
345 (string-append ddcutil "/lib/" libddcutil)))
346 (substitute* "data/etc/meson.build"
347 (("/bin/mount") "/run/setuid-programs/mount")
348 (("/bin/umount") "/run/setuid-programs/umount")
349 (("/usr/bin/eject") "/run/current-system/profile/bin/eject"))
350 (substitute* "src/bin/system/e_system_power.c"
351 (("systemctl") "loginctl"))))))))
352 (native-inputs
353 `(("gettext" ,gettext-minimal)
354 ("pkg-config" ,pkg-config)))
355 (inputs
356 `(("alsa-lib" ,alsa-lib)
357 ("bc" ,bc)
358 ("bluez" ,bluez)
359 ("dbus" ,dbus)
360 ("ddcutil" ,ddcutil)
361 ("freetype" ,freetype)
362 ("libdrm" ,libdrm)
363 ("libexif" ,libexif)
364 ("libxcb" ,libxcb)
365 ("libxext" ,libxext)
366 ("linux-pam" ,linux-pam)
367 ("pulseaudio" ,pulseaudio)
368 ("setxkbmap" ,setxkbmap)
369 ("xcb-util-keysyms" ,xcb-util-keysyms)
370 ("xkeyboard-config" ,xkeyboard-config)
371 ("xorg-server-xwayland" ,xorg-server-xwayland)))
372 (propagated-inputs
373 (list efl libxkbcommon wayland-protocols
374 ;; Default font that applications such as IceCat require.
375 font-dejavu))
376 (home-page "https://www.enlightenment.org/about-enlightenment")
377 (synopsis "Lightweight desktop environment")
378 (description
379 "Enlightenment is resource friendly desktop environment with integrated
380 file manager, wide range of configuration options, plugin system allowing to
381 unload unused functionality, with support for touchscreen and suitable for
382 embedded systems.")
383 (license license:bsd-2)))
384
385 (define-public python-efl
386 (package
387 (name "python-efl")
388 (version "1.26.0")
389 (source
390 (origin
391 (method url-fetch)
392 (uri (string-append "https://download.enlightenment.org/rel/bindings/"
393 "python/python-efl-" version ".tar.xz"))
394 (sha256
395 (base32
396 "0dj6f24n33hkpy0bkdclnzpxhvs8vpaxqaf7hkw0di19pjwrq25h"))
397 (modules '((guix build utils)))
398 ;; Remove files generated by Cython
399 (snippet
400 '(begin
401 (for-each (lambda (file)
402 (let ((generated-file
403 (string-append (string-drop-right file 3) "c")))
404 (when (file-exists? generated-file)
405 (delete-file generated-file))))
406 (find-files "efl" "\\.pyx$"))
407 (delete-file "efl/eo/efl.eo_api.h")))))
408 (build-system python-build-system)
409 (arguments
410 '(#:phases
411 (modify-phases %standard-phases
412 (replace 'build
413 (lambda _
414 (setenv "ENABLE_CYTHON" "1")
415 (invoke "python" "setup.py" "build")))
416 (add-before 'build 'set-flags
417 (lambda _
418 (setenv "CFLAGS"
419 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
420 "/include/dbus-1.0"))))
421 (add-before 'check 'set-environment
422 (lambda _
423 ;; Some tests require write access to HOME.
424 (setenv "HOME" "/tmp")
425 ;; These tests try to connect to the internet.
426 (delete-file "tests/ecore/test_09_file_download.py")
427 (delete-file "tests/ecore/test_11_con.py"))))))
428 (native-inputs
429 (list pkg-config python-cython))
430 (inputs
431 (list efl python-dbus python-packaging))
432 (home-page "https://www.enlightenment.org/")
433 (synopsis "Python bindings for EFL")
434 (description
435 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
436 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
437 (license license:lgpl3)))
438
439 (define-public edi
440 (package
441 (name "edi")
442 (version "0.8.0")
443 (source
444 (origin
445 (method url-fetch)
446 (uri (string-append "https://github.com/Enlightenment/edi/releases/"
447 "download/v" version "/edi-" version ".tar.xz"))
448 (sha256
449 (base32
450 "01k8gp8r2wa6pyg3dkbm35m6hdsbss06hybghg0qjmd4mzswcd3a"))))
451 (build-system meson-build-system)
452 (arguments
453 '(#:phases
454 (modify-phases %standard-phases
455 (add-after 'unpack 'fix-clang-header
456 (lambda _
457 (substitute* "scripts/clang_include_dir.sh"
458 (("grep clang") "grep clang | head -n1"))
459 #t))
460 (add-after 'unpack 'set-home-directory
461 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
462 (lambda _ (setenv "HOME" "/tmp") #t)))
463 #:tests? #f)) ; tests require running dbus service
464 (native-inputs
465 `(("check" ,check)
466 ("gettext" ,gettext-minimal)
467 ("pkg-config" ,pkg-config)))
468 (inputs
469 (list clang efl))
470 (home-page "https://www.enlightenment.org/about-edi")
471 (synopsis "Development environment for Enlightenment")
472 (description "EDI is a development environment designed for and built using
473 the EFL. It's aim is to create a new, native development environment for Linux
474 that tries to lower the barrier to getting involved in Enlightenment development
475 and in creating applications based on the Enlightenment Foundation Library suite.")
476 (license (list license:public-domain ; data/extra/skeleton
477 license:gpl2 ; edi
478 license:gpl3)))) ; data/extra/examples/images/mono-runtime.png
479
480 (define-public ephoto
481 (package
482 (name "ephoto")
483 (version "1.6.0")
484 (source
485 (origin
486 (method url-fetch)
487 (uri (string-append "https://download.enlightenment.org/rel/"
488 "apps/ephoto/ephoto-" version ".tar.xz"))
489 (sha256
490 (base32 "1lvhcs4ba8h3z78nyycbww8mj4cscb8k200dcc3cdy8vrvrp7g1n"))))
491 (build-system meson-build-system)
492 (arguments
493 '(#:phases
494 (modify-phases %standard-phases
495 (add-after 'unpack 'set-home-directory
496 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
497 (lambda _ (setenv "HOME" "/tmp"))))))
498 (native-inputs
499 (list pkg-config))
500 (inputs
501 (list efl))
502 (home-page "https://smhouston.us/projects/ephoto/")
503 (synopsis "EFL image viewer/editor/manipulator/slideshow creator")
504 (description "Ephoto is an image viewer and editor written using the
505 @dfn{Enlightenment Foundation Libraries} (EFL). It focuses on simplicity and
506 ease of use, while taking advantage of the speed and small footprint the EFL
507 provide.
508
509 Ephoto’s features include:
510 @enumerate
511 @item Browsing the file system and displaying images in an easy-to-use grid view.
512 @item Browsing images in a single image view format.
513 @item Viewing images in a slideshow.
514 @item Editing your image with features such as cropping, auto enhance,
515 blurring, sharpening, brightness/contrast/gamma adjustments, hue/saturation/value
516 adjustments, and color level adjustment.
517 @item Applying artistic filters to your image such as black and white and old
518 photo.
519 @item Drag And Drop along with file operations to easily maintain your photo
520 directories.
521 @end enumerate\n")
522 (license (list
523 license:bsd-2 ; Ephoto's thumbnailing code
524 license:bsd-3))))
525
526 (define-public evisum
527 (package
528 (name "evisum")
529 (version "0.6.0")
530 (source
531 (origin
532 (method url-fetch)
533 (uri (string-append "https://download.enlightenment.org/rel/apps/"
534 "evisum/evisum-" version ".tar.xz"))
535 (sha256
536 (base32 "1ip3rmp0hcn0pk6lv089cayx18p1b2wycgvwpnf7ghbdxg7n4q15"))))
537 (build-system meson-build-system)
538 (arguments
539 '(#:tests? #f ; no tests
540 #:phases
541 (modify-phases %standard-phases
542 (add-after 'unpack 'set-homedir
543 (lambda _
544 (setenv "HOME" (getcwd)))))))
545 (native-inputs
546 (list gettext-minimal
547 pkg-config))
548 (inputs
549 (list efl))
550 (home-page "https://www.enlightenment.org")
551 (synopsis "EFL process viewer")
552 (description
553 "This is a process monitor and system monitor using the
554 @dfn{Enlightenment Foundation Libraries} (EFL).")
555 (license license:bsd-2)))
556
557 (define-public epour
558 (package
559 (name "epour")
560 (version "0.7.0")
561 (source
562 (origin
563 (method url-fetch)
564 (uri (string-append "https://download.enlightenment.org/rel/apps/epour"
565 "/epour-" version ".tar.xz"))
566 (sha256
567 (base32
568 "0g9f9p01hsq6dcf4cs1pwq95g6fpkyjgwqlvdjk1km1i5gj5ygqw"))))
569 (build-system python-build-system)
570 (arguments
571 `(#:tests? #f ; no test target
572 #:use-setuptools? #f
573 #:phases
574 (modify-phases %standard-phases
575 (add-after 'unpack 'find-theme-dir
576 (lambda* (#:key outputs #:allow-other-keys)
577 (let ((out (assoc-ref outputs "out")))
578 (substitute* "epour/gui/__init__.py"
579 (("join\\(data_path")
580 (string-append "join(\"" out "/share/epour\"")))
581 #t))))))
582 (native-inputs
583 (list intltool python-distutils-extra))
584 (inputs
585 (list libtorrent-rasterbar python-dbus python-efl python-pyxdg))
586 (home-page "https://www.enlightenment.org")
587 (synopsis "EFL Bittorrent client")
588 (description "Epour is a BitTorrent client based on the @dfn{Enlightenment
589 Foundation Libraries} (EFL) and rb-libtorrent.")
590 (license license:gpl3+)))