gnu: python-deepmerge: Use pyproject-build-system.
[jackhill/guix/guix.git] / gnu / packages / conky.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
3 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
5 ;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages conky)
23 #:use-module (guix packages)
24 #:use-module (guix utils)
25 #:use-module (guix download)
26 #:use-module (guix git-download)
27 #:use-module (guix build-system cmake)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (gnu packages curl)
30 #:use-module (gnu packages fontutils)
31 #:use-module (gnu packages image)
32 #:use-module (gnu packages linux)
33 #:use-module (gnu packages lua)
34 #:use-module (gnu packages ncurses)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages pulseaudio)
37 #:use-module (gnu packages xorg))
38
39 (define-public conky
40 (package
41 (name "conky")
42 (home-page "https://github.com/brndnmtthws/conky")
43 (version "1.12.2")
44 (source
45 (origin
46 (method git-fetch)
47 (uri (git-reference
48 (url home-page)
49 (commit (string-append "v" version))))
50 (file-name (git-file-name name version))
51 (sha256
52 (base32 "1grxapl4q37fzk2rsijwz2rrl0aj520y8daki6bg48jb9vjd39n7"))))
53 (build-system cmake-build-system)
54 (arguments
55 `(#:configure-flags
56 (list "-DRELEASE=true"
57 "-DBUILD_PULSEAUDIO=ON"
58 "-DBUILD_WLAN=ON"
59 "-DBUILD_TESTS=ON")
60 #:phases
61 (modify-phases %standard-phases
62 (add-after 'unpack 'add-freetype-to-search-path
63 (lambda* (#:key inputs #:allow-other-keys)
64 (substitute* "cmake/ConkyPlatformChecks.cmake"
65 (("set\\(INCLUDE_SEARCH_PATH")
66 (string-append
67 "set(INCLUDE_SEARCH_PATH "
68 (assoc-ref inputs "freetype") "/include/freetype2 ")))
69 #t))
70 (replace 'install
71 (lambda* (#:key outputs #:allow-other-keys)
72 (let* ((out (assoc-ref outputs "out"))
73 (bin (string-append out "/bin")))
74 (install-file "src/conky" bin))
75 #t)))))
76 (inputs
77 (list freetype
78 imlib2
79 libx11
80 libxdamage
81 libxext
82 libxft
83 libxinerama
84 pulseaudio
85 lua
86 ncurses
87 curl
88 wireless-tools))
89 (native-inputs
90 (list pkg-config))
91 (synopsis "Lightweight system monitor for X")
92 (description
93 "Conky is a lightweight system monitor for X that displays operating
94 system statistics (CPU, disk, and memory usage, etc.) and more on the
95 desktop.")
96 (license license:gpl3+)))