gnu: python-deepmerge: Use pyproject-build-system.
[jackhill/guix/guix.git] / gnu / packages / chicken.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
3 ;;; Copyright © 2020 Evan Hanson <evhan@foldling.org>
4 ;;; Copyright © 2020 raingloom <raingloom@riseup.net>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages chicken)
22 #:use-module (gnu packages)
23 #:use-module (guix packages)
24 #:use-module (guix build-system chicken)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix download)
27 #:use-module (guix git-download)
28 #:use-module (guix svn-download)
29 #:use-module (gnu packages commencement)
30 #:use-module ((guix licenses)
31 #:prefix license:))
32
33 (define-public chicken
34 (package
35 (name "chicken")
36 (version "5.2.0")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "https://code.call-cc.org/releases/"
40 version "/chicken-" version ".tar.gz"))
41 (sha256
42 (base32
43 "1yl0hxm9cirgcp8jgxp6vv29lpswfvaw3zfkh6rsj0vkrv44k4c1"))))
44 (build-system gnu-build-system)
45 (arguments
46 `(#:modules ((guix build gnu-build-system)
47 (guix build utils)
48 (srfi srfi-1))
49
50 ;; No `configure' script; run "make check" after "make install" as
51 ;; prescribed by README.
52 #:phases
53 (modify-phases %standard-phases
54 (delete 'configure)
55 (delete 'check)
56 (add-after 'install 'check
57 (assoc-ref %standard-phases 'check)))
58
59 #:make-flags (let ((out (assoc-ref %outputs "out")))
60 (list "PLATFORM=linux"
61 (string-append "PREFIX=" out)
62 (string-append "VARDIR=" out "/var/lib")))
63
64 ;; Parallel builds are not supported, as noted in README.
65 #:parallel-build? #f))
66 (native-search-paths
67 (list (search-path-specification
68 (variable "CHICKEN_REPOSITORY_PATH")
69 ;; TODO extract binary version into a module level definition.
70 (files (list "var/lib/chicken/11")))))
71 (propagated-inputs (list gcc-toolchain))
72 (home-page "https://www.call-cc.org/")
73 (synopsis "R5RS Scheme implementation that compiles native code via C")
74 (description
75 "CHICKEN is a compiler for the Scheme programming language. CHICKEN
76 produces portable and efficient C, supports almost all of the R5RS Scheme
77 language standard, and includes many enhancements and extensions.")
78 (license license:bsd-3)))
79
80 (define-public chicken-srfi-1
81 (package
82 (name "chicken-srfi-1")
83 (version "0.5.1")
84 (source
85 (origin
86 (method svn-fetch)
87 (uri (svn-reference
88 (url (string-append
89 "https://code.call-cc.org/svn/chicken-eggs/"
90 "release/5/srfi-1/tags/"
91 version))
92 (revision 39055)
93 (user-name "anonymous")
94 (password "")))
95 (file-name (string-append "chicken-srfi-1" version "-checkout"))
96 (sha256
97 (base32
98 "02940zsjrmn7c34rnp1rllm2nahh9jvszlzrw8ak4pf31q09cmq1"))))
99 (build-system chicken-build-system)
100 (arguments '(#:egg-name "srfi-1"))
101 (inputs
102 (list chicken-test))
103 (home-page "https://wiki.call-cc.org/eggref/5/srfi-1")
104 (synopsis "SRFI-1 list library")
105 (description
106 "The list library defined in
107 @uref{https://srfi.schemers.org/srfi-1/srfi-1.html, SRFI-1} contains a lot of
108 useful list processing procedures for construction, examining, destructuring
109 and manipulating lists and pairs.")
110 (license license:bsd-3)))
111
112 (define-public chicken-srfi-13
113 (package
114 (name "chicken-srfi-13")
115 (version "0.3.2")
116 (source (origin
117 (method url-fetch)
118 (uri (egg-uri "srfi-13" version))
119 (sha256
120 (base32
121 "18clbmaampaxivwx9bya9fxnkzqbczhlz0kbs9bfapm77mxkwclc"))))
122 (build-system chicken-build-system)
123 (arguments '(#:egg-name "srfi-13"))
124 (native-inputs (list chicken-test))
125 (propagated-inputs (list chicken-srfi-14))
126 (home-page "https://wiki.call-cc.org/egg/srfi-13")
127 (synopsis "SRFI-13 string library for Chicken scheme")
128 (description "This package provides the SRFI-13 string library for Chicken
129 scheme.")
130 (license license:bsd-3)))
131
132 (define-public chicken-srfi-14
133 (package
134 (name "chicken-srfi-14")
135 (version "0.2.1")
136 (source
137 (origin
138 (method svn-fetch)
139 (uri (svn-reference
140 (url (string-append "https://code.call-cc.org/svn/chicken-eggs/"
141 "release/5/srfi-14/tags/" version))
142 (revision 39057)
143 (user-name "anonymous")
144 (password "")))
145 (file-name (string-append "chicken-srfi-14-" version "-checkout"))
146 (sha256
147 (base32
148 "0wjsqfwawh9bx6vvii1gwag166bxkflc0ib374fbws14914g2ac1"))))
149 (build-system chicken-build-system)
150 (arguments '(#:egg-name "srfi-14"))
151 (home-page "https://wiki.call-cc.org/eggref/5/srfi-14")
152 (synopsis "Character set library")
153 (description
154 "Character sets can be created, extended, tested for the membership of
155 a characters and be compared to other character sets")
156 (license (license:non-copyleft
157 "http://wiki.call-cc.org/eggref/5/srfi-14#license"))))
158
159 (define-public chicken-srfi-69
160 (package
161 (name "chicken-srfi-69")
162 (version "0.4.1")
163 (source
164 (origin
165 (method svn-fetch)
166 (uri (svn-reference
167 (url (string-append "https://code.call-cc.org/svn/chicken-eggs/"
168 "release/5/srfi-69/tags/"
169 version))
170 (revision 39057)
171 (user-name "anonymous")
172 (password "")))
173 (file-name (string-append "chicken-srfi-69-" version "-checkout"))
174 (sha256
175 (base32
176 "1z0m9vmg9bj9z0a941pls6igvg8nmhq4mj5psjjidbp0fac572mp"))))
177 (arguments '(#:egg-name "srfi-69"))
178 (build-system chicken-build-system)
179 (home-page "https://wiki.call-cc.org/eggref/5/srfi-69")
180 (synopsis "Implementation of SRFI 69 with SRFI 90 extensions")
181 (description
182 "This package provides an implementation of
183 @uref{https://srfi.schemers.org/srfi-69/srfi-69.html, SRFI-69 hash tables} for
184 CHICKEN Scheme, along with
185 @uref{https://srfi.schemers.org/srfi-90/srfi-90.html, SRFI-90} extensions.")
186 (license license:bsd-3)))
187
188 (define-public chicken-agrep
189 (package
190 (name "chicken-agrep")
191 (version "1.7")
192 (source
193 (origin
194 (method git-fetch)
195 (uri (git-reference
196 (url "https://github.com/iraikov/chicken-agrep")
197 (commit version)))
198 (file-name (string-append "chicken-agrep-" version "-checkout"))
199 (sha256
200 (base32
201 "0z05x7f154n9bgmainrsmncf5i6dil43r9ymr3rdgwbg4wnxmz4s"))))
202 ;; TODO do we really have to make these propagated?
203 ;; I don't know Chicken's module system well enough to tell
204 (propagated-inputs
205 (list chicken-datatype chicken-srfi-1 chicken-srfi-14))
206 (inputs
207 (list chicken-test))
208 (build-system chicken-build-system)
209 (arguments '(#:egg-name "agrep"))
210 (synopsis "Approximate string matching library")
211 (home-page "https://wiki.call-cc.org/eggref/5/agrep")
212 (description
213 "This library implements the Wu-Manber algorithm for approximate string
214 searching with errors, popularized by the agrep Unix command and the glimpse
215 file indexing tool.")
216 (license license:gpl3+)))
217
218 (define-public chicken-datatype
219 (package
220 (name "chicken-datatype")
221 (version "1.6")
222 (source
223 (origin
224 (method svn-fetch)
225 (uri (svn-reference
226 (url (string-append "https://code.call-cc.org/svn/chicken-eggs/"
227 "release/5/datatype/tags/" version))
228 (revision 39266)
229 (user-name "anonymous")
230 (password "")))
231 (file-name (string-append "chicken-datatype-" version "-checkout"))
232 (sha256
233 (base32
234 "1a58q8ypjkjz6wdv25247wixds4179239d36nnvsfn6gp70s9jfq"))))
235 (build-system chicken-build-system)
236 (arguments '(#:egg-name "datatype"))
237 (inputs
238 (list chicken-srfi-1 chicken-test))
239 (home-page "https://wiki.call-cc.org/eggref/5/datatype")
240 (synopsis "Facility for creating and using variant records")
241 (description
242 "This CHICKEN Scheme library provides a facility for creating and using
243 variant records, as described in the book @i{Essentials of Programming
244 Languages} by Friedman, Wand, and Haynes.")
245 (license license:bsd-3)))
246
247 (define-public chicken-iset
248 (package
249 (name "chicken-iset")
250 (version "2.2")
251 (source
252 (origin
253 (method svn-fetch)
254 (uri (svn-reference
255 (url (string-append "https://code.call-cc.org/svn/chicken-eggs/"
256 "release/5/iset/tags/" version))
257 (revision 39057)
258 (user-name "anonymous")
259 (password "")))
260 (file-name (string-append "chicken-iset-" version "-checkout"))
261 (sha256
262 (base32
263 "0gz50n5i561n5sk9prry0lrxz6bfrq9if5bclaq6a0f7lzinhnzb"))))
264 (inputs
265 (list chicken-test))
266 (build-system chicken-build-system)
267 (arguments '(#:egg-name "iset"))
268 (synopsis "Integer set library")
269 (home-page "https://wiki.call-cc.org/eggref/5/iset")
270 (description
271 "This ``integer set'' CHICKEN Scheme library implements bit vectors.
272 Bit-vectors provide an abstract interface to bitwise operations typically done
273 with integers.")
274 (license license:bsd-3)))
275
276 (define-public chicken-test
277 (package
278 (name "chicken-test")
279 (version "1.1")
280 (source
281 (origin
282 (method svn-fetch)
283 (uri (svn-reference
284 (url (string-append "https://code.call-cc.org/svn/chicken-eggs/"
285 "release/5/test/tags/" version))
286 (revision 39263)
287 (user-name "anonymous")
288 (password "")))
289 (file-name (string-append "chicken-test-" version "-checkout"))
290 (sha256
291 (base32
292 "14i91cxsn6hjkx6kqf7i9syck73cw71jik61jmhg87vpxx5kfnzx"))))
293 (build-system chicken-build-system)
294 (arguments '(#:egg-name "test"))
295 (home-page "https://wiki.call-cc.org/eggref/5/test")
296 (synopsis "Yet another testing utility")
297 (description
298 "This package provides a simple testing utility for CHICKEN Scheme.")
299 (license license:bsd-3)))
300
301 (define-public chicken-crypto-tools
302 (package
303 (name "chicken-crypto-tools")
304 (version "1.4")
305 (source (origin
306 (method url-fetch)
307 (uri (egg-uri "crypto-tools" version))
308 (sha256
309 (base32
310 "0ajf0qfnhp99f4x1dll2fhlxrsxamgrrwyksc7rrym77xmv8f1pd"))))
311 (build-system chicken-build-system)
312 (arguments '(#:egg-name "crypto-tools"))
313 (home-page "https://wiki.call-cc.org/egg/crypto-tools")
314 (synopsis "Useful cryptographic primitives")
315 (description "The crypto-tools egg implements useful cryptographic
316 primitives. More specifically, provided are:
317
318 @itemize
319 @item binary blobs
320 @itemize
321 @item marshallers to and from hex strings
322 @item blob xor
323 @item blob padding using either PKCS#5 or ISO7816-4
324 @end itemize
325 @item Block cipher modes of operation
326 @itemize
327 @item CBC with or without incorporated encrypted IV in the ciphertext
328 @item CTR with or without incorporated IV in the ciphertext
329 @end itemize
330 @end itemize")
331 (license license:bsd-3)))