gnu: emacs-no-x-toolkit: Fix configure flags.
[jackhill/guix/guix.git] / gnu / packages / tmux.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
5 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
6 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
7 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages tmux)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix git-download)
29 #:use-module (guix build-system gnu)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages libevent)
32 #:use-module (gnu packages ncurses))
33
34
35 (define-public tmux
36 (package
37 (name "tmux")
38 (version "2.8")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append
42 "https://github.com/tmux/tmux/releases/download/"
43 version "/tmux-" version ".tar.gz"))
44 (sha256
45 (base32
46 "1fm22wva2znkcs5jczrnlxrpzsk2jlwdwy4dhzzyrbsgccsz6svz"))))
47 (build-system gnu-build-system)
48 (inputs
49 `(("libevent" ,libevent)
50 ("ncurses" ,ncurses)))
51 (home-page "http://tmux.github.io/")
52 (synopsis "Terminal multiplexer")
53 (description
54 "tmux is a terminal multiplexer: it enables a number of terminals (or
55 windows), each running a separate program, to be created, accessed, and
56 controlled from a single screen. tmux may be detached from a screen and
57 continue running in the background, then later reattached.")
58 (license isc)))
59
60 (define-public tmux-themepack
61 (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
62 (revision "1"))
63 (package
64 (name "tmux-themepack")
65 (version (git-version "0.0.0" revision commit)) ; no version tags
66 (source (origin
67 (method git-fetch)
68 (uri (git-reference
69 (url "https://github.com/jimeh/tmux-themepack.git")
70 (commit commit)))
71 (sha256
72 (base32
73 "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
74 (file-name (git-file-name name version))))
75 (build-system gnu-build-system)
76 (arguments
77 `(#:tests? #f ; no test suite
78 #:phases (modify-phases %standard-phases
79 (delete 'configure)
80 (delete 'build)
81 (replace 'install
82 (lambda* (#:key outputs #:allow-other-keys)
83 (let* ((out (string-append
84 (assoc-ref outputs "out")
85 "/share/" ,name "-" ,version)))
86 (copy-recursively "." out)))))))
87 (home-page "https://github.com/jimeh/tmux-themepack")
88 (synopsis "Collection of themes for Tmux")
89 (description "A collection of various themes for Tmux.")
90 (license
91 (non-copyleft "http://www.wtfpl.net/txt/copying/")))))
92
93 (define-public tmuxifier
94 (package
95 (name "tmuxifier")
96 (version "0.13.0")
97 (source (origin
98 (method git-fetch)
99 (uri (git-reference
100 (url "https://github.com/jimeh/tmuxifier.git")
101 (commit (string-append "v" version))))
102 (file-name (git-file-name name version))
103 (sha256
104 (base32
105 "1b6a1cw2mnml84k5vhbcp58kvp94xlnlpp4kwdhqw4jrzfgcjfzd"))))
106 (build-system gnu-build-system)
107 (arguments
108 `(#:tests? #f
109 #:phases (modify-phases %standard-phases
110 (delete 'configure)
111 (delete 'build)
112 (replace 'install
113 (lambda* (#:key outputs #:allow-other-keys)
114 (let* ((out (assoc-ref %outputs "out"))
115 (bindir (string-append out "/bin"))
116 (share (string-append out "/share/" ,name)))
117 (install-file "bin/tmuxifier" bindir)
118 (substitute* (string-append bindir "/tmuxifier")
119 (("set -e")
120 (string-append "TMUXIFIER=" share "\nset -e")))
121 (for-each (lambda (init-script)
122 (install-file init-script (string-append
123 share "/init")))
124 '("init.sh" "init.tcsh" "init.fish"))
125 (for-each (lambda (dir)
126 (copy-recursively dir (string-append
127 share "/" dir)))
128 '("completion" "lib" "libexec"
129 "templates"))))))))
130 (home-page "https://github.com/jimeh/tmuxifier")
131 (synopsis "Powerful session, window & pane management for Tmux")
132 (description "Tmuxifier allows you to easily create, edit, and load
133 @code{layout} files, which are simple shell scripts where you use the tmux
134 command and helper commands provided by tmuxifier to manage Tmux sessions and
135 windows.")
136 (license expat)))