Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gnunet.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gnunet)
20 #:use-module (gnu packages autotools)
21 #:use-module (gnu packages compression)
22 #:use-module (gnu packages curl)
23 #:use-module (gnu packages gettext)
24 #:use-module (gnu packages glib)
25 #:use-module (gnu packages gnupg)
26 #:use-module (gnu packages gnutls)
27 #:use-module (gnu packages libjpeg)
28 #:use-module (gnu packages libtiff)
29 #:use-module (gnu packages oggvorbis)
30 #:use-module (gnu packages openssl)
31 #:use-module (gnu packages pkg-config)
32 #:use-module ((guix licenses)
33 #:renamer (symbol-prefix-proc 'license:))
34 #:use-module (guix packages)
35 #:use-module (guix download)
36 #:use-module (guix build-system gnu))
37
38 (define-public libextractor
39 (package
40 (name "libextractor")
41 (version "1.2")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "mirror://gnu/libextractor/libextractor-"
45 version ".tar.gz"))
46 (sha256
47 (base32
48 "1n7z6s5ils6xmf6b0z1xda41maxj94c1n6wlyyxmacs5lrkh2a96"))))
49 (build-system gnu-build-system)
50 ;; WARNING: Checks require /dev/shm to be in the build chroot, especially
51 ;; not to be a symbolic link to /run/shm.
52 ;; FIXME:
53 ;; The following dependencies are all optional, but should be
54 ;; available for maximum coverage:
55 ;; * libarchive
56 ;; * libavutil / libavformat / libavcodec / libswscale (ffmpeg)
57 ;; * libexiv2
58 ;; * libgif (giflib)
59 ;; * libgtk+ >= 3.0.0 (may probably drop glib then as a propagated input of
60 ;; gtk)
61 ;; * libgsf
62 ;; * libgstreamer
63 ;; * libmagic (file)
64 ;; * libmpeg2
65 ;; * libmp4v2
66 ;; * librpm
67 ;; * libsmf
68 ;; * libtidy
69 (inputs
70 `(("gettext" ,gnu-gettext)
71 ("flac" ,flac)
72 ("glib" ,glib)
73 ("libjpeg" ,libjpeg)
74 ("libogg" ,libogg)
75 ("libtiff" ,libtiff)
76 ("libtool" ,libtool)
77 ("libvorbis" ,libvorbis)
78 ("pkg-config" ,pkg-config)
79 ("zlib" ,zlib)))
80 (synopsis "Library to extract meta-data from media files")
81 (description
82 "GNU Libextractor is a library for extracting metadata from files. It
83 supports a very large number of file formats, including audio files, document
84 files, and archive files. Each file format is implemented as a plugin, so
85 new formats can be added easily. The package also containes a command-line
86 tool to extract metadata from a file and print the results.")
87 (license license:gpl3+)
88 (home-page "http://www.gnu.org/software/libextractor/")))
89
90 (define-public libmicrohttpd
91 (package
92 (name "libmicrohttpd")
93 (version "0.9.31")
94 (source (origin
95 (method url-fetch)
96 (uri (string-append "mirror://gnu/libmicrohttpd/libmicrohttpd-"
97 version ".tar.gz"))
98 (sha256
99 (base32
100 "06sxxial1794589k0ahi7nhhyfp14jf4jwirf6bkxqhs138pghfa"))))
101 (build-system gnu-build-system)
102 (inputs
103 `(("curl" ,curl)
104 ("gnutls" ,gnutls)
105 ("libgcrypt" ,libgcrypt)
106 ("openssl" ,openssl)
107 ("zlib" ,zlib)))
108 (arguments
109 `(#:parallel-tests? #f))
110 (synopsis "C library implementing an HTTP 1.1 server")
111 (description
112 "GNU libmicrohttpd is a small, embeddable HTTP server implemented as a
113 C library. It makes it easy to run an HTTP server as part of another
114 application. The library is fully HTTP 1.1 compliant. It can listen on
115 multiple ports, supports four different threading models, and supports
116 IPv6. It
117 also features security features such as basic and digest authentication
118 and support for SSL3 and TLS.")
119 (license license:lgpl2.1+)
120 (home-page "http://www.gnu.org/software/libmicrohttpd/")))