gnu: upower: Enable GObject introspection.
[jackhill/guix/guix.git] / gnu / packages / shishi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages shishi)
22 #:use-module ((guix licenses) #:select (gpl3+))
23 #:use-module (gnu packages)
24 #:use-module (gnu packages gnupg)
25 #:use-module (gnu packages libidn)
26 #:use-module (gnu packages linux)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages tls)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu))
33
34 (define-public shishi
35 (package
36 (name "shishi")
37 (version "1.0.2")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "mirror://gnu/shishi/shishi-"
42 version ".tar.gz"))
43 (sha256
44 (base32
45 "032qf72cpjdfffq1yq54gz3ahgqf2ijca4vl31sfabmjzq9q370d"))))
46 (build-system gnu-build-system)
47 (native-inputs `(("pkg-config" ,pkg-config)))
48 (inputs
49 `(("gnutls" ,gnutls)
50 ("libidn" ,libidn)
51 ("linux-pam" ,linux-pam)
52 ("zlib" ,zlib)
53 ;; libgcrypt 1.6 fails because of the following test:
54 ;; #include <gcrypt.h>
55 ;; /* GCRY_MODULE_ID_USER was added in 1.4.4 and gc-libgcrypt.c
56 ;; will fail on startup if we don't have 1.4.4 or later, so
57 ;; test for it early. */
58 ;; #if !defined GCRY_MODULE_ID_USER
59 ;; error too old libgcrypt
60 ;; #endif
61 ("libgcrypt" ,libgcrypt-1.5)
62 ("libtasn1" ,libtasn1)))
63 (home-page "http://www.gnu.org/software/shishi/")
64 (synopsis "Implementation of the Kerberos 5 network security system")
65 (description
66 "GNU Shishi is a free implementation of the Kerberos 5 network security
67 system. It is used to allow non-secure network nodes to communicate in a
68 secure manner through client-server mutual authentication via tickets.")
69 (license gpl3+)))