gnu: upower: Enable GObject introspection.
[jackhill/guix/guix.git] / gnu / packages / patches / serf-deflate-buckets-test-fix.patch
1 r2445 | chemodax | 2014-10-23 12:15:22 -0400 (Thu, 23 Oct 2014) | 6 lines
2
3 Reduce memory usage by deflate buckets test.
4
5 * test/test_buckets.c
6 (deflate_buckets): Add POOL argument and use it instead of tb->pool.
7 (test_deflate_buckets): Use iterpool for deflate_buckets() call.
8
9 Index: test/test_buckets.c
10 ===================================================================
11 --- test/test_buckets.c (revision 2444)
12 +++ test/test_buckets.c (revision 2445)
13 @@ -1400,12 +1400,12 @@
14 expected_len);
15 }
16
17 -static void deflate_buckets(CuTest *tc, int nr_of_loops)
18 +static void deflate_buckets(CuTest *tc, int nr_of_loops, apr_pool_t *pool)
19 {
20 const char *msg = "12345678901234567890123456789012345678901234567890";
21
22 test_baton_t *tb = tc->testBaton;
23 - serf_bucket_alloc_t *alloc = serf_bucket_allocator_create(tb->pool, NULL,
24 + serf_bucket_alloc_t *alloc = serf_bucket_allocator_create(pool, NULL,
25 NULL);
26 z_stream zdestr;
27 int i;
28 @@ -1424,8 +1424,8 @@
29 {
30 serf_config_t *config;
31
32 - serf_context_t *ctx = serf_context_create(tb->pool);
33 - /* status = */ serf__config_store_get_config(ctx, NULL, &config, tb->pool);
34 + serf_context_t *ctx = serf_context_create(pool);
35 + /* status = */ serf__config_store_get_config(ctx, NULL, &config, pool);
36
37 serf_bucket_set_config(defbkt, config);
38 }
39 @@ -1447,11 +1447,11 @@
40 if (i == nr_of_loops - 1) {
41 CuAssertIntEquals(tc, APR_SUCCESS,
42 deflate_compress(&data, &len, &zdestr, msg,
43 - strlen(msg), 1, tb->pool));
44 + strlen(msg), 1, pool));
45 } else {
46 CuAssertIntEquals(tc, APR_SUCCESS,
47 deflate_compress(&data, &len, &zdestr, msg,
48 - strlen(msg), 0, tb->pool));
49 + strlen(msg), 0, pool));
50 }
51
52 if (len == 0)
53 @@ -1469,10 +1469,15 @@
54 static void test_deflate_buckets(CuTest *tc)
55 {
56 int i;
57 + apr_pool_t *iterpool;
58 + test_baton_t *tb = tc->testBaton;
59
60 + apr_pool_create(&iterpool, tb->pool);
61 for (i = 1; i < 1000; i++) {
62 - deflate_buckets(tc, i);
63 + apr_pool_clear(iterpool);
64 + deflate_buckets(tc, i, iterpool);
65 }
66 + apr_pool_destroy(iterpool);
67 }
68
69 static apr_status_t discard_data(serf_bucket_t *bkt,