gnu: upower: Enable GObject introspection.
[jackhill/guix/guix.git] / gnu / packages / patches / evilwm-lost-focus-bug.patch
1 evilwm may sometimes lose focus after closing a window. This means that
2 evilwm stops responding to keyboard shortcuts, and if no other window is open
3 which the mouse can be moved over to regain focus evilwm becomes unusable and
4 has to be restarted.
5
6 Patch derived from discussion at
7 https://wiki.archlinux.org/index.php/Evilwm#Lost_focus_bug_fix
8
9 --- evilwm-1.1.1/client.c
10 +++ evilwm-1.1.1/client.c
11 @@ -172,6 +172,7 @@
12 * _NET_WM_STATE) */
13 if (c->remove) {
14 LOG_DEBUG("setting WithdrawnState\n");
15 + XSetInputFocus(dpy, PointerRoot, RevertToPointerRoot, CurrentTime);
16 set_wm_state(c, WithdrawnState);
17 ewmh_withdraw_client(c);
18 } else {