gnu: upower: Enable GObject introspection.
[jackhill/guix/guix.git] / gnu / packages / patches / bigloo-gc-shebangs.patch
1 Patch shebangs in source that gets unpacked by `configure'.
2
3 --- bigloo4.1a/gc/install-gc-7.4.0 2014-02-04 14:55:03.000000000 +0100
4 +++ bigloo4.1a/gc/install-gc-7.4.0 2014-02-04 14:55:36.000000000 +0100
5 @@ -29,10 +29,12 @@ fi
6
7 # untar the two versions of the GC
8 $tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
9 -/bin/rm -rf "../gc/$gc"_fth
10 +rm -rf "../gc/$gc"_fth
11 +find ../gc/$gc -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P sh`|g"
12 mv ../gc/$gc "../gc/$gc"_fth || (echo "mv $gc failed"; exit 1)
13
14 $tar xfz $src -C ../gc || (echo "$tar xfz $src failed"; exit 1)
15 +find ../gc/$gc -perm /111 -type f | xargs sed -i -e"s|/bin/sh|`type -P sh`|g"
16
17 # general Bigloo patch
18 (cd "../gc/$gc"_fth && $patch -p1 < ../$gc.patch > /dev/null)