gnu: upower: Enable GObject introspection.
[jackhill/guix/guix.git] / gnu / packages / moreutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages moreutils)
20 #:use-module ((guix licenses) #:prefix l:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages xml)
26 #:use-module (gnu packages docbook))
27
28 (define-public moreutils
29 (package
30 (name "moreutils")
31 (version "0.55")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append
35 "mirror://debian/pool/main/m/moreutils/moreutils_"
36 version ".orig.tar.gz"))
37 (sha256
38 (base32
39 "1dcah2jx8dbznn8966xl7sf1jrld2qfh6l6xcmx9dsnf8p8mr7fs"))))
40 (build-system gnu-build-system)
41 (inputs `(("perl" ,perl)
42 ("libxml2" ,libxml2)
43 ("libxslt" ,libxslt)
44 ("docbook-xml" ,docbook-xml-4.4)
45 ("docbook-xsl" ,docbook-xsl)))
46 (arguments
47 `(#:phases
48 (alist-replace
49 'configure
50 (lambda* (#:key inputs #:allow-other-keys)
51 (use-modules (srfi srfi-1))
52 (substitute* "Makefile"
53 (("/usr/share/xml/.*/docbook.xsl")
54 (let* ((docbook-xsl (assoc-ref inputs "docbook-xsl"))
55 (files (find-files docbook-xsl "^docbook\\.xsl$")))
56 (find (lambda (file)
57 (string-suffix? "/manpages/docbook.xsl" file))
58 files)))))
59 %standard-phases)
60 #:make-flags
61 (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
62 "CC=gcc")))
63 (home-page "http://joeyh.name/code/moreutils/")
64 (synopsis "Miscellaneous general-purpose command-line tools")
65 (description
66 "Moreutils is a collection of general-purpose command-line tools to
67 augment the traditional Unix toolbox.")
68 (license l:gpl2+)))