gnu: upower: Enable GObject introspection.
[jackhill/guix/guix.git] / gnu / packages / libffcall.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libffcall)
21 #:use-module ((guix licenses) #:prefix l:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix cvs-download)
25 #:use-module (guix build-system gnu))
26
27 (define-public libffcall
28 (package
29 (name "libffcall")
30 (version "1.10+cvs-2015-01-15")
31 (source
32 (origin
33 (method cvs-fetch)
34 (uri (cvs-reference
35 (root-directory
36 ":pserver:anonymous@cvs.savannah.gnu.org:/sources/libffcall")
37 (module "ffcall")
38 (revision "2015-01-15")))
39 (sha256
40 (base32
41 "1lwdskc2w4rr98x9flr2726lmj4190l16r0izg7gqxy50801wwgd"))))
42 (build-system gnu-build-system)
43 (arguments `(#:parallel-build? #f))
44 (synopsis "Foreign function calls from interpreters")
45 (description
46 "GNU Libffcall is a collection of libraries that can be used to build
47 foreign function call interfaces in embedded interpreters.")
48 (home-page "http://www.gnu.org/software/libffcall/")
49 (license l:gpl2+)))