gnu: upower: Enable GObject introspection.
[jackhill/guix/guix.git] / gnu / packages / gnustep.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gnustep)
20 #:use-module (guix download)
21 #:use-module (guix packages)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages fontutils)
26 #:use-module (gnu packages image)
27 #:use-module (gnu packages pkg-config))
28
29 (define-public windowmaker
30 (package
31 (name "windowmaker")
32 (version "0.95.6")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append
36 "http://windowmaker.org/pub/source/release/WindowMaker-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "1i3dw1yagsa3rs9x2na2ynqlgmbahayws0kz4vl00fla6550nns3"))))
41 (build-system gnu-build-system)
42 (arguments
43 '(#:phases (alist-cons-before
44 'configure 'pre-configure
45 (lambda* (#:key outputs #:allow-other-keys)
46 ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
47 ;; and the 'wmsetbg', so make sure it uses the right ones.
48 ;; We can't use a wrapper here because that would pollute
49 ;; $PATH in the whole session.
50 (let* ((out (assoc-ref outputs "out"))
51 (bin (string-append out "/bin")))
52 (substitute* "src/main.c"
53 (("\"wmaker\\.inst")
54 (string-append "\"" bin "/wmaker.inst")))
55 (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
56 (("\"wmsetbg")
57 (string-append "\"" bin "/wmsetbg")))))
58 (alist-cons-after
59 'install 'wrap
60 (lambda* (#:key outputs #:allow-other-keys)
61 (let* ((out (assoc-ref outputs "out"))
62 (bin (string-append out "/bin")))
63 ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
64 ;; etc., so make sure everything is in $PATH.
65 (wrap-program (string-append bin "/wmaker.inst")
66 `("PATH" ":" prefix (,bin)))))
67 %standard-phases))))
68 (inputs
69 `(("libxmu" ,libxmu)
70 ("libxft" ,libxft)
71 ("libx11" ,libx11)
72 ("fontconfig" ,fontconfig)
73 ("libjpeg" ,libjpeg)))
74 (native-inputs
75 `(("pkg-config" ,pkg-config)))
76 (home-page "http://windowmaker.org/")
77 (synopsis "NeXTSTEP-like window manager")
78 (description
79 "Window Maker is an X11 window manager originally designed to provide
80 integration support for the GNUstep Desktop Environment. In every way
81 possible, it reproduces the elegant look and feel of the NeXTSTEP user
82 interface. It is fast, feature rich, easy to configure, and easy to use.")
83
84 ;; Artwork is distributed under the WTFPL.
85 (license gpl2+)))