gnu: perl: Actually produce a host perl when cross-compiling.
[jackhill/guix/guix.git] / gnu / packages / patches / perl-cross.patch
1 Submitted upstream.
2
3 From 4c3eb19a11dfe5c88c902481a8294c4f675fcd03 Mon Sep 17 00:00:00 2001
4 From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
5 Date: Sun, 19 Apr 2020 23:33:28 +0200
6 Subject: [PATCH] Support cross-compiling to the Hurd.
7
8 * cnf/hints/gnu: New file.
9 * cnf/configure_tool.sh: Guess it.
10 ---
11 cnf/configure_tool.sh | 4 ++++
12 cnf/hints/gnu | 21 +++++++++++++++++++++
13 2 files changed, 25 insertions(+)
14 create mode 100644 cnf/hints/gnu
15
16 diff --git a/cnf/configure_tool.sh b/cnf/configure_tool.sh
17 index 32201c0..7b0baa4 100644
18 --- a/cnf/configure_tool.sh
19 +++ b/cnf/configure_tool.sh
20 @@ -266,6 +266,10 @@ if not hinted 'osname'; then
21 define osname "bsd"
22 result "BSD"
23 ;;
24 + *-gnu*)
25 + define osname "gnu"
26 + result "GNU"
27 + ;;
28 *)
29 result "no"
30 ;;
31 diff --git a/cnf/hints/gnu b/cnf/hints/gnu
32 new file mode 100644
33 index 0000000..a0583a2
34 --- /dev/null
35 +++ b/cnf/hints/gnu
36 @@ -0,0 +1,21 @@
37 +# Hurd syscalls
38 +d_voidsig='define'
39 +d_nanosleep='undef'
40 +d_clock_gettime='define'
41 +d_clock_getres='define'
42 +d_clock_nanosleep='define'
43 +d_clock='define'
44 +
45 +# From the original linux.sh
46 +usemallocwrap='define'
47 +
48 +# libraries to test
49 +libswanted='m crypt pthread nm ndbm gdbm dbm db dl gdbm_compat'
50 +
51 +d_procselfexe='undef'
52 +procselfexe='"undef"'
53 +
54 +st_ino_sign=1
55 +st_ino_size=8
56 +
57 +d_fcntl_can_lock='define'
58 --
59 2.26.0
60