gnu: emacs-helm: Update to 3.8.7.
[jackhill/guix/guix.git] / gnu / packages / scribus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017, 2018, 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
5 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
6 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages scribus)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix utils)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix build-system cmake)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages boost)
32 #:use-module (gnu packages compression)
33 #:use-module (gnu packages cups)
34 #:use-module (gnu packages fontutils)
35 #:use-module (gnu packages ghostscript)
36 #:use-module (gnu packages gtk)
37 #:use-module (gnu packages icu4c)
38 #:use-module (gnu packages image)
39 #:use-module (gnu packages imagemagick)
40 #:use-module (gnu packages libreoffice)
41 #:use-module (gnu packages linux)
42 #:use-module (gnu packages pdf)
43 #:use-module (gnu packages pkg-config)
44 #:use-module (gnu packages python)
45 #:use-module (gnu packages qt)
46 #:use-module (gnu packages tls)
47 #:use-module (gnu packages xml))
48
49 (define-public scribus
50 (package
51 (name "scribus")
52 (version "1.5.8")
53 (source
54 (origin
55 (method url-fetch)
56 (uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
57 version "/scribus-" version ".tar.xz"))
58 (sha256
59 (base32 "0x3bw58v920akca8jxvsfwf468pzjyglk93ay67ph1bdry7nx0a7"))))
60 (build-system cmake-build-system)
61 (arguments
62 `(#:tests? #f ;no test target
63 #:configure-flags
64 '("-DWANT_GRAPHICSMAGICK=1")))
65 (inputs
66 (list boost
67 cairo
68 cups
69 fontconfig
70 freetype
71 graphicsmagick
72 harfbuzz
73 hunspell
74 icu4c
75 lcms
76 libcdr
77 libfreehand
78 libjpeg-turbo
79 libmspub
80 libpagemaker
81 librevenge
82 libtiff
83 libvisio
84 libxml2
85 libzmf
86 openssl
87 podofo
88 poppler
89 python ;need Python library
90 qtbase-5
91 qtdeclarative-5
92 zlib))
93 (native-inputs
94 (list pkg-config qttools-5 util-linux))
95 (home-page "https://www.scribus.net")
96 (synopsis "Desktop publishing and page layout program")
97 (description
98 "Scribus is a @dfn{desktop publishing} (DTP) application and can
99 be used for many tasks; from brochure design to newspapers, magazines,
100 newsletters and posters to technical documentation. Scribus supports
101 professional DTP features, such as CMYK color and a color management
102 system to soft proof images for high quality color printing, flexible
103 PDF creation options, Encapsulated PostScript import/export and
104 creation of four color separations, import of EPS/PS and SVG as native
105 vector graphics, Unicode text including right to left scripts such as
106 Arabic and Hebrew via FreeType.")
107 (license license:gpl2+)))