gnu: emacs-helm: Update to 3.8.7.
[jackhill/guix/guix.git] / gnu / packages / perl-web.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages perl-web)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (gnu packages)
24 #:use-module (guix packages)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages perl-check)
27 #:use-module (guix download)
28 #:use-module (guix build-system perl)
29 #:use-module (gnu packages web))
30
31 (define-public perl-mojolicious
32 (package
33 (name "perl-mojolicious")
34 (version "9.17")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://cpan/authors/id/S/SR/SRI/Mojolicious-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "13dxjhr03dhh1f5bbxbb3jiwdv7jby96qqb97l3arf5x043yd9hd"))))
43 (build-system perl-build-system)
44 (home-page "https://mojolicious.org/")
45 (synopsis "Real-time web framework")
46 (description "Back in the early days of the web, many people learned Perl
47 because of a wonderful Perl library called @code{CGI}. It was simple enough
48 to get started without knowing much about the language and powerful enough to
49 keep you going, learning by doing was much fun. While most of the techniques
50 used are outdated now, the idea behind it is not. Mojolicious is a new
51 endeavor to implement this idea using modern technologies.")
52 (license license:artistic2.0)))
53
54 (define-public perl-uri-db
55 (package
56 (name "perl-uri-db")
57 (version "0.19")
58 (source
59 (origin
60 (method url-fetch)
61 (uri (string-append
62 "mirror://cpan/authors/id/D/DW/DWHEELER/URI-db-"
63 version
64 ".tar.gz"))
65 (sha256
66 (base32
67 "0n56xxlw7c39pfar0dxckr9mbmp6yrzk53ic0cb24raiykm9v6f4"))))
68 (build-system perl-build-system)
69 (native-inputs
70 (list perl-module-build))
71 (propagated-inputs
72 (list perl-uri perl-uri-nested))
73 (home-page "https://metacpan.org/release/URI-db")
74 (synopsis "Handle database URIs")
75 (description
76 "This module defines a format for database URIs, and provides a @{URI}
77 class to handle these.")
78 (license license:perl-license)))
79
80 (define-public perl-uri-escape
81 (package
82 (name "perl-uri-escape")
83 (version "1.76")
84 (source
85 (origin
86 (method url-fetch)
87 (uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/URI-"
88 version ".tar.gz"))
89 (sha256
90 (base32
91 "0gj1aj18k43kmzc3y1zhj5giinf8rksacf757r475xfna0fqxjdj"))))
92 (build-system perl-build-system)
93 (native-inputs
94 (list perl-test-needs))
95 (home-page "https://github.com/libwww-perl/URI")
96 (synopsis "Percent-encode and percent-decode unsafe characters")
97 (description "This module provides functions to percent-encode and
98 percent-decode URI strings as defined by RFC 3986. Percent-encoding URI's is
99 informally called URI escaping. This is the terminology used by this module,
100 which predates the formalization of the terms by the RFC by several years.")
101 (license license:perl-license)))
102
103 (define-public perl-uri-nested
104 (package
105 (name "perl-uri-nested")
106 (version "0.10")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (string-append
111 "mirror://cpan/authors/id/D/DW/DWHEELER/URI-Nested-"
112 version
113 ".tar.gz"))
114 (sha256
115 (base32
116 "1bzg6f11m8wfnmycflvp858rs99xknsx8hkip0xcdfjzlqwi75z1"))))
117 (build-system perl-build-system)
118 (native-inputs
119 (list perl-module-build))
120 (propagated-inputs
121 (list perl-uri))
122 (home-page "https://metacpan.org/release/URI-Nested")
123 (synopsis "Nested URIs")
124 (description
125 "@code{URI::Nested} provides support for nested URIs, where the scheme is
126 a prefix, and the remainder of the URI is another URI.")
127 (license license:perl-license)))