gnu: Move Linux-Libre modules to their own section.
[jackhill/guix/guix.git] / gnu / packages / nutrition.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages nutrition)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system python)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages databases)
28 #:use-module (gnu packages gtk)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages python)
32 #:use-module (gnu packages python-xyz))
33
34 (define-public gourmet
35 (package
36 (name "gourmet")
37 (version "0.17.4")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "https://github.com/thinkle/gourmet/archive/"
42 version ".tar.gz"))
43 (file-name (string-append name "-" version ".tar.gz"))
44 (sha256
45 (base32
46 "1qvz175arzqm10lpfx8ffadrgirs3240zzqcp0h7sl53qfwx7v8k"))))
47 (build-system python-build-system)
48 (native-inputs
49 `(("distutils-extra" ,python2-distutils-extra)
50 ("intltool" ,intltool)
51 ("python-pygtk" ,python2-pygtk))) ;for tests
52 ;; TODO: Add python-reportlab and/or python-poppler for printing/pdf
53 ;; export, and python-beautifulsoup for web import plugin.
54 (inputs
55 `(("pygtk" ,python2-pygtk)
56 ("sqlalchemy" ,python2-sqlalchemy)
57 ("python-lxml" ,python2-lxml)
58 ("python-pillow" ,python2-pillow)
59 ("elib.intl" ,python2-elib.intl)))
60 (arguments
61 `(#:python ,python-2 ;exception and print syntax
62 #:tests? #f ;tests look bitrotted
63 #:phases
64 (modify-phases %standard-phases
65 (replace 'install
66 (lambda* (#:key make-flags #:allow-other-keys)
67 (invoke "python" "setup.py" "install" "--prefix"
68 (assoc-ref %outputs "out")))))))
69 (home-page "https://thinkle.github.io/gourmet/")
70 (synopsis "Recipe organizer")
71 (description
72 "Gourmet Recipe Manager is a recipe organizer that allows you to collect,
73 search, organize, and browse your recipes. Gourmet can also generate shopping
74 lists and calculate nutritional information. It imports Mealmaster,
75 MasterCook and KRecipe files and exports PDFs, webpages, and other formats.")
76 (license gpl2+)))