gnu: Add fail2ban.
[jackhill/guix/guix.git] / gnu / packages / patches / fail2ban-python310-server-jails.patch
1 From 9f1d1f4fbd0804695a976beb191f2c49a2739834 Mon Sep 17 00:00:00 2001
2 From: "Sergey G. Brester" <serg.brester@sebres.de>
3 Date: Mon, 8 Feb 2021 17:35:59 +0100
4 Subject: [PATCH] amend for `Mapping` (jails)
5
6 ---
7 fail2ban/server/jails.py | 5 ++++-
8 1 file changed, 4 insertions(+), 1 deletion(-)
9
10 diff --git a/fail2ban/server/jails.py b/fail2ban/server/jails.py
11 index 972a8c4bd2..27e12ddf65 100644
12 --- a/fail2ban/server/jails.py
13 +++ b/fail2ban/server/jails.py
14 @@ -22,7 +22,10 @@
15 __license__ = "GPL"
16
17 from threading import Lock
18 -from collections import Mapping
19 +try:
20 + from collections.abc import Mapping
21 +except ImportError:
22 + from collections import Mapping
23
24 from ..exceptions import DuplicateJailException, UnknownJailException
25 from .jail import Jail