hydra: Fix typo in core package list.
[jackhill/guix/guix.git] / gnu / packages / sqlite.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages sqlite)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages))
25
26 (define-public sqlite
27 (package
28 (name "sqlite")
29 (version "3.8.2")
30 (source (origin
31 (method url-fetch)
32 ;; TODO: Download from sqlite.org once this bug :
33 ;; http://lists.gnu.org/archive/html/bug-guile/2013-01/msg00027.html
34 ;; has been fixed.
35 (uri (string-append
36 "mirror://sourceforge/sqlite.mirror/SQLite%20"
37 version "/sqlite-autoconf-3080200.tar.gz"))
38 (sha256
39 (base32
40 "14pg9zlwbwsj5w7f3qr25d3nniyv82gmczwlvpj0i0ic1431v1d0"))))
41 (build-system gnu-build-system)
42 (home-page "http://www.sqlite.org/")
43 (synopsis "The SQLite database management system")
44 (description
45 "SQLite is a software library that implements a self-contained, serverless,
46 zero-configuration, transactional SQL database engine. SQLite is the most
47 widely deployed SQL database engine in the world. The source code for SQLite is
48 in the public domain.")
49 (license public-domain)))