hydra: Fix typo in core package list.
[jackhill/guix/guix.git] / gnu / packages / gstreamer.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gstreamer)
20 #:use-module ((guix licenses) #:select (lgpl2.0+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages flex)
27 #:use-module (gnu packages glib)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages xml))
32
33 (define-public gstreamer
34 (package
35 (name "gstreamer")
36 (version "1.0.10")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
41 version ".tar.xz"))
42 (sha256
43 (base32
44 "0c0irk85jd2cihm5pmf4zxhlpg08qpxjcqv1l9qn2n3h2gsaj2lf"))))
45 (build-system gnu-build-system)
46 (arguments
47 ;; XXX: Temporarily disable tests to work around 'gst/gstbus' test
48 ;; failure: <https://bugzilla.gnome.org/show_bug.cgi?id=724073>.
49 '(#:tests? #f))
50 (inputs `(("glib" ,glib)))
51 (native-inputs
52 `(("bison" ,bison)
53 ("flex" ,flex)
54 ("perl" ,perl)
55 ("pkg-config" ,pkg-config)
56 ("python-wrapper" ,python-wrapper)))
57 (home-page "http://gstreamer.freedesktop.org/")
58 (synopsis "Multimedia library")
59 (description
60 "GStreamer is a library for constructing graphs of media-handling
61 components. The applications it supports range from simple Ogg/Vorbis
62 playback, audio/video streaming to complex audio (mixing) and video
63 (non-linear editing) processing.
64
65 Applications can take advantage of advances in codec and filter technology
66 transparently. Developers can add new codecs and filters by writing a
67 simple plugin with a clean, generic interface.
68
69 This package provides the core library and elements.")
70 (license lgpl2.0+)))
71
72 (define-public gstreamer-0.10
73 (package (inherit gstreamer)
74 (version "0.10.36")
75 (source
76 (origin
77 (method url-fetch)
78 (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
79 version ".tar.xz"))
80 (sha256
81 (base32
82 "1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
83 (patches
84 (list (search-patch "gstreamer-0.10-bison3.patch")
85 (search-patch "gstreamer-0.10-silly-test.patch")))))
86 (propagated-inputs
87 `(("libxml2" ,libxml2)))
88 (inputs `(("glib" ,glib)))
89 (native-inputs
90 `(("bison" ,bison)
91 ("flex" ,flex)
92 ("perl" ,perl)
93 ("pkg-config" ,pkg-config)
94 ("python" ,python-2)))))
95
96 (define-public gst-plugins-base
97 (package
98 (name "gst-plugins-base")
99 (version "1.0.10")
100 (source
101 (origin
102 (method url-fetch)
103 (uri (string-append "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
104 version ".tar.xz"))
105 (sha256
106 (base32
107 "1s4pphbb5kpdh4rrmb8rala4sp499k4by59925k15xiz58xyhm4p"))))
108 (build-system gnu-build-system)
109 ;; FIXME: Add more dependencies for further plugins.
110 (inputs
111 `(("glib" ,glib)
112 ("gstreamer" ,gstreamer)))
113 (native-inputs
114 `(("pkg-config" ,pkg-config)
115 ("python-wrapper" ,python-wrapper)))
116 (arguments
117 `(#:tests? #f))
118 ;; All tests pass except for one:
119 ;; Running suite(s): pbutils library
120 ;; 85%: Checks: 7, Failures: 1, Errors: 0
121 ;; libs/pbutils.c:522:F:general:test_pb_utils_install_plugins:0: gst_install_plugins_sync() failed ;; with unexpected ret 201, which is neither HELPER_MISSING nor 1
122 ;; FAIL: libs/pbutils
123 ;; According to the documentation, "gst_install_plugins_sync (...)
124 ;; should almost never be used".
125 (home-page "http://gstreamer.freedesktop.org/")
126 (synopsis
127 "Plugins for the gstreamer multimedia library")
128 (description
129 "GStreamer is a library for constructing graphs of media-handling
130 components. The applications it supports range from simple Ogg/Vorbis
131 playback, audio/video streaming to complex audio (mixing) and video
132 (non-linear editing) processing.
133
134 Applications can take advantage of advances in codec and filter technology
135 transparently. Developers can add new codecs and filters by writing a
136 simple plugin with a clean, generic interface.
137
138 This package provides an essential exemplary set of elements.")
139 (license lgpl2.0+)))
140
141 (define-public gst-plugins-base-0.10
142 (package (inherit gst-plugins-base)
143 (version "0.10.36")
144 (source
145 (origin
146 (method url-fetch)
147 (uri (string-append "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
148 version ".tar.xz"))
149 (sha256
150 (base32
151 "0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
152 (inputs
153 `(("glib" ,glib)
154 ("gstreamer" ,gstreamer-0.10)))
155 (native-inputs
156 `(("pkg-config" ,pkg-config)
157 ("python" ,python-2)))))