hydra: Fix typo in core package list.
[jackhill/guix/guix.git] / gnu / packages / gnu-pw-mgr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gnu-pw-mgr)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages which))
26
27 (define-public gnu-pw-mgr
28 (package
29 (name "gnu-pw-mgr")
30 (version "1.1")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/gnu-pw-mgr/gpw-"
35 version "/gnu-pw-mgr-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "1nqkwjsdcif51d1s4dizr1ifx0qpmkjzvi375vc27dwbav4dwalx"))))
40 (build-system gnu-build-system)
41 (inputs `(("which" ,which)))
42 (home-page "http://www.gnu.org/software/gnu-pw-mgr/")
43 (synopsis "Retrieve login credentials without recording passwords")
44 (description
45 "This program is designed to make it easy to reconstruct difficult
46 passwords when they are needed while limiting the risk of attack. The
47 user of this program inputs a self-defined transformation of a web
48 site URL and obtains the password and user name hint for that web
49 site.")
50 (license gpl3+)))