gnu: breeze: Split from breeze-icons.
[jackhill/guix/guix.git] / gnu / packages / kde-plasma.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
3 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
4 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
5 ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages kde-plasma)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix build-system cmake)
28 #:use-module (guix build-system qt)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages freedesktop)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages kde-frameworks)
33 #:use-module (gnu packages linux)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages qt)
36 #:use-module (gnu packages xorg))
37
38 (define-public breeze
39 (package
40 (name "breeze")
41 (version "5.19.5")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "mirror://kde/stable/plasma/" version "/"
45 name "-" version ".tar.xz"))
46 (sha256
47 (base32
48 "0dpk1w7zcafrzf46j060i1qb0fwqpsflkfzr6gcar81llmjnc4b1"))))
49 (build-system qt-build-system)
50 ;; TODO: Warning at /gnu/store/…-kpackage-5.34.0/…/KF5PackageMacros.cmake:
51 ;; warnings during generation of metainfo for org.kde.breezedark.desktop:
52 ;; Package type "Plasma/LookAndFeel" not found
53 ;; TODO: Check whether is makes sence splitting into several outputs, like
54 ;; Debian does:
55 ;; - breeze-cursor-theme
56 ;; - "out", "devel"
57 ;; - kde-style-breeze - Widget style
58 ;; - kde-style-breeze-qt4 - propably not useful
59 ;; - kwin-style-breeze
60 ;; - qml-module-qtquick-controls-styles-breeze - QtQuick style
61 (native-inputs
62 `(("extra-cmake-modules" ,extra-cmake-modules)
63 ("pkg-config" ,pkg-config)))
64 (inputs
65 `(("kcmutils" ,kcmutils) ; optional
66 ("kconfigwidgets" ,kconfigwidgets)
67 ("kcoreaddons" ,kcoreaddons)
68 ("kde-frameworkintegration" ,kde-frameworkintegration) ; optional
69 ("kdecoration" ,kdecoration)
70 ("kguiaddons" ,kguiaddons)
71 ("ki18n" ,ki18n)
72 ("kiconthemes" ,kiconthemes) ; for optional kde-frameworkintegration
73 ("kpackage" ,kpackage)
74 ("kwayland" ,kwayland) ; optional
75 ("kwindowsystem" ,kwindowsystem)
76 ("qtbase" ,qtbase)
77 ("qtdeclarative" ,qtdeclarative) ; optional
78 ("qtx11extras" ,qtx11extras)))
79 (home-page "https://invent.kde.org/plasma/breeze")
80 (synopsis "Default KDE Plasma theme")
81 (description "Artwork, styles and assets for the Breeze visual style for
82 the Plasma Desktop. Breeze is the default theme for the KDE Plasma desktop.")
83 (license license:gpl2+)))
84
85 (define-public kdecoration
86 (package
87 (name "kdecoration")
88 (version "5.19.5")
89 (source (origin
90 (method url-fetch)
91 (uri (string-append "mirror://kde/stable/plasma/" version
92 "/kdecoration-" version ".tar.xz"))
93 (sha256
94 (base32
95 "0pn8n7zyb0adzjnn92vmbcf7pmpss60k9k1rk5llamj016xzfgnf"))))
96 (build-system qt-build-system)
97 (native-inputs
98 `(("extra-cmake-modules" ,extra-cmake-modules)))
99 (inputs
100 `(("ki18n" ,ki18n)
101 ("qtbase" ,qtbase)))
102 (home-page "https://invent.kde.org/plasma/kdecoration")
103 (synopsis "Plugin based library to create window decorations")
104 (description "KDecoration is a library to create window decorations.
105 These window decorations can be used by for example an X11 based window
106 manager which re-parents a Client window to a window decoration frame.")
107 (license license:lgpl3+)))
108
109 (define-public kscreenlocker
110 (package
111 (name "kscreenlocker")
112 (version "5.19.5")
113 (source (origin
114 (method url-fetch)
115 (uri (string-append "mirror://kde/stable/plasma/" version
116 "/kscreenlocker-" version ".tar.xz"))
117 (sha256
118 (base32
119 "1fd5sqaqx9kj3kr0bgxpllhcm5arf8bc9pkpd9yk9c8xjy0j0fxi"))))
120 (build-system qt-build-system)
121 (arguments
122 `(#:tests? #f ;; TODO: make tests pass
123 #:phases
124 (modify-phases %standard-phases
125 (add-before 'check 'check-setup
126 (lambda* (#:key inputs outputs #:allow-other-keys)
127 (system (string-append (assoc-ref inputs "xorg-server")
128 "/bin/Xvfb :1 -screen 0 640x480x24 &"))
129 (setenv "DISPLAY" ":1")
130 #t))
131 (delete 'check)
132 ;; Tests use the installed library and require a DBus session.
133 (add-after 'install 'check
134 (lambda* (#:key tests? #:allow-other-keys)
135 (if tests?
136 (begin
137 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
138 (invoke "dbus-launch" "ctest" ".")))
139 #t)))))
140 (native-inputs
141 `(("extra-cmake-modules" ,extra-cmake-modules)
142 ("pkg-config" ,pkg-config)
143 ;; For tests.
144 ("dbus" ,dbus)
145 ("xorg-server" ,xorg-server-for-tests)))
146 (inputs
147 `(("kcmutils" ,kcmutils)
148 ("kcrash" ,kcrash)
149 ("kdeclarative" ,kdeclarative)
150 ("kglobalaccel" ,kglobalaccel)
151 ("ki18n" ,ki18n)
152 ("kidletime" ,kidletime)
153 ("knotifications" ,knotifications)
154 ("ktextwidgets" ,ktextwidgets)
155 ("kwayland" ,kwayland)
156 ("kwindowsystem" ,kwindowsystem)
157 ("kxmlgui" ,kxmlgui)
158 ("libseccomp" ,libseccomp) ;for sandboxing the look'n'feel package
159 ("libxcursor" ,libxcursor) ;missing in CMakeList.txt
160 ("libxi" ,libxi) ;XInput, required for grabbing XInput2 devices
161 ("linux-pam" ,linux-pam)
162 ("logind" ,elogind) ;optional loginctl support
163 ("qtbase" ,qtbase)
164 ("qtdeclarative" ,qtdeclarative)
165 ("qtx11extras" ,qtx11extras)
166 ("solid" ,solid)
167 ("wayland" ,wayland)
168 ("xcb-util-keysyms" ,xcb-util-keysyms)))
169 (home-page "https://invent.kde.org/plasma/kscreenlocker")
170 (synopsis "Screen locking library")
171 (description
172 "@code{kscreenlocker} is a library for creating secure lock screens.")
173 (license license:gpl2+)))
174
175 (define-public libkscreen
176 (package
177 (name "libkscreen")
178 (version "5.19.5")
179 (source
180 (origin
181 (method url-fetch)
182 (uri (string-append "mirror://kde/stable/plasma/" version "/"
183 name "-" version ".tar.xz"))
184 (sha256
185 (base32 "0rf1pm0yyc069f4n5s9ipdx4glzfr9zvv5cbrmn4q9i4v6z1qd8i"))))
186 (build-system qt-build-system)
187 (native-inputs
188 `(("extra-cmake-modules" ,extra-cmake-modules)
189 ;; For testing.
190 ("dbus" ,dbus)))
191 (inputs
192 `(("kwayland" ,kwayland)
193 ("libxrandr" ,libxrandr)
194 ("qtbase" ,qtbase)
195 ("qtx11extras" ,qtx11extras)))
196 (arguments
197 '(#:tests? #f)) ; FIXME: 55% tests passed, 5 tests failed out of 11
198 (home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
199 (synopsis "KDE's screen management software")
200 (description "KScreen is the new screen management software for KDE Plasma
201 Workspaces which tries to be as magic and automatic as possible for users with
202 basic needs and easy to configure for those who want special setups.")
203 (license license:gpl2+)))
204
205 (define-public libksysguard
206 (package
207 (name "libksysguard")
208 (version "5.19.5")
209 (source
210 (origin
211 (method url-fetch)
212 (uri (string-append "mirror://kde//stable/plasma/" version
213 "/libksysguard-" version ".tar.xz"))
214 (sha256
215 (base32 "1kd0h3p8bf9k5pqp0frhr81pa0yyrpkckg9zznirk9p1v88v7bfq"))))
216 (native-inputs
217 `(("extra-cmake-modules" ,extra-cmake-modules)
218 ("pkg-config" ,pkg-config)))
219 (inputs
220 `(("kconfigwidgets" ,kconfigwidgets)
221 ("kiconthemes" ,kiconthemes)
222 ("kwindowsystem" ,kwindowsystem)
223 ("ki18n" ,ki18n)
224 ("kauth" ,kauth)
225 ("kcompletion" ,kcompletion)
226 ("kconfig" ,kconfig)
227 ("kcoreaddons" ,kcoreaddons)
228 ("kdeclarative" ,kdeclarative)
229 ("kglobalaccel" ,kglobalaccel)
230 ("kio" ,kio)
231 ("knewstuff" ,knewstuff)
232 ("kwidgetsaddons" ,kwidgetsaddons)
233 ("kservice" ,kservice)
234 ("qtbase" ,qtbase)
235 ("qtdeclarative" ,qtdeclarative)
236 ("qtscript" ,qtscript)
237 ("qtwebkit" ,qtwebkit)
238 ("qtx11extras" ,qtx11extras)
239 ("plasma" ,plasma-framework)
240 ("zlib" ,zlib)))
241 (build-system qt-build-system)
242 (arguments
243 `(#:configure-flags
244 `(,(string-append "-DKDE_INSTALL_DATADIR="
245 (assoc-ref %outputs "out") "/share"))
246 #:phases
247 (modify-phases %standard-phases
248 (add-before 'configure 'patch-cmakelists
249 (lambda _
250 ;; TODO: Verify: This should no longer be necessary, since
251 ;; KF5AuthConfig.cmake.in contains this already.
252 (substitute* "processcore/CMakeLists.txt"
253 (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
254 (replace 'check
255 (lambda _
256 ;; TODO: Fix this failing test-case
257 (invoke "ctest" "-E" "processtest"))))))
258 (home-page "https://userbase.kde.org/KSysGuard")
259 (synopsis "Network enabled task and system monitoring")
260 (description "KSysGuard can obtain information on system load and
261 manage running processes. It obtains this information by interacting
262 with a ksysguardd daemon, which may also run on a remote system.")
263 (license license:gpl3+)))
264