gnu: Add kopete.
[jackhill/guix/guix.git] / gnu / packages / kde-internet.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages kde-internet)
20 #:use-module (guix build-system qt)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix utils)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages boost)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages gnupg)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages kde)
32 #:use-module (gnu packages kde-frameworks)
33 #:use-module (gnu packages kde-pim)
34 #:use-module (gnu packages libidn)
35 #:use-module (gnu packages linux)
36 #:use-module (gnu packages messaging)
37 #:use-module (gnu packages pkg-config)
38 #:use-module (gnu packages qt)
39 #:use-module (gnu packages serialization)
40 #:use-module (gnu packages telephony)
41 #:use-module (gnu packages tls)
42 #:use-module (gnu packages video)
43 #:use-module (gnu packages web)
44 #:use-module (gnu packages xiph)
45 #:use-module (gnu packages xml))
46
47 (define-public choqok
48 (package
49 (name "choqok")
50 (version "1.6.0")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (string-append "mirror://kde/stable/choqok/"
55 (version-major+minor version)
56 "/src/choqok-" version ".tar.xz"))
57 (sha256
58 (base32 "03ri4y1wzyqlixnhczsls5gmy7jzzm67bb5gz8bav51ngc32fxca"))
59 (patches (search-patches "choqok-Fix-building-under-Qt-5.13.patch"))))
60 (build-system qt-build-system)
61 (native-inputs
62 `(("extra-cmake-modules" ,extra-cmake-modules)
63 ("kdoctools" ,kdoctools)
64 ("pkg-config" ,pkg-config)))
65 (inputs
66 `(("attica" ,attica)
67 ("kcmutils" ,kcmutils)
68 ("kconfigwidgets" ,kconfigwidgets)
69 ("kcoreaddons" ,kcoreaddons)
70 ("kdewebkit" ,kdewebkit)
71 ("kemoticons" ,kemoticons)
72 ("kglobalaccel" ,kglobalaccel)
73 ("kguiaddons" ,kguiaddons)
74 ("ki18n" ,ki18n)
75 ("kio" ,kio)
76 ("knotifications" ,knotifications)
77 ("knotifyconfig" ,knotifyconfig)
78 ("kparts" ,kparts)
79 ("ktextwidgets" ,ktextwidgets)
80 ("kwallet" ,kwallet)
81 ("kwidgetsaddons" ,kwidgetsaddons)
82 ("kxmlgui" ,kxmlgui)
83 ;; TODO: telepathy
84 ("oxygen-icons" ,oxygen-icons) ; default icon set
85 ("qca" ,qca)
86 ("qoauth" ,qoauth)
87 ("qtbase" ,qtbase)
88 ("qtwebkit" ,qtwebkit)
89 ("sonnet" ,sonnet)))
90 (home-page "https://kde.org/applications/internet/org.kde.choqok")
91 (synopsis "Micro-Blogging Client")
92 (description "Choqok is a fast, efficient and simple to use micro-blogging
93 client for KDE. It currently supports the twitter.com and identi.ca
94 microblogging services.
95
96 Other notable features include:
97 @itemize
98 @item Support for user + friends time-lines.
99 @item Support for @Reply time-lines.
100 @item Support for sending and receiving direct messages.
101 @item Twitpic.com integration.
102 @item The ability to use multiple accounts simultaneously.
103 @item Support for search APIs for all services.
104 @item KWallet integration.
105 @item Support for automatic shortening urls with more than 30 characters.
106 @item Support for configuring status lists appearance.
107 @end itemize")
108 (license license:gpl3+)))
109
110 (define-public kget
111 (package
112 (name "kget")
113 (version "19.08.3")
114 (source
115 (origin
116 (method url-fetch)
117 (uri (string-append "mirror://kde/stable/applications/" version
118 "/src/kget-" version ".tar.xz"))
119 (sha256
120 (base32 "004qqq93iqidh2m9q2p2cwlbc2kfrz0g8a2mgd712c9p66l7s42s"))))
121 (build-system qt-build-system)
122 (native-inputs
123 `(("extra-cmake-modules" ,extra-cmake-modules)
124 ("pkg-config" ,pkg-config)))
125 (inputs
126 `(("boost" ,boost)
127 ("gmp" ,gmp)
128 ("gpgme" ,gpgme)
129 ("kcmutils" ,kcmutils)
130 ("kcompletion" ,kcompletion)
131 ("kconfig" ,kconfig)
132 ("kconfigwidgets" ,kconfigwidgets)
133 ("kcoreaddons" ,kcoreaddons)
134 ("kcrash" ,kcrash)
135 ("kdbusaddons" ,kdbusaddons)
136 ("kdelibs4support" ,kdelibs4support) ;; KLocale
137 ("kdoctools" ,kdoctools)
138 ("ki18n" ,ki18n)
139 ("kiconthemes" ,kiconthemes)
140 ("kio" ,kio)
141 ("kitemviews" ,kitemviews)
142 ("knotifications" ,knotifications)
143 ("knotifyconfig" ,knotifyconfig)
144 ("kparts" ,kparts)
145 ("kservice" ,kservice)
146 ("ktextwidgets" ,ktextwidgets)
147 ("kwallet" ,kwallet)
148 ("kwidgetsaddons" ,kwidgetsaddons)
149 ("kwindowsystem" ,kwindowsystem)
150 ("kxmlgui" ,kxmlgui)
151 ("libgcrypt" ,libgcrypt)
152 ("libktorrent" ,libktorrent)
153 ;; TODO: libmms
154 ;; TODO: LibKWorkspace - plasma-workspace?
155 ("oxygen-icons" ,oxygen-icons) ; default icon set
156 ("qca" ,qca)
157 ("qgpgme" ,qgpgme)
158 ("qtbase" ,qtbase)
159 ))
160 (home-page "http://www.kde.org/")
161 (synopsis "Versatile and user-friendly download manager")
162 (description "KGet is an advanced download manager with support for
163 Metalink and Bittorrent. Downloads are added to the list, where they can be
164 paused, queued, or scheduled for later. KGet supports download via FTP anf
165 HTTP(S) as well as pausing downloads.
166
167 This package is part of the KDE networking module.")
168 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
169 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
170
171 (define-public konversation
172 (package
173 (name "konversation")
174 (version "1.7.5")
175 (source
176 (origin
177 (method url-fetch)
178 (uri (string-append "mirror://kde/stable/konversation/" version
179 "/src/konversation-" version ".tar.xz"))
180 (sha256
181 (base32 "0h098yhlp36ls6pdvs2r93ig8dv4fys62m0h6wxccprb0qrpbgv0"))
182 (patches (search-patches "konversation-Fix-build-with-Qt-5.11.patch"))))
183 (build-system qt-build-system)
184 (native-inputs
185 `(("extra-cmake-modules" ,extra-cmake-modules)
186 ("kdoctools" ,kdoctools)))
187 (inputs
188 `(("karchive" ,karchive)
189 ("kbookmarks" ,kbookmarks)
190 ("kconfig" ,kconfig)
191 ("kconfigwidgets" ,kconfigwidgets)
192 ("kcoreaddons" ,kcoreaddons)
193 ("kcrash" ,kcrash)
194 ("kdbusaddons" ,kdbusaddons)
195 ("kemoticons" ,kemoticons)
196 ("kglobalaccel" ,kglobalaccel)
197 ("ki18n" ,ki18n)
198 ("kiconthemes" ,kiconthemes)
199 ("kidletime" ,kidletime)
200 ("kio" ,kio)
201 ("kitemviews" ,kitemviews)
202 ("knotifications" ,knotifications)
203 ("knotifyconfig" ,knotifyconfig)
204 ("kparts" ,kparts)
205 ("kwallet" ,kwallet)
206 ("kwidgetsaddons" ,kwidgetsaddons)
207 ("kwindowsystem" ,kwindowsystem)
208 ("oxygen-icons" ,oxygen-icons) ; default icon set
209 ("phonon" ,phonon)
210 ("qtbase" ,qtbase)
211 ("qca" ,qca)
212 ("solid" ,solid)
213 ("sonnet" ,sonnet)))
214 (home-page "https://kde.org/applications/internet/org.kde.konversations")
215 (synopsis "Graphical Internet Relay Chat (IRC) client for KDE")
216 (description "Konversation is a graphical Internet Relay Chat client (IRC)
217 with KDE support.
218
219 Features are:
220 @itemize
221 @item Standard IRC features
222 @item SSL server support
223 @item Bookmarking support
224 @item Easy to use graphical user interface
225 @item Multiple servers and channels in one single window
226 @item DCC file transfer with resume support
227 @item Multiple identities for different servers
228 @item Text decorations and colors
229 @item Pattern-based message highlighting and OnScreen Display notifications
230 @item Automatic UTF-8 detection
231 @item Per channel encoding support
232 @item Theme support for nick icons
233 @item Highly configurable
234 @item Multi-language scripting support (with DCOP)
235 @item Customizable command aliases
236 @item NickServ-aware log-on (for registered nicknames)
237 @item Smart logging
238 @item Traditional or enhanced-shell-style nick completion
239 @end itemize")
240 (license ;; GPL for programs, FDL for documentation
241 (list license:gpl2+ license:fdl1.2+))))
242
243 (define-public kopete
244 (package
245 (name "kopete")
246 (version "19.08.3")
247 (source
248 (origin
249 (method url-fetch)
250 (uri (string-append "mirror://kde/stable/applications/" version
251 "/src/kopete-" version ".tar.xz"))
252 (sha256
253 (base32 "088jya4v04l7r38pph1hxkr6ln4023s3ji3y8ipzdkalcx8hgr6l"))))
254 (build-system qt-build-system)
255 (native-inputs
256 `(("extra-cmake-modules" ,extra-cmake-modules)
257 ("kdoctools" ,kdoctools)
258 ("pkg-config" ,pkg-config)))
259 (inputs
260 `(("alsa-lib" ,alsa-lib)
261 ("boost" ,boost)
262 ("expat" ,expat)
263 ("glib" ,glib)
264 ("gpgme" ,gpgme)
265 ("jsoncpp" ,jsoncpp)
266 ("kcmutils" ,kcmutils)
267 ("kconfig" ,kconfig)
268 ("kcontacts" ,kcontacts)
269 ("kcoreaddons" ,kcoreaddons)
270 ("kcrash" ,kcrash)
271 ("kdbusaddons" ,kdbusaddons)
272 ("kdelibs4support" ,kdelibs4support)
273 ("kdnssd" ,kdnssd)
274 ("kemoticons" ,kemoticons)
275 ("khtml" ,khtml)
276 ("ki18n" ,ki18n)
277 ("kidentitymanagement" ,kidentitymanagement)
278 ("kjs" ,kjs)
279 ;; TODO? kleopatra (additionally to libkleo)
280 ("knotifyconfig" ,knotifyconfig)
281 ("kparts" ,kparts)
282 ("kpimtextedit" ,kpimtextedit)
283 ("ktexteditor" ,ktexteditor)
284 ("kwallet" ,kwallet)
285 ;; TODO: Libgadu
286 ("libidn" ,libidn)
287 ("libkleo" ,libkleo)
288 ;; TODO: LibMeanwhile
289 ("libotr" ,libotr)
290 ("libsrtp" ,libsrtp)
291 ("libxml2" ,libxml2)
292 ("libxstl" ,libxslt)
293 ;; TODO: Mediastreamer
294 ("openssl", openssl)
295 ("ortp" ,ortp)
296 ("phonon" ,phonon)
297 ("qca" ,qca)
298 ("qgpgme" ,qgpgme)
299 ("qtbase" ,qtbase)
300 ("speex" ,speex)
301 ("v4l-utils" ,v4l-utils)
302 ;; TODO: Xmms
303 ("zlib" ,zlib)))
304 ;; TODO: enable video support
305 (home-page "https://kde.org/applications/internet/org.kde.kopete")
306 (synopsis "Instant messaging and chat application")
307 (description "Kopete is an instant messenger supporting Jabber/XMPP ,AIM,
308 ICQ, Gadu-Gadu, Novell GroupWise Messenger, and more. It is designed to be a
309 flexible and extensible multi-protocol system suitable for personal and
310 enterprise use.
311
312 The goal of Kopete is to provide users with a single easy-to-use way to access
313 all of their instant messaging systems. The interface puts people first, and
314 is integrated with the system address book to let you access your contacts
315 from other KDE applications.
316
317 This package is part of the KDE networking module.")
318 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
319 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))