gnu: julius: Update to 1.7.0.
[jackhill/guix/guix.git] / gnu / packages / plan9.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2021 宋文武 <iyzsong@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages plan9)
20 #:use-module (guix build-system gnu)
21 #:use-module (guix git-download)
22 #:use-module (guix packages)
23 #:use-module (guix utils)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages xorg))
26
27 (define-public drawterm
28 (let ((revision "1")
29 (commit "c97fe4693f6112504d6f13fab46f7cc8b27685c1"))
30 (package
31 (name "drawterm")
32 (version (git-version "20210628" revision commit))
33 (source
34 (origin
35 (method git-fetch)
36 (uri (git-reference
37 (url "git://git.9front.org/plan9front/drawterm")
38 (commit commit)))
39 (file-name (git-file-name name version))
40 (sha256
41 (base32 "059sl60ap6c9lz8k91k6bd34694a290wm0s93b2vfszzzv683spw"))))
42 (build-system gnu-build-system)
43 (arguments
44 `(#:make-flags (list "CONF=unix"
45 (string-append "CC=" ,(cc-for-target)))
46 #:tests? #f ; no tests
47 #:phases
48 (modify-phases %standard-phases
49 (delete 'configure) ; no configure script
50 (replace 'install ; no install target
51 (lambda* (#:key outputs #:allow-other-keys)
52 (let* ((out (assoc-ref outputs "out"))
53 (bin (string-append out "/bin/"))
54 (man (string-append out "/share/man/man1/")))
55 (install-file "drawterm" bin)
56 (install-file "drawterm.1" man)))))))
57 (inputs
58 (list libx11 libxt))
59 (synopsis "Connect to Plan 9 systems")
60 (home-page "http://drawterm.9front.org")
61 (description
62 "@command{drawterm} is a client for connecting venerable systems to
63 Plan 9 systems. It behaves like a Plan 9 kernel and will attempt to
64 reconstruct a Plan 9 terminal-like experience from a non-Plan 9 system.")
65 (license license:expat))))