gnu: julius: Update to 1.7.0.
[jackhill/guix/guix.git] / gnu / packages / moreutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
3 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016–2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages moreutils)
22 #:use-module (guix gexp)
23 #:use-module ((guix licenses) #:prefix l:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix utils)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages xml)
30 #:use-module (gnu packages docbook))
31
32 (define-public moreutils
33 (package
34 (name "moreutils")
35 (version "0.67")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append
40 "https://git.joeyh.name/index.cgi/moreutils.git/snapshot/"
41 name "-" version ".tar.gz"))
42 (sha256
43 (base32 "045d2dfvsd4sxxr2i2qvkpgvi912qj9vc4gpc8fb4hr9q912z1q3"))))
44 (build-system gnu-build-system)
45 ;; For building the manual pages.
46 (native-inputs
47 (list docbook-xml-4.4 docbook-xsl libxml2 libxslt))
48 (inputs
49 (list perl perl-timedate perl-time-duration))
50 (arguments
51 (list #:phases
52 #~(modify-phases %standard-phases
53 (add-after 'install 'wrap-program
54 (lambda _
55 (wrap-program
56 (string-append #$output "/bin/ts")
57 `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))
58 (delete 'configure)) ; no configure script
59 #:make-flags
60 #~(list (string-append "PREFIX=" #$output)
61 (string-append "DOCBOOKXSL="
62 #$(this-package-native-input "docbook-xsl")
63 "/xml/xsl/docbook-xsl-"
64 #$(package-version (this-package-native-input
65 "docbook-xsl")))
66 (string-append "CC=" #$(cc-for-target)))))
67 (home-page "https://joeyh.name/code/moreutils/")
68 (synopsis "Miscellaneous general-purpose command-line tools")
69 (description
70 "Moreutils is a collection of general-purpose command-line tools to
71 augment the traditional Unix toolbox.")
72 (license l:gpl2+)))