gnu: r-zoo: Update to 1.8-7.
[jackhill/guix/guix.git] / gnu / packages / less.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages less)
21 #:use-module (guix licenses)
22 #:use-module (gnu packages ncurses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public less
28 (package
29 (name "less")
30 (version "551")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (list (string-append "mirror://gnu/less/less-"
35 version ".tar.gz")
36 (string-append "http://www.greenwoodsoftware.com/less/less-"
37 version ".tar.gz")))
38 (sha256
39 (base32 "0ggyjl3yzn7c450zk1rixi9ls6asdhgqynhk34zsd0ckhmsm45pz"))))
40 (build-system gnu-build-system)
41 (inputs `(("ncurses" ,ncurses)))
42 (home-page "https://www.gnu.org/software/less/")
43 (synopsis "Paginator for terminals")
44 (description
45 "GNU less is a pager, a program that allows you to view large amounts
46 of text in page-sized chunks. Unlike traditional pagers, it allows both
47 backwards and forwards movement through the document. It also does not have
48 to read the entire input file before starting, so it starts faster than most
49 text editors.")
50 (license gpl3+))) ; some files are under GPLv2+