gnu: emacs-taxy-magit-section: Update to 0.11.
[jackhill/guix/guix.git] / gnu / packages / bison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
6 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages bison)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages m4)
29 #:use-module (gnu packages perl)
30 #:use-module (gnu packages flex)
31 #:use-module (srfi srfi-1))
32
33 (define-public bison
34 (package
35 (name "bison")
36 (version "3.7.6")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "mirror://gnu/bison/bison-"
41 version ".tar.xz"))
42 (sha256
43 (base32
44 "1kzkxrd3z4262k2sbxmyh9k5g5r2lakw0gv44l2hb4i1wbhqrmk7"))))
45 (build-system gnu-build-system)
46 (arguments
47 '(;; Building in parallel on many-core systems may cause an error such as
48 ;; "mv: cannot stat 'examples/c/reccalc/scan.stamp.tmp': No such file or
49 ;; directory". See <https://bugs.gnu.org/36238>.
50 #:parallel-build? #f
51 ;; Similarly, when building tests in parallel, Make may produce this error:
52 ;; "./examples/c/reccalc/scan.l:13:10: fatal error: parse.h: No such file
53 ;; or directory". Full log in <https://bugs.gnu.org/36238>.
54 #:parallel-tests? #f))
55 (native-inputs (list perl
56 ;; m4 is not present in PATH when cross-building.
57 m4))
58 (inputs (list flex))
59 (propagated-inputs (list m4))
60 (home-page "https://www.gnu.org/software/bison/")
61 (synopsis "Yacc-compatible parser generator")
62 (description
63 "GNU Bison is a general-purpose parser generator. It can build a
64 deterministic or generalized LR parser from an annotated, context-free
65 grammar. It is versatile enough to have many applications, from parsers for
66 simple tools through complex programming languages.
67
68 Bison also provides an implementation of @command{yacc}, as specified by POSIX.")
69 (license gpl3+)))
70
71 (define-public bison-3.0
72 (package
73 (inherit bison)
74 (version "3.0.5")
75 (source
76 (origin
77 (method url-fetch)
78 (uri (string-append "mirror://gnu/bison/bison-"
79 version ".tar.xz"))
80 (sha256
81 (base32
82 "0f7kjygrckkx8vas2nm673592jif0a9mw5g8207f6hj6h4pfyp07"))))))