gnu: xfce, mate: Propagate 'font-dejavu'.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2017 Nikita <nikita@n0.is>
6 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages enlightenment)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix utils)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system meson)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages algebra)
34 #:use-module (gnu packages bittorrent)
35 #:use-module (gnu packages check)
36 #:use-module (gnu packages code)
37 #:use-module (gnu packages compression)
38 #:use-module (gnu packages curl)
39 #:use-module (gnu packages fonts)
40 #:use-module (gnu packages fontutils)
41 #:use-module (gnu packages freedesktop)
42 #:use-module (gnu packages fribidi)
43 #:use-module (gnu packages game-development)
44 #:use-module (gnu packages gettext)
45 #:use-module (gnu packages ghostscript)
46 #:use-module (gnu packages gl)
47 #:use-module (gnu packages glib)
48 #:use-module (gnu packages gnome)
49 #:use-module (gnu packages gstreamer)
50 #:use-module (gnu packages gtk)
51 #:use-module (gnu packages ibus)
52 #:use-module (gnu packages image)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages llvm)
55 #:use-module (gnu packages lua)
56 #:use-module (gnu packages pdf)
57 #:use-module (gnu packages perl)
58 #:use-module (gnu packages photo)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages pulseaudio)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages python-xyz)
63 #:use-module (gnu packages tls)
64 #:use-module (gnu packages video)
65 #:use-module (gnu packages xdisorg)
66 #:use-module (gnu packages xorg)
67 #:use-module (ice-9 match))
68
69 (define-public efl
70 (package
71 (name "efl")
72 (version "1.25.1")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append
76 "https://download.enlightenment.org/rel/libs/efl/efl-"
77 version ".tar.xz"))
78 (sha256
79 (base32
80 "0svybbrvpf6q955y6fclxh3md64z0dgmh0x54x2j60503hhs071m"))))
81 (build-system meson-build-system)
82 (native-inputs
83 `(("check" ,check-0.14)
84 ("gettext" ,gettext-minimal)
85 ("pkg-config" ,pkg-config)))
86 (inputs
87 `(("curl" ,curl)
88 ("giflib" ,giflib)
89 ("gstreamer" ,gstreamer)
90 ("gst-plugins-base" ,gst-plugins-base)
91 ("ibus" ,ibus)
92 ("mesa" ,mesa)
93 ("libraw" ,libraw)
94 ("librsvg" ,librsvg)
95 ("libspectre" ,libspectre)
96 ("libtiff" ,libtiff)
97 ("libxau" ,libxau)
98 ("libxcomposite" ,libxcomposite)
99 ("libxcursor" ,libxcursor)
100 ("libxdamage" ,libxdamage)
101 ("libxdmcp" ,libxdmcp)
102 ("libxext" ,libxext)
103 ("libxi" ,libxi)
104 ("libxfixes" ,libxfixes)
105 ("libxinerama" ,libxinerama)
106 ("libxrandr" ,libxrandr)
107 ("libxrender" ,libxrender)
108 ("libxss" ,libxscrnsaver)
109 ("libxtst" ,libxtst)
110 ("libwebp" ,libwebp)
111 ("openjpeg" ,openjpeg)
112 ("poppler" ,poppler)
113 ("util-linux" ,util-linux "lib")
114 ("wayland-protocols" ,wayland-protocols)))
115 (propagated-inputs
116 ;; All these inputs are in package config files in section
117 ;; Requires.private.
118 `(("dbus" ,dbus)
119 ("elogind" ,elogind)
120 ("eudev" ,eudev)
121 ("fontconfig" ,fontconfig)
122 ("freetype" ,freetype)
123 ("fribidi" ,fribidi)
124 ("glib" ,glib)
125 ("harfbuzz" ,harfbuzz)
126 ("libinput" ,libinput-minimal)
127 ("libjpeg" ,libjpeg-turbo)
128 ("libsndfile" ,libsndfile)
129 ("libpng" ,libpng)
130 ("libx11" ,libx11)
131 ("libxkbcommon" ,libxkbcommon)
132 ("luajit" ,luajit)
133 ("lz4" ,lz4)
134 ("openssl" ,openssl)
135 ("pulseaudio" ,pulseaudio)
136 ("wayland" ,wayland)
137 ("zlib" ,zlib)))
138 (arguments
139 `(#:configure-flags '("-Dembedded-lz4=false"
140 "-Dbuild-examples=false"
141 "-Decore-imf-loaders-disabler=scim"
142 "-Dglib=true"
143 "-Dmount-path=/run/setuid-programs/mount"
144 "-Dunmount-path=/run/setuid-programs/umount"
145 ;(string-append "-Ddictionaries-hyphen-dir="
146 ; (assoc-ref %build-inputs "hyphen")
147 ; "/share/hyphen")
148 "-Dnetwork-backend=connman"
149 ;; for wayland
150 "-Dwl=true"
151 "-Ddrm=true")
152 #:tests? #f ; Many tests fail due to timeouts and network requests.
153 #:phases
154 (modify-phases %standard-phases
155 ;; If we don't hardcode the location of libcurl.so and others then we
156 ;; have to wrap the outputs of efl's dependencies in those libraries.
157 (add-after 'unpack 'hardcode-dynamic-libraries
158 (lambda* (#:key inputs #:allow-other-keys)
159 (let ((curl (assoc-ref inputs "curl"))
160 (pulse (assoc-ref inputs "pulseaudio"))
161 (sndfile (assoc-ref inputs "libsndfile"))
162 (elogind (assoc-ref inputs "elogind"))
163 (lib "/lib/"))
164 (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
165 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
166 (string-append curl lib libcurl)))
167 (substitute* "src/lib/ecore_audio/ecore_audio.c"
168 (("libpulse.so.0" libpulse)
169 (string-append pulse lib libpulse))
170 (("libsndfile.so.1" libsnd)
171 (string-append sndfile lib libsnd)))
172 (substitute* "src/lib/elput/elput_logind.c"
173 (("libelogind.so.0" libelogind)
174 (string-append elogind "/lib/" libelogind)))
175 #t)))
176 (add-after 'unpack 'fix-install-paths
177 (lambda _
178 (substitute* "dbus-services/meson.build"
179 (("install_dir.*")
180 "install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
181 (substitute* "src/tests/elementary/meson.build"
182 (("dir_data") "meson.source_root(), 'test-output'"))
183 (substitute* "data/eo/meson.build"
184 (("'usr', 'lib'") "'./' + dir_lib"))
185 #t))
186 (add-after 'unpack 'set-home-directory
187 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
188 (lambda _ (setenv "HOME" "/tmp") #t)))))
189 (home-page "https://www.enlightenment.org/about-efl")
190 (synopsis "Enlightenment Foundation Libraries")
191 (description
192 "Enlightenment Foundation Libraries is a set of libraries developed
193 for Enlightenment. Libraries covers data serialization, wide support for
194 graphics rendering, UI layout and themes, interaction with OS, access to
195 removable devices or support for multimedia.")
196 ;; Different parts are under different licenses.
197 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
198
199 (define-public terminology
200 (package
201 (name "terminology")
202 (version "1.9.0")
203 (source (origin
204 (method url-fetch)
205 (uri
206 (string-append "https://download.enlightenment.org/rel/apps/"
207 "terminology/terminology-" version ".tar.xz"))
208 (sha256
209 (base32
210 "0v74858yvrrfy0l2pq7yn6izvqhpkb9gw2jpd3a3khjwv8kw6frz"))
211 (modules '((guix build utils)))
212 ;; Remove the bundled fonts.
213 (snippet
214 '(begin
215 (delete-file-recursively "data/fonts")
216 (substitute* "data/meson.build"
217 (("subdir\\('fonts'\\)") ""))
218 #t))))
219 (build-system meson-build-system)
220 (arguments
221 `(#:configure-flags
222 (let ((efl (assoc-ref %build-inputs "efl")))
223 (list "-Dtests=true"
224 (string-append "-Dedje-cc=" efl "/bin/edje_cc")
225 (string-append "-Deet=" efl "/bin/eet")))
226 #:phases
227 (modify-phases %standard-phases
228 (add-after 'unpack 'set-home-directory
229 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
230 (lambda _ (setenv "HOME" "/tmp") #t))
231 (replace 'check
232 (lambda _
233 (with-directory-excursion
234 (string-append "../" ,name "-" ,version "/tests")
235 (invoke "sh" "run_tests.sh" "--verbose"
236 "-t" "../../build/src/bin/tytest"))))
237 (add-after 'install 'remove-test-binary
238 (lambda* (#:key outputs #:allow-other-keys)
239 ;; This file is not meant to be installed.
240 (delete-file (string-append (assoc-ref outputs "out")
241 "/bin/tytest"))
242 #t)))))
243 (native-inputs
244 `(("gettext" ,gettext-minimal)
245 ("perl" ,perl)
246 ("pkg-config" ,pkg-config)))
247 (inputs
248 `(("efl" ,efl)))
249 (home-page "https://www.enlightenment.org/about-terminology")
250 (synopsis "Powerful terminal emulator based on EFL")
251 (description
252 "Terminology is fast and feature rich terminal emulator. It is solely
253 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
254 URL and local path detection, themes, popup based content viewer for non-text
255 contents and more.")
256 (license license:bsd-2)))
257
258 (define-public rage
259 (package
260 (name "rage")
261 (version "0.3.1")
262 (source (origin
263 (method url-fetch)
264 (uri
265 (string-append
266 "https://download.enlightenment.org/rel/apps/rage/rage-"
267 version ".tar.xz"))
268 (sha256
269 (base32
270 "04fdk23bbgvni212zrfy4ndg7vmshbsjgicrhckdvhay87pk9i75"))))
271 (build-system meson-build-system)
272 (arguments
273 '(#:phases
274 (modify-phases %standard-phases
275 (add-after 'unpack 'set-home-directory
276 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
277 (lambda _ (setenv "HOME" "/tmp") #t)))))
278 (native-inputs
279 `(("pkg-config" ,pkg-config)))
280 (inputs
281 `(("efl" ,efl)))
282 (home-page "https://www.enlightenment.org/about-rage")
283 (synopsis "Video and audio player based on EFL")
284 (description
285 "Rage is a video and audio player written with Enlightenment Foundation
286 Libraries with some extra bells and whistles.")
287 (license license:bsd-2)))
288
289 (define-public enlightenment
290 (package
291 (name "enlightenment")
292 (version "0.24.2")
293 (source (origin
294 (method url-fetch)
295 (uri
296 (string-append "https://download.enlightenment.org/rel/apps/"
297 "enlightenment/enlightenment-" version ".tar.xz"))
298 (sha256
299 (base32
300 "1wfz0rwwsx7c1mkswn4hc9xw1i6bsdirhxiycf7ha2vcipqy465y"))
301 (patches (search-patches "enlightenment-fix-setuid-path.patch"))))
302 (build-system meson-build-system)
303 (arguments
304 `(#:configure-flags
305 (let ((efl (assoc-ref %build-inputs "efl")))
306 (list "-Dsystemd=false"
307 "-Dpackagekit=false"
308 "-Dwl=true"
309 (string-append "-Dedje-cc=" efl "/bin/edje_cc")
310 (string-append "-Deldbus-codegen=" efl "/bin/eldbus-codegen")
311 (string-append "-Deet=" efl "/bin/eet")))
312 #:phases
313 (modify-phases %standard-phases
314 (delete 'bootstrap) ; We don't want to run the autogen script.
315 (add-before 'configure 'set-system-actions
316 (lambda* (#:key inputs #:allow-other-keys)
317 (setenv "HOME" "/tmp")
318 (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
319 (setxkbmap (assoc-ref inputs "setxkbmap"))
320 (libc (assoc-ref inputs "libc"))
321 (bc (assoc-ref inputs "bc"))
322 (efl (assoc-ref inputs "efl")))
323 ;; We need to patch the path to 'base.lst' to be able
324 ;; to switch the keyboard layout in E.
325 (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
326 "src/modules/wizard/page_011.c")
327 (("/usr/share/X11/xkb/rules/xorg.lst")
328 (string-append xkeyboard
329 "/share/X11/xkb/rules/base.lst")))
330 (substitute* "src/bin/e_xkb.c"
331 (("\"setxkbmap \"")
332 (string-append "\"" setxkbmap "/bin/setxkbmap \"")))
333 (substitute* (list "src/bin/e_intl.c"
334 "src/modules/conf_intl/e_int_config_intl.c"
335 "src/modules/wizard/page_010.c")
336 (("locale -a") (string-append libc "/bin/locale -a")))
337 (substitute* "src/modules/everything/evry_plug_apps.c"
338 (("/usr/bin/") ""))
339 (substitute* '("src/bin/e_sys_main.c"
340 "src/bin/e_util_suid.h")
341 (("PATH=/bin:/usr/bin:/sbin:/usr/sbin")
342 (string-append "PATH=/run/setuid-programs:"
343 "/run/current-system/profile/bin:"
344 "/run/current-system/profile/sbin")))
345 (substitute* "src/modules/everything/evry_plug_calc.c"
346 (("bc -l") (string-append bc "/bin/bc -l")))
347 (substitute* "data/etc/meson.build"
348 (("/bin/mount") "/run/setuid-programs/mount")
349 (("/bin/umount") "/run/setuid-programs/umount")
350 (("/usr/bin/eject") "/run/current-system/profile/bin/eject"))
351 (substitute* "src/bin/system/e_system_power.c"
352 (("systemctl") "loginctl"))
353 #t))))))
354 (native-inputs
355 `(("gettext" ,gettext-minimal)
356 ("pkg-config" ,pkg-config)))
357 (inputs
358 `(("alsa-lib" ,alsa-lib)
359 ("bc" ,bc)
360 ("bluez" ,bluez)
361 ("dbus" ,dbus)
362 ("freetype" ,freetype)
363 ("libxcb" ,libxcb)
364 ("libxext" ,libxext)
365 ("linux-pam" ,linux-pam)
366 ("puleseaudio" ,pulseaudio)
367 ("setxkbmap" ,setxkbmap)
368 ("xcb-util-keysyms" ,xcb-util-keysyms)
369 ("xkeyboard-config" ,xkeyboard-config)
370 ("xorg-server-xwayland" ,xorg-server-xwayland)))
371 (propagated-inputs
372 `(("efl" ,efl)
373 ("libxkbcommon" ,libxkbcommon)
374 ("wayland-protocols" ,wayland-protocols)
375
376 ;; Default font that applications such as IceCat require.
377 ("font-dejavu" ,font-dejavu)))
378 (home-page "https://www.enlightenment.org/about-enlightenment")
379 (synopsis "Lightweight desktop environment")
380 (description
381 "Enlightenment is resource friendly desktop environment with integrated
382 file manager, wide range of configuration options, plugin system allowing to
383 unload unused functionality, with support for touchscreen and suitable for
384 embedded systems.")
385 (license license:bsd-2)))
386
387 (define-public enlightenment-wayland
388 (deprecated-package "enlightenment-wayland" enlightenment))
389
390 (define-public python-efl
391 (package
392 (name "python-efl")
393 (version "1.25.0")
394 (source
395 (origin
396 (method url-fetch)
397 (uri (string-append "https://download.enlightenment.org/rel/bindings/"
398 "python/python-efl-" version ".tar.xz"))
399 (sha256
400 (base32
401 "0bk161xwlz4dlv56r68xwkm8snzfifaxd1j7w2wcyyk4fgvnvq4r"))
402 (modules '((guix build utils)))
403 ;; Remove files generated by Cython
404 (snippet
405 '(begin
406 (for-each (lambda (file)
407 (let ((generated-file
408 (string-append (string-drop-right file 3) "c")))
409 (when (file-exists? generated-file)
410 (delete-file generated-file))))
411 (find-files "efl" "\\.pyx$"))
412 (delete-file "efl/eo/efl.eo_api.h")
413 #t))))
414 (build-system python-build-system)
415 (arguments
416 '(#:phases
417 (modify-phases %standard-phases
418 (replace 'build
419 (lambda _
420 (setenv "ENABLE_CYTHON" "1")
421 (invoke "python" "setup.py" "build")))
422 (add-before 'build 'set-flags
423 (lambda _
424 (setenv "CFLAGS"
425 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
426 "/include/dbus-1.0"))
427 #t))
428 (add-before 'check 'set-environment
429 (lambda _
430 ;; Some tests require write access to HOME.
431 (setenv "HOME" "/tmp")
432 ;; These tests try to connect to the internet.
433 (delete-file "tests/ecore/test_09_file_download.py")
434 (delete-file "tests/ecore/test_11_con.py")
435 #t)))))
436 (native-inputs
437 `(("pkg-config" ,pkg-config)
438 ("python-cython" ,python-cython)))
439 (inputs
440 `(("efl" ,efl)
441 ("python-dbus" ,python-dbus)))
442 (home-page "https://www.enlightenment.org/")
443 (synopsis "Python bindings for EFL")
444 (description
445 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
446 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
447 (license license:lgpl3)))
448
449 (define-public python2-efl
450 (package-with-python2 python-efl))
451
452 (define-public edi
453 (package
454 (name "edi")
455 (version "0.8.0")
456 (source
457 (origin
458 (method url-fetch)
459 (uri (string-append "https://github.com/Enlightenment/edi/releases/"
460 "download/v" version "/edi-" version ".tar.xz"))
461 (sha256
462 (base32
463 "01k8gp8r2wa6pyg3dkbm35m6hdsbss06hybghg0qjmd4mzswcd3a"))))
464 (build-system meson-build-system)
465 (arguments
466 '(#:phases
467 (modify-phases %standard-phases
468 (add-after 'unpack 'fix-clang-header
469 (lambda _
470 (substitute* "scripts/clang_include_dir.sh"
471 (("grep clang") "grep clang | head -n1"))
472 #t))
473 (add-after 'unpack 'set-home-directory
474 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
475 (lambda _ (setenv "HOME" "/tmp") #t)))
476 #:tests? #f)) ; tests require running dbus service
477 (native-inputs
478 `(("check" ,check-0.14)
479 ("gettext" ,gettext-minimal)
480 ("pkg-config" ,pkg-config)))
481 (inputs
482 `(("clang" ,clang)
483 ("efl" ,efl)))
484 (home-page "https://www.enlightenment.org/about-edi")
485 (synopsis "Development environment for Enlightenment")
486 (description "EDI is a development environment designed for and built using
487 the EFL. It's aim is to create a new, native development environment for Linux
488 that tries to lower the barrier to getting involved in Enlightenment development
489 and in creating applications based on the Enlightenment Foundation Library suite.")
490 (license (list license:public-domain ; data/extra/skeleton
491 license:gpl2 ; edi
492 license:gpl3)))) ; data/extra/examples/images/mono-runtime.png
493
494 (define-public lekha
495 (package
496 (name "lekha")
497 (version "0.2.1")
498 (source (origin
499 (method url-fetch)
500 (uri (pypi-uri "Lekha" version))
501 (sha256
502 (base32
503 "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
504 (build-system python-build-system)
505 (arguments
506 `(#:tests? #f ; no test target
507 #:python ,python-2
508 #:phases
509 (modify-phases %standard-phases
510 (add-after 'unpack 'fix-data-location
511 (lambda _ (substitute* "setup.py"
512 (("'/usr/")"'"))
513 #t)))))
514 (propagated-inputs
515 `(("python2-efl" ,python2-efl)
516 ("python2-pypdf2" ,python2-pypdf2)
517 ("python2-pyxdg" ,python2-pyxdg)))
518 (synopsis "Simple PDF viewer")
519 (description
520 "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
521 (home-page "https://github.com/kaihu/lekha")
522 (license license:gpl3+)))
523
524 (define-public ephoto
525 (package
526 (name "ephoto")
527 (version "1.5")
528 (source
529 (origin
530 (method url-fetch)
531 (uri (string-append "https://download.enlightenment.org/rel/"
532 "apps/ephoto/ephoto-" version ".tar.xz"))
533 (sha256
534 (base32 "1q7v9abjp9jrs08xc7pqaac64yzax24dk1snjb9rciarzzh3mlzy"))))
535 (build-system gnu-build-system)
536 (arguments
537 '(#:phases
538 (modify-phases %standard-phases
539 (add-after 'unpack 'set-home-directory
540 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
541 (lambda _ (setenv "HOME" "/tmp") #t)))))
542 (native-inputs
543 `(("check" ,check)
544 ("pkg-config" ,pkg-config)))
545 (inputs
546 `(("efl" ,efl)))
547 (home-page "https://smhouston.us/projects/ephoto/")
548 (synopsis "EFL image viewer/editor/manipulator/slideshow creator")
549 (description "Ephoto is an image viewer and editor written using the
550 @dfn{Enlightenment Foundation Libraries} (EFL). It focuses on simplicity and
551 ease of use, while taking advantage of the speed and small footprint the EFL
552 provide.
553
554 Ephoto’s features include:
555 @enumerate
556 @item Browsing the file system and displaying images in an easy-to-use grid view.
557 @item Browsing images in a single image view format.
558 @item Viewing images in a slideshow.
559 @item Editing your image with features such as cropping, auto enhance,
560 blurring, sharpening, brightness/contrast/gamma adjustments, hue/saturation/value
561 adjustments, and color level adjustment.
562 @item Applying artistic filters to your image such as black and white and old
563 photo.
564 @item Drag And Drop along with file operations to easily maintain your photo
565 directories.
566 @end enumerate\n")
567 (license (list
568 license:bsd-2 ; Ephoto's thumbnailing code
569 license:bsd-3))))
570
571 (define-public evisum
572 (package
573 (name "evisum")
574 (version "0.5.11")
575 (source
576 (origin
577 (method url-fetch)
578 (uri (string-append "https://download.enlightenment.org/rel/apps/"
579 "evisum/evisum-" version ".tar.xz"))
580 (sha256
581 (base32 "0cbfg393nlf0k91a2hdlyakns3dpzvs3isd95dm3zizydyf9h8wc"))))
582 (build-system meson-build-system)
583 (arguments
584 '(#:tests? #f)) ; no tests
585 (native-inputs
586 `(("gettext" ,gettext-minimal)
587 ("pkg-config" ,pkg-config)))
588 (inputs
589 `(("efl" ,efl)))
590 (home-page "https://www.enlightenment.org")
591 (synopsis "EFL process viewer")
592 (description
593 "This is a process monitor and system monitor using the
594 @dfn{Enlightenment Foundation Libraries} (EFL).")
595 (license license:bsd-2)))
596
597 (define-public epour
598 (package
599 (name "epour")
600 (version "0.7.0")
601 (source
602 (origin
603 (method url-fetch)
604 (uri (string-append "https://download.enlightenment.org/rel/apps/epour"
605 "/epour-" version ".tar.xz"))
606 (sha256
607 (base32
608 "0g9f9p01hsq6dcf4cs1pwq95g6fpkyjgwqlvdjk1km1i5gj5ygqw"))))
609 (build-system python-build-system)
610 (arguments
611 `(#:tests? #f ; no test target
612 #:use-setuptools? #f
613 #:phases
614 (modify-phases %standard-phases
615 (add-after 'unpack 'find-theme-dir
616 (lambda* (#:key outputs #:allow-other-keys)
617 (let ((out (assoc-ref outputs "out")))
618 (substitute* "epour/gui/__init__.py"
619 (("join\\(data_path")
620 (string-append "join(\"" out "/share/epour\"")))
621 #t))))))
622 (native-inputs
623 `(("intltool" ,intltool)
624 ("python-distutils-extra" ,python-distutils-extra)))
625 (inputs
626 `(("libtorrent-rasterbar" ,libtorrent-rasterbar)
627 ("python-dbus" ,python-dbus)
628 ("python-efl" ,python-efl)
629 ("python-pyxdg" ,python-pyxdg)))
630 (home-page "https://www.enlightenment.org")
631 (synopsis "EFL Bittorrent client")
632 (description "Epour is a BitTorrent client based on the @dfn{Enlightenment
633 Foundation Libraries} (EFL) and rb-libtorrent.")
634 (license license:gpl3+)))