gnu: xfce4-appfinder: Update to 4.12.0.
[jackhill/guix/guix.git] / gnu / packages / xfce.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Sou Bunnbu <iyzsong@gmail.com>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages xfce)
21 #:use-module ((guix licenses) #:hide (freetype))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix utils)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system glib-or-gtk)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages gtk)
31 #:use-module (gnu packages xorg)
32 #:use-module (gnu packages xdisorg)
33 #:use-module (gnu packages web)
34 #:use-module (gnu packages fontutils)
35 #:use-module (gnu packages image)
36 #:use-module (gnu packages gnome)
37 #:use-module (gnu packages pdf)
38 #:use-module (gnu packages gstreamer)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages photo)
41 #:use-module (gnu packages pcre))
42
43 (define-public gtk-xfce-engine
44 (package
45 (name "gtk-xfce-engine")
46 (version "3.0.0")
47 (source (origin
48 (method url-fetch)
49 (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
50 name "-" version ".tar.bz2"))
51 (sha256
52 (base32
53 "13c3ajfqkdr6jlqjyhcp4nls0ddanypr83q9qib2ciffik78zq4h"))))
54 (build-system gnu-build-system)
55 (native-inputs
56 `(("pkg-config" ,pkg-config)
57 ("intltool" ,intltool)))
58 (inputs `(("gtk+" ,gtk+-2)))
59 (home-page "http://www.xfce.org/")
60 (synopsis "GTK+ theme engine for Xfce")
61 (description
62 "Default GTK+ engine and themes for Xfce Desktop Environment.")
63 (license gpl2+)))
64
65 (define-public libxfce4util
66 (package
67 (name "libxfce4util")
68 (version "4.12.1")
69 (source (origin
70 (method url-fetch)
71 (uri (string-append "http://archive.xfce.org/xfce/"
72 (version-major+minor version)
73 "/src/" name "-" version ".tar.bz2"))
74 (sha256
75 (base32
76 "07c8r3xwx5is298zk77m3r784gmr5y4mh8bbca5zdjqk5vxdwsw7"))))
77 (build-system gnu-build-system)
78 (native-inputs
79 `(("pkg-config" ,pkg-config)
80 ("intltool" ,intltool)))
81 (propagated-inputs `(("glib" ,glib))) ; required by libxfce4util-1.0.pc
82 (home-page "http://www.xfce.org/")
83 (synopsis "Basic utility library for Xfce")
84 (description
85 "A general-purpose utility library with core application support for the
86 Xfce Desktop Environment.")
87 (license lgpl2.0+)))
88
89 (define-public xfconf
90 (package
91 (name "xfconf")
92 (version "4.10.0")
93 (source (origin
94 (method url-fetch)
95 (uri (string-append "http://archive.xfce.org/xfce/"
96 (version-major+minor version)
97 "/src/" name "-" version ".tar.bz2"))
98 (sha256
99 (base32
100 "0xh520z0qh0ib0ijgnyrgii9h5d4pc53n6mx1chhyzfc86j1jlhp"))))
101 (build-system gnu-build-system)
102 (arguments '(#:parallel-tests? #f)) ; parallel tests failed
103 (native-inputs
104 `(("pkg-config" ,pkg-config)
105 ("intltool" ,intltool)))
106 (propagated-inputs
107 ;; libxfconf-0.pc refers to all these.
108 `(("glib" ,glib)
109 ("dbus" ,dbus)
110 ("dbus-glib" ,dbus-glib)))
111 (inputs
112 `(("libxfce4util" ,libxfce4util)))
113 (home-page "http://www.xfce.org/")
114 (synopsis "Configuration storage and query system for Xfce")
115 (description
116 "Settings daemon for Xfce, implemented as a D-Bus-based configuration
117 storage system.")
118 (license lgpl2.0+)))
119
120 (define-public libxfce4ui
121 (package
122 (name "libxfce4ui")
123 (version "4.12.0")
124 (source (origin
125 (method url-fetch)
126 (uri (string-append "http://archive.xfce.org/xfce/"
127 (version-major+minor version)
128 "/src/" name "-" version ".tar.bz2"))
129 (sha256
130 (base32
131 "11rrhqxnfwx5jls3nlg9s2x8saag9f2zqk9cdm6hr3bs6cr9a781"))))
132 (build-system gnu-build-system)
133 (native-inputs
134 `(("pkg-config" ,pkg-config)
135 ("intltool" ,intltool)))
136 (propagated-inputs
137 ;; libxfce4kbd-private-2.pc refers to all these.
138 `(("gtk+" ,gtk+-2)
139 ("libxfce4util" ,libxfce4util)
140 ("xfconf" ,xfconf)))
141 (inputs `(("libsm" ,libsm)
142 ("libice" ,libice)
143 ("startup-notification" ,startup-notification)))
144 (home-page "http://www.xfce.org/")
145 (synopsis "Widgets library for Xfce")
146 (description
147 "Libxfce4ui is the replacement of the old libxfcegui4 library. It is used
148 to share commonly used Xfce widgets amoung the Xfce applications.")
149 (license lgpl2.0+)))
150
151 (define-public exo
152 (package
153 (name "exo")
154 (version "0.10.3")
155 (source (origin
156 (method url-fetch)
157 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
158 name "-" version ".tar.bz2"))
159 (sha256
160 (base32
161 "1g9651ra395v2fmzb943l68b9pg0rfxc19x97a62crchxwa4nw4m"))))
162 (build-system gnu-build-system)
163 (native-inputs
164 `(("pkg-config" ,pkg-config)
165 ("intltool" ,intltool)))
166 (propagated-inputs
167 ;; exo-1.pc refers to all these.
168 `(("gtk+" ,gtk+-2)
169 ("libxfce4util" ,libxfce4util)))
170 (inputs
171 `(("libxfce4ui" ,libxfce4ui)
172 ("perl-uri" ,perl-uri)))
173 (home-page "http://www.xfce.org/")
174 (synopsis "Extension library for Xfce")
175 (description
176 "An extension library to Xfce. While Xfce comes with quite a few libraries
177 that are targeted at desktop development, libexo is targeted at application
178 development.")
179 ;; Libraries are under LGPLv2+, and programs under GPLv2+.
180 (license (list gpl2+ lgpl2.1+))))
181
182 (define-public garcon
183 (package
184 (name "garcon")
185 (version "0.4.0")
186 (source (origin
187 (method url-fetch)
188 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
189 name "-" version ".tar.bz2"))
190 (sha256
191 (base32
192 "0wm9pjbwq53s3n3nwvsyf0q8lbmhiy2ln3bn5ncihr9vf5cwhzbq"))))
193 (build-system gnu-build-system)
194 (native-inputs
195 `(("pkg-config" ,pkg-config)
196 ("intltool" ,intltool)
197 ("glib:bin" ,glib "bin")))
198 (propagated-inputs
199 `(("libxfce4ui" ,libxfce4ui))) ; required by garcon-gtk2-1.pc
200 (home-page "http://www.xfce.org/")
201 (synopsis "Implementation of the freedesktop.org menu specification")
202 (description
203 "Garcon is a freedesktop.org compliant menu implementation based on
204 GLib and GIO. It was started as a complete rewrite of the former Xfce menu
205 library called libxfce4menu, which, in contrast to garcon, was lacking menu
206 merging features essential for loading menus modified with menu editors.")
207 (license lgpl2.0+)))
208
209 (define-public tumbler
210 (package
211 (name "tumbler")
212 (version "0.1.31")
213 (source (origin
214 (method url-fetch)
215 (uri (string-append "http://archive.xfce.org/src/xfce/tumbler/0.1/"
216 name "-" version ".tar.bz2"))
217 (sha256
218 (base32
219 "0wvip28gm2w061hn84zp2q4dv947ihylrppahn4cjspzff935zfh"))))
220 (build-system gnu-build-system)
221 (native-inputs
222 `(("pkg-config" ,pkg-config)
223 ("intltool" ,intltool)
224 ("glib:bin" ,glib "bin") ; need glib-genmarshal
225 ("dbus-glib" ,dbus-glib))) ; need dbus-binding-tool
226 (propagated-inputs
227 `(("glib" ,glib))) ; required by tumbler-1.pc
228 (inputs
229 `(("dbus" ,dbus)
230 ("gdk-pixbuf" ,gdk-pixbuf)
231 ("freetype" ,freetype)
232 ("libjpeg" ,libjpeg)
233 ("libgsf" ,libgsf)
234 ("poppler" ,poppler)
235 ("gstreamer" ,gstreamer)))
236 (home-page "http://www.xfce.org/")
237 (synopsis "D-Bus service for applications to request thumbnails")
238 (description
239 "Tumbler is a D-Bus service for applications to request thumbnails for
240 various URI schemes and MIME types. It is an implementation of the thumbnail
241 management D-Bus specification.")
242 (license gpl2+)))
243
244 (define-public xfce4-panel
245 (package
246 (name "xfce4-panel")
247 (version "4.12.0")
248 (source (origin
249 (method url-fetch)
250 (uri (string-append "http://archive.xfce.org/xfce/"
251 (version-major+minor version)
252 "/src/" name "-" version ".tar.bz2"))
253 (sha256
254 (base32
255 "1c4p3ckghvsad1sj5v8wmar5mh9cbhail9mmhad2f9pwwb10z4ih"))
256 (patches (list (search-patch "xfce4-panel-plugins.patch")))))
257 (build-system gnu-build-system)
258 (native-inputs
259 `(("pkg-config" ,pkg-config)
260 ("intltool" ,intltool)))
261 (propagated-inputs
262 `(("libxfce4util" ,libxfce4util))) ; required by libxfce4panel-1.0.pc
263 (inputs
264 `(("exo" ,exo)
265 ("garcon", garcon)
266 ("libwnck" ,libwnck-1)
267 ("libxfce4ui" ,libxfce4ui)))
268 (native-search-paths
269 (list (search-path-specification
270 (variable "X_XFCE4_LIB_DIRS")
271 (files '("lib/xfce4")))))
272 (home-page "http://www.xfce.org/")
273 (synopsis "Xfce desktop panel")
274 (description
275 "Desktop panel for Xfce, which contains program launchers, window buttons,
276 applications menu, workspace switcher and more.")
277 ;; Libraries are under LGPLv2.1+, and programs under GPLv2+.
278 (license (list gpl2+ lgpl2.1+))))
279
280 (define-public xfce4-battery-plugin
281 (package
282 (name "xfce4-battery-plugin")
283 (version "1.0.5")
284 (source (origin
285 (method url-fetch)
286 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
287 name "/" (version-major+minor version) "/"
288 name "-" version ".tar.bz2"))
289 (sha256
290 (base32
291 "04gbplcj8z4vg5xbks8cc2jjf62mmf9sdymg90scjwmb82pv2ngn"))))
292 (build-system gnu-build-system)
293 (native-inputs `(("pkg-config" ,pkg-config)
294 ("intltool" ,intltool)))
295 (inputs `(("glib" ,glib)
296 ("gtk+" ,gtk+-2)
297 ("libxfce4util" ,libxfce4util)
298 ("libxfce4ui" ,libxfce4ui)
299 ("xfce4-panel" ,xfce4-panel)))
300 (home-page
301 "http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin")
302 (synopsis "Battery monitor panel plugin for Xfce4")
303 (description
304 "A battery monitor panel plugin for Xfce4, compatible with APM and ACPI.")
305 ;; The main plugin code is covered by gpl2+, but the files containing code
306 ;; to read the battery state via ACPI or APM are covered by lgpl2.0+.
307 (license (list gpl2+ lgpl2.0+))))
308
309 (define-public xfce4-appfinder
310 (package
311 (name "xfce4-appfinder")
312 (version "4.12.0")
313 (source (origin
314 (method url-fetch)
315 (uri (string-append "http://archive.xfce.org/xfce/"
316 (version-major+minor version)
317 "/src/" name "-" version ".tar.bz2"))
318 (sha256
319 (base32
320 "0ry5hin8xhgnkmm9vs7jq8blk1cnbyr0s18nm1j6nsm7360abm1a"))))
321 (build-system gnu-build-system)
322 (native-inputs
323 `(("pkg-config" ,pkg-config)
324 ("intltool" ,intltool)))
325 (inputs
326 `(("garcon" ,garcon)
327 ("libxfce4ui" ,libxfce4ui)))
328 (home-page "http://www.xfce.org/")
329 (synopsis "Xfce application finder")
330 (description
331 "Application finder for Xfce, it will show the applications installed on
332 your system in categories, so you can quickly find and launch them.")
333 (license gpl2+)))
334
335 (define-public xfce4-session
336 (package
337 (name "xfce4-session")
338 (version "4.10.0")
339 (source (origin
340 (method url-fetch)
341 (uri (string-append "http://archive.xfce.org/xfce/"
342 (version-major+minor version)
343 "/src/" name "-" version ".tar.bz2"))
344 (sha256
345 (base32
346 "1kj65jkjhd0ysf0yxsf88wzpyv6n8i8qgd3gb502hf1x9jksk2mv"))))
347 (build-system gnu-build-system)
348 (arguments
349 '(#:configure-flags
350 (list (string-append "--with-xsession-prefix=" %output))))
351 (native-inputs
352 `(("pkg-config" ,pkg-config)
353 ("intltool" ,intltool)))
354 (inputs
355 `(("iceauth" ,iceauth)
356 ("libsm" ,libsm)
357 ("libwnck" ,libwnck-1)
358 ("libxfce4ui" ,libxfce4ui)))
359 (home-page "http://www.xfce.org/")
360 (synopsis "Xfce session manager")
361 (description
362 "Session manager for Xfce, it will restore your session on startup and
363 allows you to shutdown the computer from Xfce.")
364 (license gpl2+)))
365
366 (define-public xfce4-settings
367 (package
368 (name "xfce4-settings")
369 (version "4.10.0")
370 (source (origin
371 (method url-fetch)
372 (uri (string-append "http://archive.xfce.org/xfce/"
373 (version-major+minor version)
374 "/src/" name "-" version ".tar.bz2"))
375 (sha256
376 (base32
377 "0zppq747z9lrxyv5zrrvpalq7hb3gfhy9p7qbldisgv7m6dz0hq8"))))
378 (build-system gnu-build-system)
379 (native-inputs
380 `(("pkg-config" ,pkg-config)
381 ("intltool" ,intltool)))
382 (inputs
383 `(("exo" ,exo)
384 ("garcon" ,garcon)
385 ("libnotify" ,libnotify)
386 ("libxcursor", libxcursor)
387 ("libxi" ,libxi)
388 ("libxrandr" ,libxrandr)
389 ("libxfce4ui" ,libxfce4ui)))
390 (home-page "http://www.xfce.org/")
391 (synopsis "Xfce settings manager")
392 (description
393 "Settings manager for Xfce, it can control various aspects of the desktop
394 like appearance, display, keyboard and mouse settings.")
395 (license gpl2+)))
396
397 (define-public thunar
398 (package
399 (name "thunar")
400 (version "1.4.0")
401 (source (origin
402 (method url-fetch)
403 (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
404 "Thunar-" version ".tar.bz2"))
405 (sha256
406 (base32
407 "1fn8wjzkfvnx2giv3rrg2cyrr2c96f9mskgvcji0ixyfcjga249c"))))
408 (build-system gnu-build-system)
409 (native-inputs
410 `(("pkg-config" ,pkg-config)
411 ("intltool" ,intltool)))
412 (inputs
413 `(("exo" ,exo)
414 ("gudev", eudev)
415 ("libexif" ,libexif)
416 ("libnotify" ,libnotify)
417 ("libxfce4ui" ,libxfce4ui)
418 ("pcre" ,pcre)
419 ("xfce4-panel" ,xfce4-panel)
420 ("startup-notification" ,startup-notification)))
421 (home-page "http://www.xfce.org/")
422 (synopsis "Xfce file manager")
423 (description
424 "A modern file manager for graphical desktop, aiming to be easy-to-use and
425 fast.")
426 (license gpl2+)))
427
428 (define-public thunar-volman
429 (package
430 (name "thunar-volman")
431 (version "0.8.0")
432 (source (origin
433 (method url-fetch)
434 (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
435 name "-" version ".tar.bz2"))
436 (sha256
437 (base32
438 "1sxw09fwyn5sr6ipxk7r8gqjyf41c2v7vkgl0l6mhy5mcb48f27z"))))
439 (build-system gnu-build-system)
440 (native-inputs
441 `(("pkg-config" ,pkg-config)
442 ("intltool" ,intltool)))
443 (inputs
444 `(("exo" ,exo)
445 ("gudev" ,eudev)
446 ("libnotify" ,libnotify)
447 ("libxfce4ui" ,libxfce4ui)))
448 (home-page "http://www.xfce.org/")
449 (synopsis "Removable media manager for Thunar")
450 (description
451 "Thunar-volman is an extension for the Thunar File Manager, which enables
452 automatic management of removable drives and media. For example, if
453 thunar-volman is installed and configured properly, and you plug in your
454 digitcal camera, it will automatically spawn your preferred photo application
455 and import the new pictures from your camera.")
456 (license gpl2+)))
457
458 (define-public xfwm4
459 (package
460 (name "xfwm4")
461 (version "4.10.0")
462 (source (origin
463 (method url-fetch)
464 (uri (string-append "http://archive.xfce.org/xfce/"
465 (version-major+minor version)
466 "/src/" name "-" version ".tar.bz2"))
467 (sha256
468 (base32
469 "170zzs7adj47srsi2cl723w9pl8k8awd7w1bpzxby7hj92zmf8s9"))))
470 (build-system gnu-build-system)
471 (native-inputs
472 `(("pkg-config" ,pkg-config)
473 ("intltool" ,intltool)))
474 (inputs
475 `(("libwnck", libwnck-1)
476 ("libxfce4ui" ,libxfce4ui)
477 ("libxrandr" ,libxrandr)
478 ("libxcomposite" ,libxcomposite)))
479 (home-page "http://www.xfce.org/")
480 (synopsis "Xfce window manager")
481 (description
482 "Window manager for Xfce, it handles the placement of windows
483 on the screen.")
484 (license gpl2+)))
485
486 (define-public xfdesktop
487 (package
488 (name "xfdesktop")
489 (version "4.10.0")
490 (source (origin
491 (method url-fetch)
492 (uri (string-append "http://archive.xfce.org/xfce/"
493 (version-major+minor version)
494 "/src/" name "-" version ".tar.bz2"))
495 (sha256
496 (base32
497 "0yrddj1lgk3xn4w340y89z7x2isks72ia36pka08kk2x8gpfcyl9"))))
498 (build-system gnu-build-system)
499 (native-inputs
500 `(("pkg-config" ,pkg-config)
501 ("intltool" ,intltool)))
502 (inputs
503 `(("exo" ,exo)
504 ("garcon" ,garcon)
505 ("libnotify" ,libnotify)
506 ("libwnck" ,libwnck-1)
507 ("libxfce4ui" ,libxfce4ui)
508 ("thunar" ,thunar)))
509 (home-page "http://www.xfce.org/")
510 (synopsis "Xfce desktop manager")
511 (description
512 "Desktop manager for Xfce, it sets the background color or image with
513 optional application menu or icons for minimized applications or launchers,
514 devices and folders.")
515 (license gpl2+)))
516
517 (define-public xfce4-terminal
518 (package
519 (name "xfce4-terminal")
520 (version "0.6.3")
521 (source (origin
522 (method url-fetch)
523 (uri (string-append "http://archive.xfce.org/src/apps/" name "/"
524 (version-major+minor version) "/"
525 name "-" version ".tar.bz2"))
526 (sha256
527 (base32
528 "023y0lkfijifh05yz8grimxadqpi98mrivr00sl18nirq8b4fbwi"))))
529 (build-system gnu-build-system)
530 (native-inputs
531 `(("pkg-config" ,pkg-config)
532 ("intltool" ,intltool)))
533 (inputs
534 `(("libxfce4ui" ,libxfce4ui)
535 ("vte" ,vte/gtk+-2)))
536 (home-page "http://www.xfce.org/")
537 (synopsis "Xfce terminal emulator")
538 (description
539 "A lightweight and easy to use terminal emulator for Xfce. Features
540 include a simple configuration interface, the ability to use multiple tabs
541 with terminals within a single window, the possibility to have a
542 pseudo-transparent terminal background, and a compact mode (where both the
543 menubar and the window decorations are hidden) that helps you to save space
544 on your desktop.")
545 (license gpl2+)))
546
547 (define-public xfce
548 (package
549 (name "xfce")
550 (version (package-version xfce4-session))
551 (source #f)
552 (build-system glib-or-gtk-build-system)
553 (arguments
554 '(#:modules ((guix build gnu-build-system)
555 (guix build glib-or-gtk-build-system)
556 (guix build utils)
557 (srfi srfi-26))
558 #:imported-modules ((guix build gnu-build-system)
559 (guix build glib-or-gtk-build-system)
560 (guix build utils))
561 #:phases
562 (alist-replace
563 'install
564 (lambda* (#:key outputs #:allow-other-keys)
565 (let* ((out (assoc-ref outputs "out"))
566 (bin (string-append out "/bin"))
567 (prog (string-append bin "/startxfce4")))
568 (mkdir-p bin)
569 (symlink (string-append
570 (assoc-ref %build-inputs "xfce4-session")
571 "/bin/startxfce4")
572 prog)
573 (wrap-program prog
574 ;; For xfce4-panel plugins.
575 `("X_XFCE4_LIB_DIRS" = ,(list (getenv "X_XFCE4_LIB_DIRS"))))))
576 (map (cut assq <> %standard-phases)
577 '(set-paths install glib-or-gtk-wrap)))))
578 (propagated-inputs
579 `(("exo" ,exo)
580 ("garcon" ,garcon)
581 ("gnome-icon-theme" ,gnome-icon-theme)
582 ("gtk-xfce-engine" ,gtk-xfce-engine)
583 ("hicolor-icon-theme" ,hicolor-icon-theme)
584 ("shared-mime-info" ,shared-mime-info)
585 ("thunar" ,thunar)
586 ("thunar-volman" ,thunar-volman)
587 ("tumlber" ,tumbler)
588 ("xfce4-appfinder" ,xfce4-appfinder)
589 ("xfce4-battery-plugin" ,xfce4-battery-plugin)
590 ("xfce4-panel" ,xfce4-panel)
591 ("xfce4-session" ,xfce4-session)
592 ("xfce4-settings" ,xfce4-settings)
593 ("xfce4-terminal" ,xfce4-terminal)
594 ("xfconf" ,xfconf)
595 ("xfdesktop" ,xfdesktop)
596 ("xfwm4" ,xfwm4)))
597 (home-page "http://www.xfce.org/")
598 (synopsis "Desktop environment (meta-package)")
599 (description
600 "Xfce is a lightweight desktop environment. It aims to be fast and low on
601 system resources, while still being visually appealing and user friendly.")
602 (license gpl2+)))