gnu: emacs-scratch-el: Update source and homepage.
[jackhill/guix/guix.git] / gnu / packages / dav.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
3 ;;; Copyright © 2018, 2019, 2022 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
6 ;;; Copyright © 2021 Tanguy Le Carrour <tanguy@bioneland.org>
7 ;;; Copyright © 2022 Jonathan Brielmaier <jonathan.brielmaier@web.de>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages dav)
25 #:use-module (guix build-system python)
26 #:use-module (guix download)
27 #:use-module (guix licenses)
28 #:use-module (guix packages)
29 #:use-module (guix git-download)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages check)
32 #:use-module (gnu packages python)
33 #:use-module (gnu packages python-build)
34 #:use-module (gnu packages python-check)
35 #:use-module (gnu packages python-crypto)
36 #:use-module (gnu packages python-web)
37 #:use-module (gnu packages python-xyz)
38 #:use-module (gnu packages sphinx)
39 #:use-module (gnu packages time)
40 #:use-module (gnu packages xml))
41
42 (define-public radicale
43 (package
44 (name "radicale")
45 (version "3.1.7")
46 (source
47 (origin
48 ;; There are no tests in the PyPI tarball.
49 (method git-fetch)
50 (uri (git-reference
51 (url "https://github.com/Kozea/Radicale")
52 (commit (string-append "v" version))))
53 (file-name (git-file-name name version))
54 (sha256
55 (base32 "1mv1w9qazbis9ir5shr1ybsfn4cxd3rmxa3ns6kbk23yramlzwhg"))))
56 (build-system python-build-system)
57 (arguments
58 (list
59 ;; TODO: enable again when https://github.com/Kozea/Radicale/issues/1184
60 ;; is fixed
61 #:tests? #f))
62 (native-inputs
63 (list python-pytest
64 python-pytest-cov
65 python-pytest-flake8
66 python-pytest-isort
67 python-pytest-runner
68 python-waitress))
69 (propagated-inputs
70 (list python-dateutil python-defusedxml python-passlib
71 python-vobject))
72 (synopsis "Basic CalDAV and CardDAV server")
73 (description "Radicale is a CalDAV and CardDAV server for UNIX-like
74 platforms. Calendars and address books are available for both local and remote
75 access, possibly limited through authentication policies. They can be viewed
76 and edited by calendar and contact clients on mobile phones or computers.
77
78 Radicale intentionally does not fully comply with the CalDAV and CardDAV RFCs.
79 Instead, it supports the CalDAV and CardDAV implementations of popular
80 clients.")
81 (home-page "https://radicale.org/")
82 (license gpl3+)))
83
84 (define-public xandikos
85 (package
86 (name "xandikos")
87 (version "0.2.3")
88 (source
89 (origin
90 (method url-fetch)
91 (uri (pypi-uri "xandikos" version))
92 (sha256
93 (base32 "13ikmcja9p42azb5ccqj2bw98zybna6zlflj10hqy0kvbib70l94"))))
94 (build-system python-build-system)
95 (propagated-inputs
96 (list python-aiohttp
97 python-defusedxml
98 python-dulwich
99 python-icalendar
100 python-jinja2
101 python-multidict))
102 (home-page "https://www.xandikos.org/")
103 (synopsis "Lightweight CalDAV/CardDAV server")
104 (description
105 "Xandikos is a lightweight yet complete CardDAV/CalDAV server that backs
106 onto a Git repository.
107
108 Features:
109
110 @itemize
111 @item Easy to set up
112 @item Share calendars (events, todo items, journal entries) via CalDAV and
113 contacts (vCard) via CardDAV
114 @item Automatically keep history and back up changes in Git
115 @item Supports synchronization extensions for CalDAV/CardDAV for quick and
116 efficient syncing
117 @item Automatically keep history and back up
118 @item Works with all tested CalDAV and CardDAV clients
119 @end itemize")
120 (license gpl3+)))
121
122 (define-public vdirsyncer
123 (package
124 (name "vdirsyncer")
125 ;; When updating, check whether python-click-5 can be removed entirely.
126 (version "0.18.0")
127 (source (origin
128 (method url-fetch)
129 (uri (pypi-uri name version))
130 (sha256
131 (base32
132 "00f2bw1a2jbbd1sbci0swnd67kylr341aa9rpbxkajbp3zakxg17"))))
133 (build-system python-build-system)
134 (arguments
135 `(#:tests? #f ; The test suite is very flakey.
136 #:phases (modify-phases %standard-phases
137 (replace 'check
138 (lambda* (#:key inputs outputs tests? #:allow-other-keys)
139 (add-installed-pythonpath inputs outputs)
140 (setenv "DETERMINISTIC_TESTS" "true")
141 (setenv "DAV_SERVER" "radicale")
142 (setenv "REMOTESTORAGE_SERVER" "skip")
143 (if tests?
144 (invoke "make" "test")
145 #t)))
146 (add-after 'unpack 'patch-version-call
147 (lambda _
148 (substitute* "docs/conf.py"
149 (("^release.*") (string-append "release = '" ,version "'\n")))
150 #t))
151 (add-after 'install 'manpage
152 (lambda* (#:key inputs outputs #:allow-other-keys)
153 (invoke "make" "--directory=docs/" "man")
154 (install-file
155 "docs/_build/man/vdirsyncer.1"
156 (string-append
157 (assoc-ref outputs "out")
158 "/share/man/man1"))
159 #t)))))
160 (native-inputs
161 (list python-setuptools-scm
162 python-sphinx
163 ;; Required for testing
164 python-hypothesis
165 python-pytest
166 python-pytest-localserver
167 python-pytest-subtesthack
168 python-urllib3
169 python-wsgi-intercept
170 radicale))
171 (inputs
172 (list ;; XXX https://github.com/mitsuhiko/click/issues/200
173 python-click-5))
174 (propagated-inputs
175 (list python-atomicwrites python-click-log python-click-threading
176 python-requests-toolbelt))
177 (synopsis "Synchronize calendars and contacts")
178 (description "Vdirsyncer synchronizes your calendars and addressbooks
179 between two storage locations. The most popular purpose is to
180 synchronize a CalDAV or CardDAV server with a local folder or file. The
181 local data can then be accessed via a variety of programs, none of which
182 have to know or worry about syncing to a server.")
183 (home-page "https://github.com/pimutils/vdirsyncer")
184 (license bsd-3)))